Go Back   Team-BHP > Under the Hood > Technical Stuff

Thread Tools Search this Thread
Old 18th July 2007, 12:01   #1
Join Date: May 2006
Location: Mumbai
Posts: 86
Thanked: 29 Times
Default WagonR - Steering feels sticky (EPS)

1) Has a typical problem, MASS can't rectify this after 3 -4 days of trial and testing. The sterring feels to get stuck (sticly feel) at driving and it needs to give some attention while driving. Its NOT free as it was used to be.

What MASS did
a) They got the problem noticed atleast.
b) Removed the entire sterring, checked all Voltage etc of EPS, tried with new stust, replced all washers etc, tried wil each and every piece that is attached with Streering column.
c) Found everything is alright, including the complete EPS assymbly
d) Could not sort that.
e) They can only predit that there are something in the ECM which sends voltage to EPS. Can't get right

This seems very diff driving the same car now. The probelm is not major, BUT the feel of the steering is not that was used to be before, It still feels sticky

Anyone can help me please ...

2) After 2 yr of ownign the Wagon R (After 22,000 KM), at every 6 months (KM run does nto matter), I got a serious noise under front wheel. Every time I compain the Guy as MASS says that its the brake caliper pin noise and he does gressing etc and it world fien for 3 -4 months, again the same issue.

He has also suggested me to replace the caliper pin now that I am doing. I does nto drive this car much , but still this is a typical WagonR probelm it seems. Its doen 42k KM now.

Pl advice.
vipul_bscity is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hyundai Xcent / Grand i10 EPS issue: Steering suddenly becomes 'loose' RVVSatya Technical Stuff 42 25th July 2016 13:54
Honda City - Steering Rack Assembly (EPS) vipul_bscity Technical Stuff 6 5th May 2013 19:28
Retrofitting an EPS viper Technical Stuff 13 10th April 2008 08:54
Help - Steering feels underpowered for my Swift abhaybakshi Technical Stuff 3 7th March 2007 12:04
Swift no more with eps? hari_rama The Indian Car Scene 18 25th February 2007 12:46

All times are GMT +5.5. The time now is 13:39.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks