Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 29th July 2007, 14:20   #1
BHPian
 
Join Date: Sep 2006
Location: Bangalore
Posts: 157
Thanked: 27 Times
Default maruti wagonr knocking

Experts,

This is for my co brother's WagonR ( petrol model). Problem is

while on higher ( relatively) gear, if he has to downshift, he experiences knocking after releasing the clutch (after the downshift). The other problem he faces is the vehicle needs to go further than the normal rpms to shift to the next higher gear. for example if he was able to shift to fifth gear from fourth at 40 kph , now the same can be done only at 50kph.

He could feel the drop in power throughout the drive but they are more evident and uncomfortable during gearshifts.

He had experienced the same problem about an year ago and the service center guys said that it was a problem with ignitor and had it replaced. The same problem has come up again

Has any WagonR owners or other petrol car owners experienced the same problem? IF so, what was done to rectify this?

-tortoise
tortoise is offline   Reply With Quote
Old 29th July 2007, 14:44   #2
Distinguished - BHPian
 
CrAzY dRiVeR's Avatar
 
Join Date: Jun 2006
Location: Bangalore / TVM
Posts: 8,974
Thanked: 16,771 Times
Default

You mean, the problem occured recently?

Sure petrol is of good quality? Guess you could also try cleaning the air filter.
CrAzY dRiVeR is offline   Reply With Quote
Old 11th December 2007, 17:33   #3
BHPian
 
Join Date: Nov 2007
Location: Bangalore
Posts: 38
Thanked: 2 Times
Default

I was searching a thread that has a solution to the experience posted by @tortoise. Can someone suggest a solution here.
aby.sam is offline   Reply With Quote
Old 11th December 2007, 19:59   #4
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,752
Thanked: 7,476 Times
Default

what exactly you want to know aby?

Is it exact same as tortoise mentioned?
Jaggu is offline   Reply With Quote
Old 11th December 2007, 21:39   #5
BHPian
 
yasw_anth's Avatar
 
Join Date: Oct 2006
Location: Chennai
Posts: 101
Thanked: 0 Times
Default

i was having the same problem in my zen 2003 mpfi but my engine turns off and sometimes knocking...before few days the mechanic said the fault was with the ignition wires so got it cleaned but problem still persisted. yesterday the problem came again and i got the spark plugs replaced.i think the problem has been fixed.
previously i was using iridium spark plugs but got them changed to champion plugs yesterday..
yasw_anth is offline   Reply With Quote
Old 12th December 2007, 07:46   #6
Senior - BHPian
 
vigsom's Avatar
 
Join Date: Feb 2006
Location: AUH<->MAA
Posts: 1,722
Thanked: 581 Times
Default The Knocker

Quote:
Originally Posted by tortoise View Post
Experts,

This is for my co brother's WagonR ( petrol model). Problem is

while on higher ( relatively) gear, if he has to downshift, he experiences knocking after releasing the clutch (after the downshift). The other problem he faces is the vehicle needs to go further than the normal rpms to shift to the next higher gear. for example if he was able to shift to fifth gear from fourth at 40 kph , now the same can be done only at 50kph.

He could feel the drop in power throughout the drive but they are more evident and uncomfortable during gearshifts.

He had experienced the same problem about an year ago and the service center guys said that it was a problem with ignitor and had it replaced. The same problem has come up again

Has any WagonR owners or other petrol car owners experienced the same problem? IF so, what was done to rectify this?

-tortoise
1.Has engine oil been changed religiously as recommended?(every10k kms)
2.How many kms has the car done?

My Fears:
1.It appears that the engine's compression is a tad weak.
2.The ignition timing I do not suspect this much as the WagonR has distributorless ignition.
vigsom is offline   Reply With Quote
Old 12th December 2007, 10:08   #7
BANNED
 
Join Date: May 2006
Location: Mumbai ( Borivali )
Posts: 328
Thanked: 0 Times
Default

Get the spark plug clean ,,, problem shd get solved !
nicejits is offline   Reply With Quote
Old 13th December 2007, 15:32   #8
BHPian
 
Join Date: Nov 2007
Location: Bangalore
Posts: 38
Thanked: 2 Times
Default

Thanks everyone for reply.
My WagonR has done just 4k kms. Its done its 2nd service in 1st week of Oct. Its not yet time to change the engine oil.
I fill only from Shell (so hope there is no adulteration)
Their is knocking and miss even while accelerating in all the gears. (probably less noticed in 1st gear)
Could that be due to tuning that happened during the 2nd service.
aby.sam is offline   Reply With Quote
Old 13th December 2007, 16:50   #9
Senior - BHPian
 
vigsom's Avatar
 
Join Date: Feb 2006
Location: AUH<->MAA
Posts: 1,722
Thanked: 581 Times
Default Knock..Knock

Quote:
Originally Posted by aby.sam View Post
Thanks everyone for reply.
My WagonR has done just 4k kms. Its done its 2nd service in 1st week of Oct. Its not yet time to change the engine oil.
I fill only from Shell (so hope there is no adulteration)
Their is knocking and miss even while accelerating in all the gears. (probably less noticed in 1st gear)
Could that be due to tuning that happened during the 2nd service.
If it is only 4k kms,then there is some problem with the vehicle's tuning/ignition timing.Please have this checked.
vigsom is offline   Reply With Quote
Old 13th December 2007, 17:46   #10
Senior - BHPian
 
snaronikar's Avatar
 
Join Date: Jun 2007
Location: Bengaluru
Posts: 2,845
Thanked: 23 Times
Default

Spark plugs/Air fliter..might be the culprits. Try tpo clean them and change if possible. BTW, how does your co-brother drive?
snaronikar is offline   Reply With Quote
Old 13th December 2007, 19:56   #11
BHPian
 
breezydrive's Avatar
 
Join Date: Aug 2007
Location: NOIDA
Posts: 709
Thanked: 68 Times
Default

Quote:
Originally Posted by yasw_anth View Post
i was having the same problem in my zen 2003 mpfi but my engine turns off and sometimes knocking...before few days the mechanic said the fault was with the ignition wires so got it cleaned but problem still persisted. yesterday the problem came again and i got the spark plugs replaced.i think the problem has been fixed.
previously i was using iridium spark plugs but got them changed to champion plugs yesterday..
Have your car's engine shrudder vanished completely, which you had mentioned in the thread by me?
breezydrive is offline   Reply With Quote
Old 14th December 2007, 16:06   #12
BHPian
 
chetans's Avatar
 
Join Date: Sep 2007
Location: Pune
Posts: 227
Thanked: 73 Times
Default

have recently bought wagonr.
have been facing 2 problems.
1. after the 1st service, i see that engine is knocking, when moving from 2nd to higher gears. though i rev engine it seems like petrol supply is cut-off.

2. while in traffic, on hitting brake, car moves backwards. maybe because the road is inclined backwards. but if i continuosly hold brake, car shouldnt move at all?
chetans is offline   Reply With Quote
Old 14th December 2007, 20:34   #13
Distinguished - BHPian
 
CrAzY dRiVeR's Avatar
 
Join Date: Jun 2006
Location: Bangalore / TVM
Posts: 8,974
Thanked: 16,771 Times
Default

Quote:
Originally Posted by chetans View Post
2. while in traffic, on hitting brake, car moves backwards. maybe because the road is inclined backwards. but if i continuosly hold brake, car shouldnt move at all?
With the engine off, the car may move unless you press it hard. this is because of the hydraulic system.

However, it SHOULDN'T move with brake pressed when the engine is on. If so, get it checked.
CrAzY dRiVeR is offline   Reply With Quote
Old 15th December 2007, 18:41   #14
BHPian
 
Join Date: May 2007
Location: Navi Mumbai
Posts: 184
Thanked: 46 Times
Default

Quote:
Originally Posted by aby.sam View Post
Thanks everyone for reply.
My WagonR has done just 4k kms. Its done its 2nd service in 1st week of Oct. Its not yet time to change the engine oil.
I fill only from Shell (so hope there is no adulteration)
Their is knocking and miss even while accelerating in all the gears. (probably less noticed in 1st gear)
Could that be due to tuning that happened during the 2nd service.
@aby.sam,
I too faced exactly the same problem with my petrol Wagon R, and coincidentaly at 4K kms.
The techn at maruti service center replaced the ignitor rod...ofcourse free of cost (under warranty) and now the problem has disappeared. So just get it checked before suspecting any other engine problem.
anuragn is offline   Reply With Quote
Old 17th December 2007, 11:35   #15
BHPian
 
Join Date: Nov 2007
Location: Bangalore
Posts: 38
Thanked: 2 Times
Default

[quote=anuragn;658793The techn at maruti service center replaced the ignitor rod...ofcourse free of cost (under warranty) and now the problem has disappeared. So just get it checked before suspecting any other engine problem.[/quote]

I had been to Solar automobiles, St. Johns road. The technicians took the vehicle for a test drive and confirmed a problem of knocking (jerking). He too replaced the ignitor and it works well now.
Suspect this to be a common problem with all WagonR's. All those who face this issue, pl get them checked so that u replace it under warranty period. Service was really good at Solar. They serviced my vehicle for free though I didn't ask for it.
aby.sam is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
WagonR knocking at lower RPMs ravi@64bhp Technical Stuff 20 6th February 2017 18:24
Maruti WagonR over Hyundai Eon? EDIT : Bought WagonR with ABS / Airbags BoneCollector Hatchbacks 35 22nd May 2015 11:49
Only a WagonR can replace a WagonR ! From F10D to K10B.. DCEite Test-Drives & Initial Ownership Reports 27 19th April 2014 23:02
WagonR or Swift?(calling swift and wagonR owners) rajshenoy Hatchbacks 43 29th March 2007 09:54


All times are GMT +5.5. The time now is 05:08.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks