Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 4th August 2007, 00:07   #1
BHPian
 
jalsa777's Avatar
 
Join Date: May 2006
Location: Mumbai
Posts: 637
Thanked: 1,044 Times
Question screwed up injectors in palio

i have a palio 1.2, 50k kms.

2 days ago, while driving, the engine light started glowing on the dash...
i thought it might again be mice eating away some wires.

gave the car to the workshop and they say the injectors need to be replaced.

now, how would all injectors malfunction all-of-a-sudden ??

i wanna know what causes injectors to malfunction and why whould it happen at only 50k kms ??
jalsa777 is offline   Reply With Quote
Old 4th August 2007, 10:54   #2
BANNED
 
viper's Avatar
 
Join Date: Mar 2005
Location: Mumbai
Posts: 1,769
Thanked: 8 Times
Default

Hi,
In all possibilities they are taking you for a ride. Is the car jerking or pick up dropped or what symptoms do you have. Is it only the light showing up.

Viper
viper is offline   Reply With Quote
Old 4th August 2007, 11:34   #3
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,748
Thanked: 7,462 Times
Default

Is there any change in the way engine performs? Idle or Running ? If NO, please do get a second opinion before you proceed.

Also did they say all the injectors?? thats highly unlikely.
Jaggu is online now   Reply With Quote
Old 4th August 2007, 11:39   #4
BHPian
 
wolfinstein's Avatar
 
Join Date: Feb 2006
Location: New Delhi
Posts: 994
Thanked: 14 Times
Default

Try Cleaning the injectors, it will cost you around 100-150 per Injector, at the same time get the Fuel Pump, Fuel Lines, Fuel Filter checked and replaced if required.

Clear the Error codes, and The most Imp thing, Always remove the injectors after you disconnect the Battery.

Should solve it most likely.
wolfinstein is offline   Reply With Quote
Old 4th August 2007, 21:07   #5
BHPian
 
jalsa777's Avatar
 
Join Date: May 2006
Location: Mumbai
Posts: 637
Thanked: 1,044 Times
Default

the car is jerking really badly....at idle it feels as if it its going to stall.....

the pickup, even an m80 will be faster...

i got the injector cleaned, but the problem remained
jalsa777 is offline   Reply With Quote
Old 4th August 2007, 21:09   #6
BHPian
 
jalsa777's Avatar
 
Join Date: May 2006
Location: Mumbai
Posts: 637
Thanked: 1,044 Times
Default

Quote:
Originally Posted by Jaggu View Post

Also did they say all the injectors?? thats highly unlikely.
yeah ....all

thts what is worrying me....one part going wrong and one can understand....all of them....its crazy
jalsa777 is offline   Reply With Quote
Old 4th August 2007, 21:13   #7
BHPian
 
FERRO's Avatar
 
Join Date: May 2007
Location: Mumbai
Posts: 313
Thanked: 0 Times
Default

make sure u dont buy those Injectors for Rs.4500 from the A.S.S. I know a place where u can get new 1.2 or 1.6 Fiat injectors for 1300-1500 max.
FERRO is offline   Reply With Quote
Old 4th August 2007, 23:49   #8
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,748
Thanked: 7,462 Times
Default

This sounds like a clogged injector issue.

But first ensure you are sure of "which" injector is faulty, inspecting one injector at a time. Also clean the complete fuel line and tank once you do the injector cleaning.

Cleaning most of the times help, if not you will have to replace, usually one injector unit cost aroun 6-8 k.

Last edited by Jaggu : 4th August 2007 at 23:50.
Jaggu is online now   Reply With Quote
Old 5th August 2007, 10:38   #9
BHPian
 
wolfinstein's Avatar
 
Join Date: Feb 2006
Location: New Delhi
Posts: 994
Thanked: 14 Times
Default

Check the fuel pump, and fuel line, and also the Spark plugs before you decide on the Replacement.

Another good option will be to get in touch with Bosch India, they make FI for most cars, maybe you can source them or find a good dealer.

Highly unlikely for all to fail at the same time.
wolfinstein is offline   Reply With Quote
Old 5th August 2007, 11:21   #10
Senior - BHPian
 
merve_extreme's Avatar
 
Join Date: Apr 2004
Location: Mumbai
Posts: 1,360
Thanked: 12 Times
Default

if it is not your injectors,check your ignition coil.they are known to malfuntion often.tell them to put your ignition coil on another 1.2 and check it,because the ignition coild failure is sometimes not reported by the scanner.
merve_extreme is offline   Reply With Quote
Old 5th August 2007, 11:34   #11
BHPian
 
warchild's Avatar
 
Join Date: Oct 2006
Location: Bangalore (Metropolis de motorheads)
Posts: 62
Thanked: Once
Default

Quote:
Originally Posted by jalsa777 View Post
the engine light started glowing on the dash...
....they say the injectors need to be replaced.
... even i faced a similar problem. i had to replace only one of the injectors . make sure u get a second opinion before ya replace all of em!

Quote:
Originally Posted by FERRO View Post
I know a place where u can get new 1.2 or 1.6 Fiat injectors for 1300-1500 max.
ferro this place sells only injectors or other parts of fiat too?
warchild is offline   Reply With Quote
Old 5th August 2007, 12:57   #12
BHPian
 
jalsa777's Avatar
 
Join Date: May 2006
Location: Mumbai
Posts: 637
Thanked: 1,044 Times
Default

thanks ferro and all....

i have told the fiat guys to not replace the injectors.....those shaman auto guys always want to replace everything....i'll take the car to my mechanic and then clean and check all that is mentioned in the above posts...
will update you'll with what happens
jalsa777 is offline   Reply With Quote
Old 5th August 2007, 12:58   #13
BHPian
 
jalsa777's Avatar
 
Join Date: May 2006
Location: Mumbai
Posts: 637
Thanked: 1,044 Times
Default

also, ever heard of coolent getting rusted??

....my car was idle for a month and the damn coolent got rusted
jalsa777 is offline   Reply With Quote
Old 5th August 2007, 13:44   #14
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,748
Thanked: 7,462 Times
Default

ohh so car was idle also, ok so should be one of the injectors, i faced the same issue with the iKON. Mine only one injector went bad, it was not getting fully closed and small leak into the common rail played havoc.

Remove the connector to the injector one at a time, if the idle becomes ok while doing this you can pin point which injector is faulty.

Regarding coolant, it can happen. Do radiator/coolant flush and fill with new coolant.
Jaggu is online now   Reply With Quote
Old 5th August 2007, 14:15   #15
BHPian
 
2fast4u's Avatar
 
Join Date: Mar 2005
Location: pune / Bahrain
Posts: 488
Thanked: 5 Times
Default

probably a fuel gelled problem due to non usage.

ask ur mech to check for pulse of injector

jaggu@ all can fail if sugar is added to fuel.
2fast4u is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
I think I Screwed up my Swift suspension! Need Help! Spartan Technical Stuff 28 29th April 2009 21:23
Auto Fusion screwed up my Alpine nirmalts Modifications & Accessories 6 30th October 2007 20:52
Starting problems-Injectors just cleaned,engine flushed rahul_intlad Technical Stuff 16 9th February 2007 12:07
How to check if Fuel Injectors are alright? extreme_torque Technical Stuff 4 28th July 2006 10:00
Fuel Injectors Added to an Indian Bike? srikantans04 Motorbikes 3 15th June 2006 19:01


All times are GMT +5.5. The time now is 15:42.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks