Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 12th September 2007, 17:07   #1
BHPian
 
kapilsharma80's Avatar
 
Join Date: Jul 2007
Location: Chandigarh
Posts: 177
Thanked: 25 Times
Default palio 1.2 nv 'pressure sensor error and water pump issue'

Lately theres a strange 'ktrr ktrr' sound coming from the car's engine. The frequency of sound increases with the the speed. its not loud and could only be heard when the bonnet is open. The temprature needle also touches the half mark when the car is neutral (this happens when i have done about 4-5 kms of driving) but comes back to 1/4th mark while in motion. Dont know whats happening.

I hope the pistons are alright.

The car has done 5 thousand kms. The car has been serviced once and the next service/oil change is due in december.

I took the car for a check up today.
the ecu analyser showed an 'intermittent error in the pressure sensor' , which the service guy deleted through the computer. I hope its not a seious problem.

The service guy said that the 'kkrr kkrr' sound is coming from the 'water pump'or a bearing connected to the timing belt.
They did not have both and ordered from mumbai. Will let you know once i visit the work shop next weekend.

your comments please!!
kapilsharma80 is offline   Reply With Quote
Old 15th September 2007, 09:27   #2
Senior - BHPian
 
Join Date: Sep 2007
Location: New Delhi
Posts: 3,083
Thanked: 252 Times
Default

Kapil, if you could be a little clearer in your description of the problem, some people might try to help. Your first para is confusing, regarding the temperature.
The ECU showing 'error in PRESSURE sensor' with fault being temperature, etc.. is all too confusing.
The noise could be from some bearing (usually ball bearings are used) in the belt path - water pump, alternator, idler pulleys etc..
Perhaps that is why there is no response from anyone.......
And why on earth are you doubting your pistons?!
anupmathur is offline   Reply With Quote
Old 17th September 2007, 10:15   #3
BHPian
 
kapilsharma80's Avatar
 
Join Date: Jul 2007
Location: Chandigarh
Posts: 177
Thanked: 25 Times
Default

Anup,

I will try to be clear this time.

Problem 1 -

The temp neddle touches the half way mark sometimes when the air conditioner is not on or switched off after usage. I recently topped up the the coolent also ('Puroguard manufactured by Anand').

When i park the car overnight or for long, the coolant marks on the pavement can be seen. the mark is 2 inch in diametre.


Problem 2 -

As i mentioned before, the ECU analyser showed an intermittent error in the pressure sensor. I have no clue as to what is the function of the pressure sensor.

Problem 3 -

There is a strange nose around the engine. the service guys pointed out that the fault is either with the water pump or a bearing.
kapilsharma80 is offline   Reply With Quote
Old 17th September 2007, 13:35   #4
BHPian
 
rishibravo's Avatar
 
Join Date: Jul 2006
Location: New Delhi
Posts: 579
Thanked: 6 Times
Default

Firstly your coolant is leaking. Get it rectified. And hope its from the L-point and not from any of the waterplugs . The L-point leakage can be rectified in an hour or so but if its leaking from the waterplugs its half a days job coz they might have to down your gearbox.

Is the car under warrently. If it is then insist on getting the faulty parts replaced immediately. Clearing the error wont cause any problem . If there is a problem with the pressure sensor then the error will pop again.

Last edited by rishibravo : 17th September 2007 at 13:37.
rishibravo is offline   Reply With Quote
Old 17th September 2007, 15:44   #5
BHPian
 
kapilsharma80's Avatar
 
Join Date: Jul 2007
Location: Chandigarh
Posts: 177
Thanked: 25 Times
Default

Rishi, thanks for the advice.

yes, the car is under warranty. Will go to the work shop in couple of days time and let you know the leak point.

Would you please point out as to what kind of problems can an error in pressure sensor cause!
kapilsharma80 is offline   Reply With Quote
Old 17th September 2007, 17:58   #6
Senior - BHPian
 
Join Date: Sep 2007
Location: New Delhi
Posts: 3,083
Thanked: 252 Times
Default

Kapil, if your car is in warranty, do take a tough stand and have these issues sorted out. Fiat are not known for good service; expect to make a bit of a scene!
The coolant should not leak ONE DROP after overnight parking.
The noise from the engine MUST go.
The pressure sensor error would be hard to rectify till your car shows some 'symptoms'. If you can get them to show it again on the Analyzer, ask that the same test be done on another similar vehicle at the garage. If that one shows no error then you better insist that the concerned sensor be replaced in your car under warranty. And do WRITE COMMENTS on the delivery note after the service or repair call. This could come in handy later on if something turns out to be amiss.
Good luck and keep us posted.
anupmathur is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tyre pressure gauge and portable inflator pump / foot pump adityapd Modifications & Accessories 698 29th November 2017 16:38
Pioneer Head Unit Errors. Error 11 and error 17 in pioneer MP3 rajivanoj In-Car Entertainment 32 10th December 2013 17:07
Major error in Autocar March issue & Overdrive April issue as well Guna Shifting gears 20 11th May 2010 11:15
Cam Sensor-Crank Sensor-TDC Sensor. Are They The Same Thing? genesis Technical Stuff 8 5th October 2009 11:17
Palio 1.2 Nv pressure sensor problem kapilsharma80 Technical Stuff 0 21st September 2007 11:04


All times are GMT +5.5. The time now is 04:52.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks