Go Back   Team-BHP > Under the Hood > Technical Stuff

Thread Tools Search this Thread
Old 1st October 2007, 00:10   #16
mclaren1885's Avatar
Join Date: Jul 2005
Location: Bangalore (the city of modded cars) !!
Posts: 4,821
Thanked: 27 Times
Infractions: 0/1 (10)

Mohnish, my understanding of "limp mode" is when the ECU limits the characteristics of the engine and drops power drastically or doesn't allow you to rev past 3500 rpm (or whatever the rpm set by a manufac). None of this happened when my EGR or O2 sensor were disconnected. IIRC, the O2 sensor on your car too had conked off but I remember you telling me that there was no drop in performance except that your car gave really low FE.

I am quite sure that there was no drop in performance or that the ECU did not send the car into "limp mode" as per my understanding. If you still have doubts, you might want to get the same clarified with psycho. Or maybe wait till someone like Rdkarthik can clarify this. Because I was told by psycho that there was no harm in running with the O2 not connected.

I also know that you guys are far more technically sound than I am. I am just reporting what I saw with my own eyes over a period of 3 months (the time during which I ran with the MIL light on). So pardon my ignorance & do correct me if I am wrong. I am here to learn, maybe if you are right that could have been one of the primary reasons for the cause of concern on my car. And the reason for the rebuilds. But I would like to make sure before I take a stand on this.
mclaren1885 is offline   Reply With Quote
Old 21st October 2007, 07:22   #17
Senior - BHPian
rr_zen's Avatar
Join Date: Sep 2006
Location: Chennai, India
Posts: 1,692
Thanked: 237 Times

I had the engine oil replaced for my Honda Civic yesterday and have driven about 10 miles since the oil was replaced. Today, I started the car and the check engine light came on a few seconds later. I am planning to take it back to the service station tomorrow. What could be the problem ? I have read in the above posts that the light comes on if the engine oil has not been changed for a long time but my scenario here seems to be exactly the opposite.
rr_zen is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
MIL Light glows while running on CNG in Honda city rajeevpatel Technical Stuff 15 29th August 2012 20:55
Chevrolet, Man Utd in 25 mil pounds/season deal DukeNukem The International Automotive Scene 5 7th August 2012 11:28
Matiz : Jerks and MIL lamp ON Tawwa Technical Stuff 6 9th July 2008 12:39
E-Zen & B-Zen.... MustangMan The Indian Car Scene 3 2nd July 2005 21:27

All times are GMT +5.5. The time now is 23:17.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks