Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 2nd February 2010, 23:12   #526
jav
BHPian
 
Join Date: Apr 2007
Location: Bangalore
Posts: 193
Thanked: 5 Times
Default

Quote:
Originally Posted by adityamunshi View Post
There is a strange problem in my DLS 2004 done 85 K Kms on the odo. The engine cranks fine but refuses to start, if it starts there is idle fluctuation and it dies with 5-10 secs. Even push starting does not help, the engine starts for half a sec and then dies. What could be the problem ? Should i take the car to Lucas or TASC ?
I remember having this problem once, in my case it was air the the fuel system since i had loosened the small plastic knobs at the base of the diesel filter but forgot to tighten them back

Last edited by jav : 2nd February 2010 at 23:13.
jav is offline   Reply With Quote
Old 5th February 2010, 13:39   #527
BHPian
 
Join Date: Feb 2007
Location: Bangalore
Posts: 87
Thanked: 5 Times
Default

I have Indica DLG run 52K. Until now i have not faced any major issues and use it daily for 100 KMS. Today i noticed that their is leak of oil in left rear wheel. The shock is oily and very little oil was spill on the floor. Anyone can tell me the problem.
I will be taking it to the service station tomorrow. I think it may be the break fluid leakage. Had taken it for long drive to Madakeri, some patches of the road was horrible.
srinivasmhn is offline   Reply With Quote
Old 6th February 2010, 00:32   #528
BHPian
 
kcj3b's Avatar
 
Join Date: Feb 2009
Location: New Delhi
Posts: 137
Thanked: 50 Times
Default

Quote:
Originally Posted by srinivasmhn View Post
I have Indica DLG run 52K. Until now i have not faced any major issues and use it daily for 100 KMS. Today i noticed that their is leak of oil in left rear wheel. The shock is oily and very little oil was spill on the floor. Anyone can tell me the problem.
I will be taking it to the service station tomorrow. I think it may be the break fluid leakage. Had taken it for long drive to Madakeri, some patches of the road was horrible.

The shocker strut has given away, leaking all the way down
kcj3b is offline   Reply With Quote
Old 17th February 2010, 15:37   #529
BHPian
 
dr.faramroze's Avatar
 
Join Date: Aug 2009
Location: Valsad/Mumbai
Posts: 151
Thanked: 11 Times
Default

I got an Indica V2 Lsi (2004), from my friend, which has clocked 42000kms. This is my latest upgrade for highway driving after getting rid of my 1999 M-800.

When I bought the car, there was a missing problem, changed the ignition HT cables myself, costing Rs 1050 at Borivali. The car became normal and I have driven it for around 4000 kms now in 18 days.

I found the steering a little wobly over small patches of broken roads. Got the front suspension opened, personally checked all the linkages, ball joints, lower arm, balance rod. The mechanic said there is a need to replace both front struts. He dislantled the springs and showed me that the inner hydraulic cylinder was not retracting upwards and it cannot be serviced, no oil topup. There is no leakage in the front or rear suspension. I wonder, how can a strut give up in such a low mileage.

I am aware that Indica suspension is hard and coarse, but its way better than the Maruti 800. Can anyone tell me why do I hear a thud from two of the wheels when I stumble over a pothole? The thud sound is also felt in the rear.

There is no other niggle in the condition of this car. The ignition, ecu, throttle, gearbox and other parts are working fine. I get a fuel return of 12kmpl in city and 16kmpl on highway, without AC, highways mostly in 5th gear at constant 80kmph.

Also there is a slight vibration which is only felt for about 2-3 seconds at in the range of 30 kmph to 40kmph in the third gear.

Spending Rs 2800 per strut is not a problem, but the suspension should improve.

Friends please give your suggestions. Thank you all in advance.

Last edited by dr.faramroze : 17th February 2010 at 15:40. Reason: left incomplete
dr.faramroze is offline   Reply With Quote
Old 17th February 2010, 17:36   #530
Senior - BHPian
 
mercedised's Avatar
 
Join Date: Nov 2009
Location: Indore
Posts: 1,061
Thanked: 155 Times
Default

Quote:
Originally Posted by dr.faramroze View Post
I got an Indica V2 Lsi (2004), from my friend, which has clocked 42000kms. This is my latest upgrade for highway driving after getting rid of my 1999 M-800.

When I bought the car, there was a missing problem, changed the ignition HT cables myself, costing Rs 1050 at Borivali. The car became normal and I have driven it for around 4000 kms now in 18 days.

I found the steering a little wobly over small patches of broken roads. Got the front suspension opened, personally checked all the linkages, ball joints, lower arm, balance rod. The mechanic said there is a need to replace both front struts. He dislantled the springs and showed me that the inner hydraulic cylinder was not retracting upwards and it cannot be serviced, no oil topup. There is no leakage in the front or rear suspension. I wonder, how can a strut give up in such a low mileage.

I am aware that Indica suspension is hard and coarse, but its way better than the Maruti 800. Can anyone tell me why do I hear a thud from two of the wheels when I stumble over a pothole? The thud sound is also felt in the rear.

There is no other niggle in the condition of this car. The ignition, ecu, throttle, gearbox and other parts are working fine. I get a fuel return of 12kmpl in city and 16kmpl on highway, without AC, highways mostly in 5th gear at constant 80kmph.

Also there is a slight vibration which is only felt for about 2-3 seconds at in the range of 30 kmph to 40kmph in the third gear.

Spending Rs 2800 per strut is not a problem, but the suspension should improve.

Friends please give your suggestions. Thank you all in advance.

There will bw some sort of issues with the car being Tata. I too own a Tata Indica 1999 which has done morethan 1,30000kms and happily giving me an mileage of 23kmpl(on my very recent trip of 2500kms)
and 19kmpl in cities. I donot know why you are getting such low mileage.
mercedised is offline   Reply With Quote
Old 17th February 2010, 18:35   #531
Senior - BHPian
 
kiku007's Avatar
 
Join Date: Apr 2005
Location: Brisbane
Posts: 1,593
Thanked: 1,178 Times
Default

Took my Uncle's Indica Dicor (2006/2007) for a Madurai-Munnar-Madurai trip (450 Kms)

Before starting about the issues let me record that the car offers max power and space for min bucks!

Issues:
1. At times the car moves fast even after lifting off the throttle. RPM shotting up for no reason?
2. NOISY. Extremelly noisy engine
3. It wasn't possible to move the seat belts at times. They tend to lock in their position like we are pulling it hard. Due to this we had to try multiple times very slowly to buckle up and since they lock up and didn't move at all, we ended up with mild bruises on the chest/shoulder.
4. Car rattles a lot:( It's not the parcel tray.
5. Some strange rubbing noise comes when driving over 100 Kms/hour and taking a very very small turn. Say for eg. overtaking a car. Or taking a hair pin bend at much lesser speeds at times.
kiku007 is offline   Reply With Quote
Old 17th February 2010, 20:04   #532
BHPian
 
dr.faramroze's Avatar
 
Join Date: Aug 2009
Location: Valsad/Mumbai
Posts: 151
Thanked: 11 Times
Default

sirs, my car is petrol, as i have mentioned lsi above. To my knowledge 1.4 L petrol Indicas give less average.
dr.faramroze is offline   Reply With Quote
Old 17th February 2010, 20:34   #533
BHPian
 
yogeshnaik's Avatar
 
Join Date: Dec 2009
Location: Bangalore
Posts: 311
Thanked: 40 Times
Default

Are there any Indica V2 with 1.4L petrol engines? It must be TDi 1.4L. Indica with petrol is always 1.2L.
yogeshnaik is offline   Reply With Quote
Old 17th February 2010, 20:40   #534
Senior - BHPian
 
Gilead's Avatar
 
Join Date: May 2009
Location: Chennai
Posts: 2,140
Thanked: 20 Times
Default

Quote:
Originally Posted by yogeshnaik View Post
Are there any Indica V2 with 1.4L petrol engines? It must be TDi 1.4L. Indica with petrol is always 1.2L.
I had a Indica V2 with a 1.4L petrol engine. Bought it in 2002. Complete piece of junk. When I finally managed to get rid of it, all I could afford to buy was an 800. Then they re-branded it as Xeta and launched it with a 1.2L engine.

Last edited by Gilead : 17th February 2010 at 20:45.
Gilead is offline   Reply With Quote
Old 17th February 2010, 21:40   #535
BHPian
 
dr.faramroze's Avatar
 
Join Date: Aug 2009
Location: Valsad/Mumbai
Posts: 151
Thanked: 11 Times
Default

And now if we adjust to the truth that I have an Indica thats petrol, can anyone help me with the suspension problem?
dr.faramroze is offline   Reply With Quote
Old 22nd February 2010, 23:36   #536
BHPian
 
kcj3b's Avatar
 
Join Date: Feb 2009
Location: New Delhi
Posts: 137
Thanked: 50 Times
Default

Quote:
Originally Posted by dr.faramroze View Post
And now if we adjust to the truth that I have an Indica thats petrol, can anyone help me with the suspension problem?

Hi,
Indica's front suspension is very prone to damages so are the Rims.

The Rims are purposely build such that they such bend and absord shocks and hence saving the suspension , this is biggest reasons why a Tyre Up size is somewhat needed in Indica.

The only thing that gives away are the struts, mine are too at the end of life cycle at 48k on the odo.although strut servicing is possible and is very popular thanks to indicab!
Once my suspension in front in unbearable , i will upsize and change the struts together!
kcj3b is offline   Reply With Quote
Old 25th February 2010, 05:02   #537
Newbie
 
Join Date: Nov 2008
Location: Bangalore
Posts: 9
Thanked: 0 Times
Default Indica DLG Blues

I have a serious issue with my Indica DLG 2007 model. It has run 25K now and here is a serious problem now:

- The check engine light is on forever
- The head light goes bright and dull intermittently
- Rpm goes 1050 at idle and engine makes lot of noise
- No pickup in second or third gear at times. The car refuses to pull. I get her a gear down and back and it seems ok.
- AC blowing fast and slow automatically
- Audio system going silent in between.

Need help. What's going crazy?
sp33d is offline   Reply With Quote
Old 25th February 2010, 09:54   #538
BHPian
 
dkamath's Avatar
 
Join Date: May 2006
Location: Bangalore
Posts: 540
Thanked: 74 Times
Default

Hi, firstly, the following thread suits your issue http://www.team-bhp.com/forum/techni...-problems.html (Tata Indica - List of problems)

The issue doesn't look to be as serious as you mention. Please get the alternator belt tension adjusted. If that doesn't solve the problem, the alternator might need an overhaul. Just my thoughts on what could possibly be wrong, while we wait for experts to reply.
dkamath is offline   Reply With Quote
Old 25th February 2010, 10:14   #539
jav
BHPian
 
Join Date: Apr 2007
Location: Bangalore
Posts: 193
Thanked: 5 Times
Default

Hi

please get the alternator regulator looked at, i am pretty sure it is malfunctioning making voltage output more than normal which causes the lights to go bright and drop in pickup.

happened to my car as well, my regulator output was 20+volts and the max should be around 14.5v

Last edited by jav : 25th February 2010 at 10:17.
jav is offline   Reply With Quote
Old 25th February 2010, 10:35   #540
BHPian
 
Join Date: Jan 2010
Location: bangalore
Posts: 36
Thanked: Once
Default

I suggest you can get your battery plates checked, even i have faced a similar kind of an issue with my 2007 model DLX. The stock battery was gone only after two years and i got it replaced in 2009 with a new one.
kites is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Indica Vista - list of Known problems greenhorn Technical Stuff 1418 20th June 2017 17:13
Tata Manza - List Of Problems jkdas Technical Stuff 188 4th January 2017 14:01
Tata Indica Vista- Technical Specifications & Feature List Stratos Technical Stuff 2 24th June 2011 19:47
Tata Indica V2 DLS customized vs Tata Indica V2 DLX karikrishni Hatchbacks 20 12th November 2009 10:59


All times are GMT +5.5. The time now is 17:36.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks