Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
LinkBack Thread Tools Search this Thread
Old 20th March 2008, 19:10   #91
Senior - BHPian
 
rkbharat's Avatar
 
Join Date: Sep 2006
Location: Gurgaon/New Delhi
Posts: 1,570
Thanked: 512 Times
Default

Quote:
Originally Posted by adityamunshi View Post
Im planning to buy an Amaron black 60AH battery. Price is 4100 minus 550 for old battery.

Is 60AH enough or do i need 65AH ?
60Ah is enough, also price quoted is fine if its for 1.5 Yr warranty + 1.5 yrs limited warranty
rkbharat is offline   Reply With Quote

Old 20th March 2008, 19:35   #92
BHPian
 
adityamunshi's Avatar
 
Join Date: May 2007
Location: Baroda
Posts: 769
Thanked: 2 Times
Default

Actually Amaron Black has 18 months replacement warranty.
I decided not to spend more and get Amaron Go (18+18 , Rs. 5350 - 550) because im going to sell off this car in the coming year.

Quote:
Originally Posted by rkbharat View Post
60Ah is enough, also price quoted is fine if its for 1.5 Yr warranty + 1.5 yrs limited warranty
adityamunshi is offline   Reply With Quote
Old 20th March 2008, 19:46   #93
Senior - BHPian
 
rkbharat's Avatar
 
Join Date: Sep 2006
Location: Gurgaon/New Delhi
Posts: 1,570
Thanked: 512 Times
Default

ok than the price is high. I bought Amaron Green, 18+18 for 3800 Rs(after 500Rs for old battery).

Quote:
Originally Posted by adityamunshi View Post
Actually Amaron Black has 18 months replacement warranty.
I decided not to spend more and get Amaron Go (18+18 , Rs. 5350 - 550) because im going to sell off this car in the coming year.
rkbharat is offline   Reply With Quote
Old 26th March 2008, 22:27   #94
BHPian
 
anonymous's Avatar
 
Join Date: Jan 2007
Location: NCR
Posts: 562
Thanked: 14 Times
Default

Quote:
Originally Posted by anonymous View Post
The RPM niddle went down to zero. The car was still running, I changed the gear and niddle went up again after this I drove around 50 KM and kept an eye on RPM Meter but it would not happen again. Again I drove around 150 KM but the RPM never came down below 1000.
Quote:
Originally Posted by anonymous View Post
Ok. The RPM Meter just died, while the car was running and battery light came on. The car was still running fine. I stopped the car, restarted it again but same situation, so I decided to go to TASS. The car was still in same condition and after around 200 meter, the battery light went off and RPM niddle started dancing.
TASS guys told me that it could be Radiator problem (The car has clocked 80K so far)
Quote:
Originally Posted by Zappo View Post
At 80k+ it could only mean your alternator is on the verge of packing up. Do get this thing checked before it conks permanently and leaves you stranded.
Quote:
Originally Posted by tsk1979 View Post
This could be the problem with the mechanism which powers the RPM meter. Why assume the worst. Or it can be a case of bad fuses or relays etc.
Ok. Finally it was the alternator. Got it changed. Cost was around 11K. Have driven almost 500 Km and issue has not come up again.
anonymous is offline   Reply With Quote
Old 26th March 2008, 23:46   #95
BHPian
 
Join Date: Nov 2005
Location: Chennai
Posts: 29
Thanked: 0 Times
Default

hmm Dictionary term:
Indica = Full of Problems

i have practically seen many people cursing over getting a indica but still quantity wins in india not quality.
one guy visible crided in front of the mechanic stating that "i would have better bought two dane and feed them up " this happened to prior to the release of V2
a.ashokdurai is offline   Reply With Quote
Old 27th March 2008, 08:05   #96
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 20,059
Thanked: 9,085 Times
Default

Quote:
Originally Posted by anonymous View Post
Ok. Finally it was the alternator. Got it changed. Cost was around 11K. Have driven almost 500 Km and issue has not come up again.
11K? Lucas TVS indica alternator is 8.5K with 1 year warranty. Did TASS give you the one year warranty with the alternator?
tsk1979 is offline   Reply With Quote
Old 27th March 2008, 09:36   #97
Senior - BHPian
 
rkbharat's Avatar
 
Join Date: Sep 2006
Location: Gurgaon/New Delhi
Posts: 1,570
Thanked: 512 Times
Default

Quote:
Originally Posted by anonymous View Post
Ok. Finally it was the alternator. Got it changed. Cost was around 11K. Have driven almost 500 Km and issue has not come up again.
I think price is on the higher side. You could have gone to Lucas's Jhandewalan office and got the work done there. Thats saves lots of labor charges from TASC and all profit margins from TASC.
rkbharat is offline   Reply With Quote
Old 27th March 2008, 14:04   #98
BHPian
 
anonymous's Avatar
 
Join Date: Jan 2007
Location: NCR
Posts: 562
Thanked: 14 Times
Default

Quote:
Originally Posted by tsk1979 View Post
11K? Lucas TVS indica alternator is 8.5K with 1 year warranty. Did TASS give you the one year warranty with the alternator?
Yup. Got 1 year warranty with the new one.

Quote:
Originally Posted by rkbharat View Post
I think price is on the higher side. You could have gone to Lucas's Jhandewalan office and got the work done there. Thats saves lots of labor charges from TASC and all profit margins from TASC.
Labor charges were only 350 Rs. Alternator price could be on higher side but as always, I had a very long trip planned on the next day and I had no time to be in any local workshop for this, so had no option but to get this done from TASS.
anonymous is offline   Reply With Quote
Old 27th March 2008, 14:10   #99
BHPian
 
adityamunshi's Avatar
 
Join Date: May 2007
Location: Baroda
Posts: 769
Thanked: 2 Times
Default

Bought Amaron Black 60AH for 3500 incl all discounts. All starting problems gone
adityamunshi is offline   Reply With Quote
Old 7th April 2008, 19:20   #100
Senior - BHPian
 
rkbharat's Avatar
 
Join Date: Sep 2006
Location: Gurgaon/New Delhi
Posts: 1,570
Thanked: 512 Times
Unhappy Radiator fan fuse blown twice

I had Radiator Fan Fuse blown twice in 3 days. Never happened this in last 6 years and 95000KM.

First time its was just a blown fuse. but second time its blown and melted as well.

I have replaced the fuse with new one but nothing has happened in last 100km.

Electrician at TASC told me that radiator fan needs replacement if fuse blows twice. Which is bit wiered.

Any help guys?
rkbharat is offline   Reply With Quote
Old 7th April 2008, 21:01   #101
BHPian
 
wolfinstein's Avatar
 
Join Date: Feb 2006
Location: New Delhi
Posts: 994
Thanked: 12 Times
Default

I think, the second fuse was defective-Should not be a problem now-However suggest you have the Electrical system checked with the Volt Meter-Load On and Load Off.

I once had a similar situation where my OEM Rear Lamp Bulb fused out, and the replacement din't last a day-Got it changed again for Free-Its been lighting the Night for the last 8 months.
wolfinstein is offline   Reply With Quote
Old 8th April 2008, 09:56   #102
Senior - BHPian
 
rkbharat's Avatar
 
Join Date: Sep 2006
Location: Gurgaon/New Delhi
Posts: 1,570
Thanked: 512 Times
Default

I took both the fuse from TASC at the same time. I am planning to get the load of radiator fan checked.

Quote:
Originally Posted by wolfinstein View Post
I think, the second fuse was defective-Should not be a problem now-However suggest you have the Electrical system checked with the Volt Meter-Load On and Load Off.

I once had a similar situation where my OEM Rear Lamp Bulb fused out, and the replacement din't last a day-Got it changed again for Free-Its been lighting the Night for the last 8 months.
rkbharat is offline   Reply With Quote
Old 8th April 2008, 12:03   #103
BHPian
 
Join Date: Mar 2008
Location: Hyderabad
Posts: 614
Thanked: 95 Times
Default

The squealing while braking may be due to the disc...the problem may be rectified if the disc is sand papered/ground. Also, check the hardness of the pads.
simplyself is offline   Reply With Quote
Old 28th April 2008, 22:38   #104
Newbie
 
Join Date: Mar 2008
Location: Mumbai
Posts: 14
Thanked: 0 Times
Default

Radiator fan in my Cielo starts whenever I start my Cielo(195000 km) even in morning. What is remedy ?. Fuse is OK. Also its rpm looks much higher when idling. There is no problem in running. Radiator fan relay also heats up. What should I do ? Thermostate T below distributor has also been checked by multimeter.
Magnan is offline   Reply With Quote
Old 30th April 2008, 16:28   #105
BHPian
 
adityamunshi's Avatar
 
Join Date: May 2007
Location: Baroda
Posts: 769
Thanked: 2 Times
Default

My indica seems to be losing power in the afternoons when its very hot. Is this normal ?
adityamunshi is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tata Manza - List Of Problems jkdas Technical Stuff 130 9th October 2014 10:27
Indica Vista - list of Known problems greenhorn Technical Stuff 1330 21st August 2014 20:33
Tata Indica eV2- Technical Specifications & Feature List Stratos Technical Stuff 4 10th August 2011 14:11
Tata Indica Vista- Technical Specifications & Feature List Stratos Technical Stuff 2 24th June 2011 19:47


All times are GMT +5.5. The time now is 00:03.

Copyright 2000 - 2014, Team-BHP.com
Proudly powered by E2E Networks