Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 4th January 2008, 22:03   #1
Newbie
 
Join Date: Dec 2007
Location: Mumbai
Posts: 11
Thanked: 0 Times
Default Esteem MPFI engine too fast

Hi
Friends, i own a 2001 model MPFI esteem VX...i ve jus bought it recently
the cars running fine but thers one small problem..
ocassionally wen u start the car the rpm goes up to 1k or more wen in neutral n stays ther..so while drivin if u leave the accel 2 ..the car keeps movin ahead wid good enuf speed..which cn b dangerous in traffic..
somtimes this is gone wen i restart my car..wid everythn becomin normal n rpm remainin less than 1k in neutral..i ve shown it to a couple of mechanics who did some tuning n said it ws done..bt while driving i steel feel that the engine is fast...plz help me out as to what i cn do..

thnx

Note from the Team-BHP Support Staff : Slang and SMS Language are STRICTLY prohibited on Team-BHP. Please type in full and proper English for the benefit of other community members.

We advise you to read the Announcements and Board Rules section before proceeding any further.

Last edited by DCEite : 5th January 2008 at 20:34. Reason: See note.
schumi2508 is offline   Reply With Quote Received Infraction
Old 5th January 2008, 20:19   #2
BHPian
 
wolfinstein's Avatar
 
Join Date: Feb 2006
Location: New Delhi
Posts: 994
Thanked: 14 Times
Default

Check the Throttle, clean if required...I think the adjustment of the Throttle valve needs to be done.
wolfinstein is offline   Reply With Quote
Old 5th January 2008, 20:56   #3
BHPian
 
yasw_anth's Avatar
 
Join Date: Oct 2006
Location: Chennai
Posts: 101
Thanked: 0 Times
Default

had same problem in my zen till yesterday.got the throttle body cleaned today and that solved
yasw_anth is offline   Reply With Quote
Old 5th January 2008, 21:24   #4
BHPian
 
Join Date: Jul 2007
Location: Bangalore
Posts: 448
Thanked: 33 Times
Default

actually, today even i noticed the same problem in my 3 months old esteem. When i cold start the car, the rpm goes to 1500. then after a min settles down to 900+
I guess got to get it checked next time i go for service.

Regards,
amohit is offline   Reply With Quote
Old 5th January 2008, 21:54   #5
Team-BHP Support
 
Akshay1234's Avatar
 
Join Date: Dec 2006
Location: Mumbai
Posts: 9,759
Thanked: 6,668 Times
Default

Quote:
Originally Posted by amohit View Post
actually, today even i noticed the same problem in my 3 months old esteem. When i cold start the car, the rpm goes to 1500. then after a min settles down to 900+
I guess got to get it checked next time i go for service.

Regards,
thats not a problem. it would be high when you cold start a car so that it warms up quickly. after warming up it settles back down.
Akshay1234 is online now   Reply With Quote
Old 5th January 2008, 22:30   #6
Senior - BHPian
 
esteem_lover's Avatar
 
Join Date: Jul 2006
Location: Madras/Py
Posts: 7,554
Thanked: 445 Times
Default

Quote:
Originally Posted by amohit View Post
actually, today even i noticed the same problem in my 3 months old esteem. When i cold start the car, the rpm goes to 1500. then after a min settles down to 900+
I guess got to get it checked next time i go for service.

Regards,

This is not a problem at all. All mpfi engines are set like that. In cold starts, they tend to idle at higher rpms & settle down to 900 rpm after a while whereas a carb engine can be made to idle even at 500-600 rpm, please do not compare these two.
esteem_lover is offline   Reply With Quote
Old 6th January 2008, 20:50   #7
BHPian
 
kjdesigns_2000's Avatar
 
Join Date: Dec 2006
Location: Gurgaon
Posts: 159
Thanked: 0 Times
Default

Quote:
Originally Posted by amohit View Post
actually, today even i noticed the same problem in my 3 months old esteem. When i cold start the car, the rpm goes to 1500. then after a min settles down to 900+
I guess got to get it checked next time i go for service.

Regards,
It is all controlled by the ECU. Till the engine has reached a certain revs or maybe temp it will stay there. But after a very short drive it gets settled down. Nothing to worry here, its normal.
kjdesigns_2000 is offline   Reply With Quote
Old 6th January 2008, 21:16   #8
Senior - BHPian
 
snaronikar's Avatar
 
Join Date: Jun 2007
Location: Bengaluru
Posts: 2,845
Thanked: 23 Times
Default

As others has put it, this is not a problem at all. Even my previous Wagon R was behaving the same way and now the Ikon is also same. This is the normal idling rpm when cold started. It settles down after about 5~10 mins running. Hence do not worry about this.
snaronikar is offline   Reply With Quote
Old 6th January 2008, 22:17   #9
BHPian
 
Join Date: Jul 2007
Location: Bangalore
Posts: 448
Thanked: 33 Times
Default

oh thank god!
all this time I had started thinking i'm wasting extra few ml of Shell Super every time I start my baby

Regards,
amohit is offline   Reply With Quote
Old 7th January 2008, 10:09   #10
Senior - BHPian
 
amit_mechengg's Avatar
 
Join Date: Dec 2007
Location: Pune
Posts: 2,406
Thanked: 1,539 Times
Default

dont worry guys. its very normal and delibrate.for every cold start all car that are ecu controlled have a concept of auto choke wherein a very rich mixture is injected to avoid dry run and to get that initial temp quickly. this settles within 5-15 sec depending on engine temp the sensors sense.
amit_mechengg is offline   Reply With Quote
Old 7th January 2008, 12:10   #11
Senior - BHPian
 
vnabhi's Avatar
 
Join Date: May 2007
Location: DC -> DC
Posts: 5,269
Thanked: 1,234 Times
Default

Quote:
Originally Posted by snaronikar View Post
As others has put it, this is not a problem at all. Even my previous Wagon R was behaving the same way and now the Ikon is also same. This is the normal idling rpm when cold started. It settles down after about 5~10 mins running. Hence do not worry about this.
I agree. Even my petrol Fiesta has similar traits.
vnabhi is offline   Reply With Quote
Old 7th January 2008, 15:37   #12
BHPian
 
Join Date: Jan 2006
Location: Gurgaon
Posts: 213
Thanked: 61 Times
Default check the coolant valve.

Hi,

There is valve for the coolant at the connector that connects the coolant hose to the engine. The valve may be bad not closing or may have been removed as mechanics remove it if it is not working properly. I have the same issue on my esteem it was overheating as the valve was bad so i removed it but havent found the time to look for the missing valve. The valve stops the coolant flow when it is not needed. You may also find that the car is taking more time to warm up than normal that is due to excess coolant flowing through the engine.
bhogalrajnish is offline   Reply With Quote
Old 9th January 2008, 19:57   #13
BHPian
 
Join Date: Dec 2007
Location: mumbai
Posts: 38
Thanked: 6 Times
Default

Quote:
Originally Posted by schumi2508 View Post
Hi
Friends, i own a 2001 model MPFI esteem VX...i ve jus bought it recently
the cars running fine but thers one small problem..
ocassionally wen u start the car the rpm goes up to 1k or more wen in neutral n stays ther..so while drivin if u leave the accel 2 ..the car keeps movin ahead wid good enuf speed..which cn b dangerous in traffic..
somtimes this is gone wen i restart my car..wid everythn becomin normal n rpm remainin less than 1k in neutral..i ve shown it to a couple of mechanics who did some tuning n said it ws done..bt while driving i steel feel that the engine is fast...plz help me out as to what i cn do..

thnx

Note from the Team-BHP Support Staff : Slang and SMS Language are STRICTLY prohibited on Team-BHP. Please type in full and proper English for the benefit of other community members.

We advise you to read the Announcements and Board Rules section before proceeding any further.
hello
CHECK UR IDEAL CONTROLL VALVE
armotosport is offline   Reply With Quote
Old 8th February 2008, 14:44   #14
Senior - BHPian
 
Psycho's Avatar
 
Join Date: Jul 2004
Location: Bangalore
Posts: 1,042
Thanked: 95 Times
Default

This is common with 2001 model esteems the rpm comes down when the engine heats up.
Psycho is offline   Reply With Quote
Old 8th February 2008, 18:20   #15
BHPian
 
Join Date: Dec 2007
Location: PATNA
Posts: 35
Thanked: 4 Times
Default Esteem High Idling Rpm

HI, please take ur car to a authorised workshop and ask them to do a rpm control test by a tech2 diagnostic equipment. If the engine does not respond to the comand of tech2 gradualy and responds with jerks then it is time to replace the I.A.C valve,no wonder how much u try to clean the throtle body will not help. Actualy in this rpm test the I.A.C duty is changed tmporarily to which the engine response should be linear.
Quote:
Originally Posted by schumi2508 View Post
Hi
Friends, i own a 2001 model MPFI esteem VX...i ve jus bought it recently
the cars running fine but thers one small problem..
ocassionally wen u start the car the rpm goes up to 1k or more wen in neutral n stays ther..so while drivin if u leave the accel 2 ..the car keeps movin ahead wid good enuf speed..which cn b dangerous in traffic..
somtimes this is gone wen i restart my car..wid everythn becomin normal n rpm remainin less than 1k in neutral..i ve shown it to a couple of mechanics who did some tuning n said it ws done..bt while driving i steel feel that the engine is fast...plz help me out as to what i cn do..

thnx

Note from the Team-BHP Support Staff : Slang and SMS Language are STRICTLY prohibited on Team-BHP. Please type in full and proper English for the benefit of other community members.

We advise you to read the Announcements and Board Rules section before proceeding any further.
alankarmotor is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fast and Furious 5 : "Fast Five" Cyrus43 Shifting gears 19 18th December 2011 18:53
Fast and Furious: Fast 5 is on its way vinayvtec Shifting gears 1 8th October 2010 14:45
Esteem fuel pump(mpfi) in esteem-carb tank techn0l0gist Technical Stuff 0 13th June 2009 22:03
How fast....How fast? sri Street Experiences 10 16th July 2007 18:58
too fast too furious MODS amitverma Modifications & Accessories 16 10th March 2005 20:31


All times are GMT +5.5. The time now is 03:10.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks