Go Back   Team-BHP > Under the Hood > Technical Stuff

Thread Tools Search this Thread
Old 25th March 2008, 17:55   #31
johy's Avatar
Join Date: Mar 2006
Location: Siliguri
Posts: 826
Thanked: 362 Times
Exclamation Sluggish car : Related problem?

Originally Posted by johy View Post
2) The car feels heavier than before - needs more accelerator to reach the same speeds. This is especially noticeable on gears 2 and 3. On the 2nd and 3th gears especially, feels like something is "stopping" or "pulling back" the car.
Hi folks,

I am reposting on this thread because somehow I feel my new problem might be related to the old one.

As some of you may remember, the MUL dealer changed my gear lever assembly and after that my problems went away. Yes, as I mentioned before, the car felt sluggish, but they retuned the engine and it was fine. Mileage was not affected - giving me 14.5 kmpl, mixed traffic conditions with the AC on all the time.

Today, however, when driving back home, I suddenly found the car suddenly go sluggish. The AC was on and only two people in the car (including me) and it felt like there were 15 people on board. Accelerator pedal felt very heavy. Stopped the AC, a little less sluggish, but still very sluggish. Pulled over. Stopped engine. Restarted engine after around 30 seconds and came back home driving slowly, but still sluggish. Could this be related?

Last edited by johy : 25th March 2008 at 17:59.
johy is offline   Reply With Quote
Old 25th March 2008, 18:29   #32
Team-BHP Support
Jaggu's Avatar
Join Date: May 2004
Location: Bangalore
Posts: 16,592
Thanked: 4,800 Times

I would suggest you do a good tune up job, air filter, fuel filter, plugs and check the throttle body. This should fix the issue.
Jaggu is offline   Reply With Quote
Old 25th March 2008, 19:01   #33
Senior - BHPian
shajufx's Avatar
Join Date: Apr 2007
Location: BLR & Muscat
Posts: 1,506
Thanked: 210 Times

WagonRs generally have slugglish gear box and it is commented by 90% of the owners. Most of gear related issues are handled by the dealer workshop directly. I remember my issue was not properly attended by the Nexus service centre in bangalore, they asked me to leave the car with them, so that they can take it to the RNS (dealer) workshop. Which means, dealer workshops are equipped with trouble shooting and solving facilities.

New generation WagonR has minor issues compared to the Euro II batches as I understand from my dealer service executive. I had very bad gear issue for the first 6 months of usage. Shifting from 1st to 2nd and 4th to 5th and reverse used to be a real pain for the shoulders. Although I was supposed to do some major gear box repairs at the dealer, I never got time, so left it as it is. Now after 1 year of usage (only 3800 kms so far), gear issue seems to be gone by itself.

As Jaggu suggested, please execute the tuning, cleaning and checking of engine, air filter, fuel filter etc. Please update after that, curiously waiting to hear the progress.
shajufx is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Switch off / Park in first gear or neutral? devnull Technical Stuff 49 18th December 2015 16:57
Swift Diesel moving ahead in Neutral Gear Racer_X Technical Stuff 44 16th April 2012 23:19
Scorpio MHawk-5th Gear Slips to Neutral akshay4587 Technical Stuff 15 16th December 2011 00:02
Santro gear shifts suddenly into neutral nura Technical Stuff 18 11th August 2008 14:21
Re: Gear "jumping" to neutral??? johy Technical Stuff 9 9th November 2006 21:45

All times are GMT +5.5. The time now is 13:08.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks