Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 19th January 2008, 06:31   #1
BHPian
 
Join Date: Nov 2007
Location: Delhi
Posts: 62
Thanked: 0 Times
Default Facing problem with Getz ignition

Hi people.. my getz is 15 days old but i am facing a problem with its ignition. When i turn my ignition and after thet turn the key further to start the vehicle its doesnt start, neither it make amy noise. Jst i case my audio system is on it goes of as usual for 4-5 seconds as it use to in case of a normal start.
What might be the reason?? I face this problem 5-6 time still now.
The highest number of times that it gives me a missed start till now is 2 times.
wmax is offline   Reply With Quote
Old 19th January 2008, 09:09   #2
Senior - BHPian
 
DirtyDan's Avatar
 
Join Date: Jul 2007
Location: Dharamsala
Posts: 1,798
Thanked: 745 Times
Default Ignition switch

The ignition switch may be bad, the thing where you put the key in and turn. Do you have many keys on your key chain? Sometimes the weight of many keys can make the switch lose contact. Try it with just the ignition key only and see if it works. But if it does your switch is still suspect. If that is not it then you may have a wiring problem, maybe a disconnect by the starter motor. Take it back to the dealer and have him find the problem and fix it.
DirtyDan is offline   Reply With Quote
Old 19th January 2008, 09:21   #3
BHPian
 
Join Date: Mar 2005
Location: goa
Posts: 981
Thanked: 43 Times
Default

Quote:
Originally Posted by wmax View Post
Hi people.. my getz is 15 days old but i am facing a problem with its ignition. When i turn my ignition and after thet turn the key further to start the vehicle its doesnt start, neither it make amy noise. Jst i case my audio system is on it goes of as usual for 4-5 seconds as it use to in case of a normal start.
What might be the reason?? I face this problem 5-6 time still now.
The highest number of times that it gives me a missed start till now is 2 times.
Maybe you know this, but in the Getz, you need to press the clutch fully before ignition will fire. Have you been doing this?
filcord is offline   Reply With Quote
Old 19th January 2008, 12:42   #4
GTO
Team-BHP Support
 
GTO's Avatar
 
Join Date: Feb 2004
Location: Bombay
Posts: 47,758
Thanked: 89,450 Times
Default

Quote:
Maybe you know this, but in the Getz, you need to press the clutch fully before ignition will fire. Have you been doing this?
Exactly what I thought of! The clutch pedal needs to be pressed fully; it is a safety regulation from the United States.
GTO is offline   Reply With Quote
Old 19th January 2008, 19:23   #5
Senior - BHPian
 
ramie2400's Avatar
 
Join Date: Nov 2006
Location: Mumbai
Posts: 1,900
Thanked: 58 Times
Default

I own a new getz prime 1,3L,you need to press full clutch before ignition even while starting if you try to release,it will fail to start(as tried on a demo car )its suerly one of the best system in Getz,i like the clutch start thing.

Ramie
ramie2400 is offline   Reply With Quote
Old 20th January 2008, 02:33   #6
BHPian
 
Join Date: Nov 2007
Location: Delhi
Posts: 62
Thanked: 0 Times
Default

Quote:
Originally Posted by GTO View Post
Exactly what I thought of! The clutch pedal needs to be pressed fully; it is a safety regulation from the United States.
I always press the clutch pedal fully while starting. I have talked to the dealer and he says there might be a problem with the ignition and he will check and fix it well i havent got time to visit him tho..

i guess its a wiring problem..
wmax is offline   Reply With Quote
Old 13th February 2008, 12:58   #7
BHPian
 
Join Date: Mar 2005
Location: goa
Posts: 981
Thanked: 43 Times
Default

Hi Mate, has your problem been solved and what was it due to?
filcord is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Front facing Vs Rear facing Vs Side facing seats in MUVs/SUVs ritz830 The Indian Car Scene 20 11th July 2009 16:55
Help!! Alto facing a weird vibration problem wanderluster The Indian Car Scene 0 8th September 2007 01:15
facing problem in my accord. prateek Technical Stuff 39 17th June 2007 12:34
facing problem with my turbo setup. prateek Technical Stuff 6 2nd June 2007 00:46
Facing a problem in Palio 1.2 engine amitverma Technical Stuff 18 24th April 2006 09:06


All times are GMT +5.5. The time now is 19:47.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks