Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 11th February 2008, 16:38   #1
BHPian
 
Join Date: Apr 2004
Location: New Delhi
Posts: 152
Thanked: 2 Times
Default Getz problem - Revving on its own ?

Guys,
Strange experience yesterday.
Was driving my Getz (1.3), stopped to buy some medicines. Started the engine again and it was revving on its own from 1500 Rpm to 2500 Rpm. First thought may be accelerator was stuck or ?? But it was fine. Shut down the engine and started again but same result. Tried opening the bonnet but did not open, heard some strange noise from bonnet. I was close to my place so finally parked the car and took my Zen. I again tried after couple of hours but car still behaved the same.

Any idea what could be the problem ? It was running fine the whole day the suddenly this after a brief stop ?

Tarun.
Tarun is offline   Reply With Quote
Old 11th February 2008, 16:42   #2
Senior - BHPian
 
snaronikar's Avatar
 
Join Date: Jun 2007
Location: Bengaluru
Posts: 2,845
Thanked: 23 Times
Default

Was it a cold start by any chance. Usually, high revvs will happen when the car is started after keeping idle for some time.
snaronikar is offline   Reply With Quote
Old 11th February 2008, 16:50   #3
BHPian
 
Join Date: Apr 2004
Location: New Delhi
Posts: 152
Thanked: 2 Times
Default

Nope the car already had run for about 10 kms that day.
Besides, i generally wait for about a minute for first start of the day before moving.

Tarun.
Tarun is offline   Reply With Quote
Old 11th February 2008, 16:52   #4
BHPian
 
Join Date: Sep 2007
Location: Bangalore
Posts: 119
Thanked: 2 Times
Default

My earlier car (Santro) got this problem once. My bro got it serviced and the car was fine afterwards. AFAIK, the problem was with the throttle play. Sorry, don't have more details since I was out of town for many months at that time and also it was quite a few years back.


If high rev is present all the time, I would suggest the obvious - getting it checked with the service station. If it's a one-off event, perhaps you can wait till next service to bring it up.
sreenidhibr is offline   Reply With Quote
Old 11th February 2008, 23:33   #5
Senior - BHPian
 
ramie2400's Avatar
 
Join Date: Nov 2006
Location: Mumbai
Posts: 1,900
Thanked: 58 Times
Default

My getz when i cold start in the morning it revv's to 1200+ RPM and the comes down automatically to somewhere 800-900rpm.. i think its pretty normal as my Ikon and the city also used to do the same
ramie2400 is offline   Reply With Quote
Old 12th February 2008, 02:54   #6
BANNED
 
hellspawn's Avatar
 
Join Date: Jul 2005
Location: noida
Posts: 1,686
Thanked: 6 Times
Infractions: 0/1 (10)
Default

get the getz's throttle body cleaned...
hellspawn is offline   Reply With Quote
Old 12th February 2008, 09:55   #7
Senior - BHPian
 
Join Date: Sep 2006
Location: Melbourne, Hyd
Posts: 1,235
Thanked: 23 Times
Default

My 2 wheeler if started with the choke, the rpm raises from 1000 to 3500. Since modern cars run on FI, there could be a similar thing which can not be turned of yourself. take it to the workshop.
kkr2k2 is offline   Reply With Quote
Old 12th February 2008, 10:25   #8
GTO
Team-BHP Support
 
GTO's Avatar
 
Join Date: Feb 2004
Location: Bombay
Posts: 47,749
Thanked: 89,386 Times
Default

My Vtec had the same problem. Cleaning the throttle body and air-filter solved the problem.
GTO is offline   Reply With Quote
Old 12th February 2008, 10:59   #9
Senior - BHPian
 
PatienceWins's Avatar
 
Join Date: May 2007
Location: Bangalore
Posts: 2,157
Thanked: 261 Times
Default

Quote:
Originally Posted by ramie2400 View Post
My getz when i cold start in the morning it revv's to 1200+ RPM and the comes down automatically to somewhere 800-900rpm.. i think its pretty normal as my Ikon and the city also used to do the same
Yes. Thats exactly the behaviour of Getz on cold start.

I always do not wait until the rpm comes to 800 rpm. It takes around 5-7 minutes.Usually, I wait for 2 minutes and drive the car on 2nd gear without throttle for sometime. This way the rpm comes down fast without much strain on the engine.

Last edited by PatienceWins : 12th February 2008 at 11:01.
PatienceWins is offline   Reply With Quote
Old 12th February 2008, 11:14   #10
BANNED
 
viper's Avatar
 
Join Date: Mar 2005
Location: Mumbai
Posts: 1,769
Thanked: 8 Times
Default

Quote:
Originally Posted by Tarun View Post
Tried opening the bonnet but did not open, heard some strange noise from bonnet.Any idea what could be the problem ? It was running fine the whole day the suddenly this after a brief stop ?

Tarun.
Hi,

Did you manage to get the bonnet open. From what you describe it is likely that there is something fouling with the accelerator cable. What did you see find when you opened the bonnet. A dirty throttle will not make any noises as you described or cause your bonnet not to open.

Viper
viper is offline   Reply With Quote
Old 12th February 2008, 11:30   #11
Team-BHP Support
 
benbsb29's Avatar
 
Join Date: Nov 2006
Location: Brisbane
Posts: 8,025
Thanked: 3,482 Times
Default

Quote:
Originally Posted by GTO View Post
My Vtec had the same problem. Cleaning the throttle body and air-filter solved the problem.
Tarun, this is the remedy you should be looking at. Get the throttle body cleaned.
benbsb29 is online now   Reply With Quote
Old 12th February 2008, 19:17   #12
BHPian
 
Join Date: Apr 2004
Location: New Delhi
Posts: 152
Thanked: 2 Times
Default

Thanks Guys !

Will ask for throttle body and air filter clean up.
Though on second thoughts, the car had barely clocked 2000 kms(1.5 months) since it was last serviced. Besides, it was my first such experience in 3.5 years of ownership.

I think it is safe to take the car to service station or shall call breakdown services?

Viper : The bonnet is slightly dented in front but still gets open. However, this time it didn’t. I could not even hear the unlocking sound which usually is heard once the lever is pulled from the dash. But if the accelerator cable is stuck, the car should stuck at one rpm, however it is revving on its own as if its getting ready for a drag.

Tarun.
Tarun is offline   Reply With Quote
Old 12th February 2008, 20:23   #13
BHPian
 
Join Date: Nov 2007
Location: Delhi
Posts: 62
Thanked: 0 Times
Default

even wrote about the same problem. My getz too is just 1 month old and sometimes after starting to move the car in first gear when i apply brakes to stop the car, the car stops and at the same time the RPM meter shoots to 2-2.5 automatically even tho ugh i do not even touch the pedal. this doesnt happen all the time but happens very often. May be it will get resolved after the first servicing. Is this a common behaviour of new cars??

Note from Support Team - Please take time to type your posts in proper English. Sms language is not allowed. Read the rules thoroughly before posting.

This time I have edited your post for better readability.

Last edited by normally_crazy : 12th February 2008 at 20:46. Reason: Corrected sms language
wmax is offline   Reply With Quote
Old 12th February 2008, 21:34   #14
BHPian
 
arpandiv's Avatar
 
Join Date: Aug 2007
Location: Mumbai
Posts: 428
Thanked: 27 Times
Default

Quote:
Originally Posted by Tarun View Post
Viper : The bonnet is slightly dented in front but still gets open. However, this time it didn’t. I could not even hear the unlocking sound which usually is heard once the lever is pulled from the dash.
use a long screw driver with a (-) tip manually slide the bonnet lock.
arpandiv is offline   Reply With Quote
Old 12th February 2008, 23:21   #15
BHPian
 
rranjith_kum's Avatar
 
Join Date: Aug 2006
Location: Coimbatore/ Aachen
Posts: 693
Thanked: 17 Times
Default

Quote:
Originally Posted by sreenidhibr View Post
My earlier car (Santro) got this problem once. My bro got it serviced and the car was fine afterwards.
I too had the same experience with santro ....
rranjith_kum is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2011 i10 Asta A/T - its Korean, its new, its fast, its red, and its coming. nirupesh Test-Drives & Initial Ownership Reports 1 8th January 2011 10:45
Time to own my very own italian beauty - Fiat Linea Petrol E+ rajagopal_j Test-Drives & Initial Ownership Reports 50 13th January 2010 12:51
Its a bird....Its a plane...Its our Cycleman WhiteKnight Street Experiences 15 3rd September 2008 19:21
S10 engine revving on its own 16v100bhp Technical Stuff 19 18th January 2007 21:20


All times are GMT +5.5. The time now is 04:06.

Copyright ©2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks