Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 12th February 2008, 11:16   #1
Senior - BHPian
 
anachronix's Avatar
 
Join Date: Mar 2006
Location: Madras
Posts: 3,250
Thanked: 1,241 Times
Default Electrical Problem with my Ikon!

Frens,

I have a 2004 model Ikon 1.6.

These days i have a wierd problem in my car. The horn sounds well initially when in the start of the day and as i drive it around in the traffic the horn sound changes to a very weak tone (Somthing like its getting less power). Also when i brake and honk at the same time the horn will go really dull and sometimes it cuts out too!

I assume this to be an electrical problem. I need to get this fixed guys. Please help!
anachronix is online now   Reply With Quote
Old 12th February 2008, 11:27   #2
Team-BHP Support
 
benbsb29's Avatar
 
Join Date: Nov 2006
Location: Brisbane
Posts: 8,022
Thanked: 3,480 Times
Default

I may be wrong here, but is it something to do with a weak battery?
benbsb29 is offline   Reply With Quote
Old 12th February 2008, 11:30   #3
Senior - BHPian
 
snaronikar's Avatar
 
Join Date: Jun 2007
Location: Bengaluru
Posts: 2,845
Thanked: 23 Times
Default

Have you checked the wiring. Is the battery getting charged enough. When did you last change the battery? Check these poins and it may be of help.
snaronikar is offline   Reply With Quote
Old 12th February 2008, 11:50   #4
Senior - BHPian
 
Join Date: Mar 2006
Location: Faridabad
Posts: 6,814
Thanked: 294 Times
Default

It only happens in two cases

1) Extra load -> it is like ICE, Fog lights, 100 Watts Headlamps

2) Weak Battery -> how old is your current car battery
low_bass_makker is offline   Reply With Quote
Old 12th February 2008, 11:51   #5
Senior - BHPian
 
anachronix's Avatar
 
Join Date: Mar 2006
Location: Madras
Posts: 3,250
Thanked: 1,241 Times
Default

I changed the battery only an year back! I doubt that it could be weak!
anachronix is online now   Reply With Quote
Old 12th February 2008, 14:08   #6
BHPian
 
VC12's Avatar
 
Join Date: Apr 2007
Location: Hyderabad
Posts: 297
Thanked: 0 Times
Default

Though the batttery may be good, check for the earthing of the battery, this may casue the battery drain and create less power.

Also, at times the horn may have water /moisture thus hampering the sound....
VC12 is offline   Reply With Quote
Old 12th February 2008, 16:17   #7
BHPian
 
wolfinstein's Avatar
 
Join Date: Feb 2006
Location: New Delhi
Posts: 994
Thanked: 14 Times
Default

Have a similar issue in my lancer- Battery is SF one year old, I changed the horns from Roots to Bosch Symphony problem went away but now again recurrs occassionally by sounding weak.

The Mech here said problem could be with the new horns, so will change them under warranty and update.
wolfinstein is offline   Reply With Quote
Old 12th February 2008, 20:20   #8
BHPian
 
Join Date: Feb 2007
Location: Madras
Posts: 558
Thanked: 2 Times
Default

Hey, always the tone of my OEM horn is different. If cruising on the highway its how it should be. In traffic times it has vari-tone . Battery voltage seems to be varying above 12.5-12.8v tho.

Are you using the OEM horn?

cya
A
Absar is offline   Reply With Quote
Old 12th February 2008, 20:41   #9
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,752
Thanked: 7,471 Times
Default

your horn might be getting conked/out of tune with age. am not sure tuning is an option with iKON OE horns.
Jaggu is offline   Reply With Quote
Old 13th February 2008, 12:49   #10
Senior - BHPian
 
anachronix's Avatar
 
Join Date: Mar 2006
Location: Madras
Posts: 3,250
Thanked: 1,241 Times
Default

Can someone help me with a good wiring technician in chennai. I dont want to take it to the dealer and waste my time again. I have already informed the dealer about this problem and he has no answer for that!
anachronix is online now   Reply With Quote
Old 13th February 2008, 17:34   #11
BHPian
 
Join Date: Feb 2007
Location: Madras
Posts: 558
Thanked: 2 Times
Default

You haven't answered if its your OEM horn thats playing around or its an aftermarket horn.

cya
A
Absar is offline   Reply With Quote
Old 13th February 2008, 19:07   #12
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,953
Thanked: 15,646 Times
Default

Get your horn tuned. Looks like it acts up when heated.
The mechanic will take a screwdriver and tune your horn. Once your horn is tuned, this problem should go away.
I doubt its a weak battery issue, because if that was the case even your lights would go dim etc.,
I presume only your horn is acting up.
tsk1979 is offline   Reply With Quote
Old 14th February 2008, 14:56   #13
Senior - BHPian
 
anachronix's Avatar
 
Join Date: Mar 2006
Location: Madras
Posts: 3,250
Thanked: 1,241 Times
Default

Quote:
Originally Posted by Absar View Post
You haven't answered if its your OEM horn thats playing around or its an aftermarket horn.

cya
A
@Absar: its the OEM horn, but i also have a 2nd horn which is installed with proper wiring done. Its a stebel nautilius and that dims out too rarely!
anachronix is online now   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
'Strange'st electrical problem in Fiat Palio 1.2 extreme_torque Technical Stuff 30 21st May 2011 14:14
Strange Electrical Problem on P180 Fountainheader Motorbikes 17 13th March 2011 22:57
Ikon peculiar electrical problem - Help! kaynmantis Technical Stuff 7 7th July 2009 01:51
Scorpio : Weird electrical problem forbhaskarm Technical Stuff 4 7th January 2008 11:16


All times are GMT +5.5. The time now is 03:36.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks