Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 1st March 2008, 14:47   #1
Newbie
 
Join Date: Jan 2008
Location: Gurgaon
Posts: 20
Thanked: 0 Times
Default Lesser Power. My engine don't like me no more?!

Hi Guys!
I have a Fiesta 1.4ZXI pertol, bought five months ago, which has done about 10,000 kms now. I have been experiencing lesser power in the top gears for a while. Earlier it used to pull magnificiently in the second gear and reach upto 50 kmph with the tacho somewhere between 3000-3500 rpm. Now I can barely manage to get it upto 30-35 kmph and the needle is already registering 4000 rpm!

I did a 4500 km run just after the second service (3 months, 3900 km) from Delhi to Goa and have been experiencing this 'powerlessness' since. Have a scheduled 10,000 km service tommorrow. I was wondering if I could get some advice or pointers to take up with the service guys tommorrow.

Thanks a lot!
EngineOil is offline   Reply With Quote
Old 1st March 2008, 19:33   #2
BHPian
 
Join Date: May 2006
Location: bombay
Posts: 440
Thanked: 5 Times
Default

Well tell them your problems , in detail.
I say its your spark plugs , air filter , oil condition etc. Possibly poor Quality petrol too.
Ask them if they can and if they recommend an engine decarb.

PS:Are you a high performance driver?

Last edited by cyneverdie : 1st March 2008 at 19:34.
cyneverdie is offline   Reply With Quote
Old 1st March 2008, 19:45   #3
Senior - BHPian
 
DirtyDan's Avatar
 
Join Date: Jul 2007
Location: Dharamsala
Posts: 1,798
Thanked: 745 Times
Default Symptoms?

Any other symptoms like maybe your fuel average going down?
DirtyDan is offline   Reply With Quote
Old 1st March 2008, 19:46   #4
BHPian
 
amitpunjani's Avatar
 
Join Date: Jul 2007
Location: Delhi
Posts: 451
Thanked: 101 Times
Default

Ask them if they can and if they recommend an engine decarb.


Hi,

Don't really that Engine Decarb would be a good idea, when the car has clocked just 10,000 kms.

Amit
amitpunjani is online now   Reply With Quote
Old 1st March 2008, 19:50   #5
BHPian
 
Pankaj401's Avatar
 
Join Date: Mar 2006
Location: Bangalore, India
Posts: 216
Thanked: 4 Times
Default

Quote:
Now I can barely manage to get it upto 30-35 kmph and the needle is already registering 4000 rpm
Clutch?
Seems like if rpm for given speed is higher than it should be.
Pankaj401 is offline   Reply With Quote
Old 1st March 2008, 20:04   #6
Senior - BHPian
 
DirtyDan's Avatar
 
Join Date: Jul 2007
Location: Dharamsala
Posts: 1,798
Thanked: 745 Times
Default Clutch

Quote:
Originally Posted by Pankaj401 View Post
Clutch?
Seems like if rpm for given speed is higher than it should be.
Sounds like clutch but it is so new it should not be. But then it is so new it should not be anything else either.

I would tell them the symptoms and tell them to check the clutch, the entire drive train and the motor mounts. Its probably the clutch and it will be under warranty.
DirtyDan is offline   Reply With Quote
Old 1st March 2008, 20:13   #7
Senior - BHPian
 
DirtyDan's Avatar
 
Join Date: Jul 2007
Location: Dharamsala
Posts: 1,798
Thanked: 745 Times
Default Oil leak

One other thing, you may want to check and see if you have an oil leak that is dripping on the clutch and causing it to slip. This seems at least possible since it started after an oil change?
DirtyDan is offline   Reply With Quote
Old 1st March 2008, 20:22   #8
Team-BHP Support
 
Akshay1234's Avatar
 
Join Date: Dec 2006
Location: Mumbai
Posts: 9,761
Thanked: 6,670 Times
Default

seems like theres a problem with your clutch. but it shouldnt worn so early.
Akshay1234 is online now   Reply With Quote
Old 1st March 2008, 21:44   #9
BHPian
 
toiingg's Avatar
 
Join Date: Oct 2006
Location: Calcutta
Posts: 601
Thanked: 70 Times
Default

Quote:
Originally Posted by DirtyDan View Post
One other thing, you may want to check and see if you have an oil leak that is dripping on the clutch and causing it to slip. This seems at least possible since it started after an oil change?

I would second that. Was there a chance of an overfill ? We had a thread about that just recently.
toiingg is offline   Reply With Quote
Old 1st March 2008, 22:50   #10
Team-BHP Support
 
Rehaan's Avatar
 
Join Date: Feb 2004
Location: Bombay
Posts: 22,381
Thanked: 22,601 Times
Default

Quote:
Originally Posted by EngineOil View Post
Earlier it used to pull magnificiently in the second gear and reach upto 50 kmph with the tacho somewhere between 3000-3500 rpm. Now I can barely manage to get it upto 30-35 kmph and the needle is already registering 4000 rpm!
If this ^ description is accurate (and both speed / rpms are mentioned for second gear), then it HAS to be a clutch problem, and cannot be anything else.

Do you get any burning or rotten egg smell while driving?

cya
R
Rehaan is offline   Reply With Quote
Old 1st March 2008, 23:06   #11
BHPian
 
TARUL's Avatar
 
Join Date: Oct 2005
Location: BANGALORE
Posts: 117
Thanked: Once
Default

Quote:
Originally Posted by DirtyDan View Post
Sounds like clutch but it is so new it should not be. But then it is so new it should not be anything else either.

.Its probably the clutch and it will be under warranty.
Isn't the clutch a wear & tear part?I am sure you don't get warranty on those.
TARUL is offline   Reply With Quote
Old 2nd March 2008, 03:58   #12
Senior - BHPian
 
DirtyDan's Avatar
 
Join Date: Jul 2007
Location: Dharamsala
Posts: 1,798
Thanked: 745 Times
Default oil

Look for oil dropped on the clutch.
DirtyDan is offline   Reply With Quote
Old 2nd March 2008, 07:18   #13
BHPian
 
chetanhanda's Avatar
 
Join Date: Mar 2005
Location: Toronto
Posts: 886
Thanked: 42 Times
Default

Quote:
Originally Posted by EngineOil View Post
Hi Guys!
I have a Fiesta 1.4ZXI pertol, bought five months ago, which has done about 10,000 kms now. I have been experiencing lesser power in the top gears for a while. Earlier it used to pull magnificiently in the second gear and reach upto 50 kmph with the tacho somewhere between 3000-3500 rpm. Now I can barely manage to get it upto 30-35 kmph and the needle is already registering 4000 rpm!

I did a 4500 km run just after the second service (3 months, 3900 km) from Delhi to Goa and have been experiencing this 'powerlessness' since. Have a scheduled 10,000 km service tommorrow. I was wondering if I could get some advice or pointers to take up with the service guys tommorrow.

Thanks a lot!
like everyone over here mentioned ..looks like a clutch thing based on ur description..
chetanhanda is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Americans driving lesser, using public transportation more AUTO_CRAZY The International Automotive Scene 4 17th August 2013 15:57
Pics of forgotten/lesser known remains of our history darklord Shifting gears 1 9th May 2009 20:34
Why palio is lesser priced? pradeepdayanand The Indian Car Scene 48 8th August 2008 12:39
What technologies you don't like in modern cars? sbasak Technical Stuff 15 18th January 2007 11:31
Why I don't like Maruti? prkothan The Indian Car Scene 12 17th August 2005 21:55


All times are GMT +5.5. The time now is 22:29.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks