Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 24th March 2008, 11:05   #1
BHPian
 
adman77's Avatar
 
Join Date: Mar 2007
Location: Mumbai
Posts: 382
Thanked: 3 Times
Default Strange check light problem, please help.

Have a weird problem guys. Couple of days back, went for car and engine wash at a service center. During the engine wash, the service guy put a plastic cover on the filter and after the wash, he removed it. But while removing it, he must have made the filter a little loose. Later that night, while driving, the ECU check light came on. Parked the car and opened the hood. Imagine what I saw.

The filter had fallen on the alternator belt and the belt had almost come off the wheel. Somehow, I managed to get align the belt back on the wheel and put the filter back. After that, the car was perfectly fine but the ECU check light is permanently on.

I tried all this but the problem still remains.

Disconnected the battery for 10 minutes and reconected.

Changed the filter with a spare one I had.

Disconnected the O2 sensor, cleaned it and connected it back.


So any suggestions guys?
adman77 is offline   Reply With Quote
Old 24th March 2008, 11:24   #2
BHPian
 
amitwiz1's Avatar
 
Join Date: Aug 2007
Location: Bangalore
Posts: 186
Thanked: 8 Times
Default

Get the error info removed with the service station. I really dont know, but have been reading a lot of threads.
amitwiz1 is offline   Reply With Quote
Old 24th March 2008, 18:32   #3
BHPian
 
rohan_fonseca's Avatar
 
Join Date: Jan 2006
Location: Panaji
Posts: 984
Thanked: 4 Times
Default

Pretty elementary whichi'm sure you've done. None the less, have you checked wether the iat sensor coupler is loose or disconnected?
rohan_fonseca is offline   Reply With Quote
Old 24th March 2008, 21:06   #4
BHPian
 
adman77's Avatar
 
Join Date: Mar 2007
Location: Mumbai
Posts: 382
Thanked: 3 Times
Default

Quote:
Originally Posted by rohan_fonseca View Post
have you checked wether the iat sensor coupler is loose or disconnected?
Sorry for being so ignorant, but what's that? And where's that?
adman77 is offline   Reply With Quote
Old 24th March 2008, 22:30   #5
BANNED
 
anku's Avatar
 
Join Date: Jan 2006
Location: mumbai
Posts: 256
Thanked: 111 Times
Cool

Sell Of The CAR Dude Get Some Thing New Now
anku is offline   Reply With Quote
Old 24th March 2008, 23:06   #6
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,746
Thanked: 7,449 Times
Default

ok just take it to a good mech and get it checked, just to ensure things dont slip off and give you big bills. Engine check light might be an error code and you might require a scanner to clear it off, this varies from car to car. Or it can be a faulty coupler/sensor etc. So take the car to a mech soon.
Jaggu is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Very Strange Overheating Issue, Please Help johnruben Technical Stuff 34 3rd December 2010 02:22
Strange Heating Problem in 2002 model santro Pls..... help manne Technical Stuff 9 17th May 2009 03:53
Siena - ECU check light not working superavi Technical Stuff 5 17th October 2006 16:12
Palio not starting; ECU Check light not lighting up shineshine Technical Stuff 2 12th August 2006 11:50


All times are GMT +5.5. The time now is 16:39.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks