Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 28th March 2008, 07:36   #1
BANNED
 
Join Date: Jan 2008
Location: patiala
Posts: 347
Thanked: 0 Times
Default car loosing power

hi friends i own a maruti carb 97 model it has completed 82k without any major issues , now it seems to be loosing its power .before it easily went to 80kmph in 3rd gear but now it struggles for 80kmph. it reached upto 130 with struggle but now needle rests at 120. what could be the possible cause for it. i get it serviced regulary.
jobs done
clutch plates at 55000km
front axle changed at 78000km
harry2223 is offline   Reply With Quote
Old 28th March 2008, 09:31   #2
BHPian
 
dinu2506's Avatar
 
Join Date: Mar 2007
Location: Bangalore
Posts: 788
Thanked: 320 Times
Default

Try the following
1) Replace the air filter
2) Engine decarbonising
3) Check/ replace spark plugs
dinu2506 is offline   Reply With Quote
Old 28th March 2008, 09:38   #3
BHPian
 
amitpunjani's Avatar
 
Join Date: Jul 2007
Location: Delhi
Posts: 451
Thanked: 101 Times
Default

Hi,

Firstly get the compression ratio checked. As the car as clocked a fair bit of Kms it will be worth while to get the compression ratio test done. No point in wasting money for the spark plugs or decarbonising the engine if the comprsssion itself is weak.

Amit
amitpunjani is offline   Reply With Quote
Old 28th March 2008, 10:28   #4
Senior - BHPian
 
amit_mechengg's Avatar
 
Join Date: Dec 2007
Location: Pune
Posts: 2,411
Thanked: 1,540 Times
Default

82k kms. surely the engine might have lost its power. check the cylinders. if they are weak. i.e the compression test. at this stage its better to go for engine overhaul than going for decarb and other stages. the 3 cylinder half engine cost of maruti is just rs 9000. u will get a brand new engine with warranty from maruti.
amit_mechengg is online now   Reply With Quote
Old 28th March 2008, 10:52   #5
Senior - BHPian
 
humyum's Avatar
 
Join Date: Feb 2006
Location: Leicester/Mumbai
Posts: 2,306
Thanked: 2,188 Times
Default

Quote:
Originally Posted by harry2223 View Post
hi friends i own a maruti carb 97 model it has completed 82k without any major issues , now it seems to be loosing its power .before it easily went to 80kmph in 3rd gear but now it struggles for 80kmph. it reached upto 130 with struggle but now needle rests at 120. what could be the possible cause for it. i get it serviced regulary.
jobs done
clutch plates at 55000km
front axle changed at 78000km
Harry bro chill.Nothing major.I have a 81 thousand run 800 1998 model 800 too.
When was the last you got the car serviced?
I know what u mean by loosin power.
First and most i want you to check your secondary butterfly.If that is not opening.BANG power loss.The car will seem like its only revvin minus any power and hence the struggle to reach 80 in 3rd gear.In this case get a WD40 and spray it around and free it up.If it does not work the carb will need to be opened and the secondry will need to be freed.
With your hand on the accelerator cable in the bonnet pull it upto max and see as the rev increases the secondary should open.See how does it open.U ll get the idea.
Get your spark plugs cleaned and gapped/air filter cleaned and your airfuel mixture tuned with a PUC machine and at a reliable maruti service station who know how to tune carbs.If all this does not work out(mostly it will) then get a compression test done.
Quote:
Originally Posted by amit_mechengg View Post
82k kms. surely the engine might have lost its power. check the cylinders. if they are weak. i.e the compression test. at this stage its better to go for engine overhaul than going for decarb and other stages. the 3 cylinder half engine cost of maruti is just rs 9000. u will get a brand new engine with warranty from maruti.
Nope.If maintained properly the engine will work way past 80 thousand km without losin any noticable compression loss.
And half engine is 13 thousand btw.

Last edited by humyum : 28th March 2008 at 11:12.
humyum is offline   Reply With Quote
Old 28th March 2008, 11:28   #6
BANNED
 
Join Date: Jan 2008
Location: patiala
Posts: 347
Thanked: 0 Times
Default

i got my car serviced nearly three weeks ago and drove it around 1k after that . i dont see any signs of engine wear out as it is running smooth without any smoke , but it feels like something is blocking the accleration. there seems to be no problem if i accerate gently but in case of sudden acceleration like for overtaking the power loss is seen. i am also suspecting worn engine mounts , as car jerks as i deaccelerate . can this be also reason.
harry2223 is offline   Reply With Quote
Old 28th March 2008, 11:29   #7
Senior - BHPian
 
humyum's Avatar
 
Join Date: Feb 2006
Location: Leicester/Mumbai
Posts: 2,306
Thanked: 2,188 Times
Default

Also also forgot to add.Check the vaccume pipe if thats come out or no.If it has u ll lose power.Its behind the carb and goes onto an opening near the ignition coil.Just connect it back from whereever it has come out from.Carb or the holding.
humyum is offline   Reply With Quote
Old 28th March 2008, 11:31   #8
Senior - BHPian
 
humyum's Avatar
 
Join Date: Feb 2006
Location: Leicester/Mumbai
Posts: 2,306
Thanked: 2,188 Times
Default

Quote:
Originally Posted by harry2223 View Post
i got my car serviced nearly three weeks ago and drove it around 1k after that . i dont see any signs of engine wear out as it is running smooth without any smoke , but it feels like something is blocking the accleration. there seems to be no problem if i accerate gently but in case of sudden acceleration like for overtaking the power loss is seen. i am also suspecting worn engine mounts , as car jerks as i deaccelerate . can this be also reason.
Nope worn engine mounts wont lead to acceleration loss.Its 99% tuning problem.Too rich a mixture.Go to the guy and ask him to PUC tune it.problem will be solved and as a safety check,check your secondary butterfly and vaccume pipe

Last edited by humyum : 28th March 2008 at 11:32.
humyum is offline   Reply With Quote
Old 28th March 2008, 11:34   #9
BANNED
 
Join Date: Jan 2008
Location: patiala
Posts: 347
Thanked: 0 Times
Default

thanx bro i will get it checked
harry2223 is offline   Reply With Quote
Old 28th March 2008, 11:34   #10
BHPian
 
dustDevil's Avatar
 
Join Date: Jun 2006
Location: Surat/Pune
Posts: 155
Thanked: Once
Default

Quote:
Originally Posted by humyum View Post
First and most i want you to check your secondary butterfly.If that is not opening.BANG power loss.
What is the second butterfly valve for?


And I really don't think you should be THAT worried about compression at 82k kms.
dustDevil is offline   Reply With Quote
Old 28th March 2008, 11:52   #11
BHPian
 
nikkibike's Avatar
 
Join Date: May 2006
Location: QoAS
Posts: 523
Thanked: 2 Times
Default check distributor

Check your distributor assy too! The timing advancing system might have failed. Do a thorough overall of that and see...
Carb o/h and an engine compression test is anyway good doing at this stage!
nikkibike is offline   Reply With Quote
Old 28th March 2008, 12:45   #12
BANNED
 
Join Date: Jan 2008
Location: patiala
Posts: 347
Thanked: 0 Times
Default

thanx friends i will get it checked . another thing i want to fit an ac in my car is it advisabe to go for a bigger compressor . what will be the drop in FE . will double condenser decrease load on engine. do i have to change the blower also . my car is maruti 800 type 2 .suggestions plz.

Last edited by harry2223 : 28th March 2008 at 12:46. Reason: error
harry2223 is offline   Reply With Quote
Old 28th March 2008, 12:50   #13
Senior - BHPian
 
amit_mechengg's Avatar
 
Join Date: Dec 2007
Location: Pune
Posts: 2,411
Thanked: 1,540 Times
Default

Quote:
Originally Posted by harry2223 View Post
thanx friends i will get it checked . another thing i want to fit an ac in my car is it advisabe to go for a bigger compressor . what will be the drop in FE . will double condenser decrease load on engine. do i have to change the blower also . my car is maruti 800 type 2 .suggestions plz.
put a standard subros AC. get it fitted from the MUL A.S.C. bigger the compressor more will be the load on the engine. i would recommend you a standard fittment.
amit_mechengg is online now   Reply With Quote
Old 28th March 2008, 13:03   #14
BANNED
 
Join Date: Jan 2008
Location: patiala
Posts: 347
Thanked: 0 Times
Default

Quote:
Originally Posted by amit_mechengg View Post
put a standard subros AC. get it fitted from the MUL A.S.C. bigger the compressor more will be the load on the engine. i would recommend you a standard fittment.
but i have experienced that standard one dont have much cooling . someone suggested me to go for matiz compressor.
harry2223 is offline   Reply With Quote
Old 28th March 2008, 13:39   #15
BANNED
 
Join Date: Jan 2008
Location: patiala
Posts: 347
Thanked: 0 Times
Default

can you plz tell me the wattage of maruti 800 radiator fan . do i need to replace fan if i want to install sanden compressor or it will be sufficient.
harry2223 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Matching HU amp power with Speaker power? hitra In-Car Entertainment 21 25th March 2015 16:18
2003 Lancer: Engine Loosing Oil MSP9994 Technical Stuff 3 29th November 2009 19:33
Car loosing speed too quickly uphill... and power loss amu1983 Technical Stuff 10 27th June 2007 19:09


All times are GMT +5.5. The time now is 19:48.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks