Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 28th March 2008, 22:25   #1
Senior - BHPian
 
gemithomas's Avatar
 
Join Date: Jan 2007
Location: Trivandrum
Posts: 2,364
Thanked: 136 Times
Default FIAT Adventure issues

MODS: Starting a new thread since the earlier thread in which i put this did not give much replies. Thought a new thread would give it more visibility.

My Adventure has started showing irregular rpms. These are the details
- 3 weeks back i start the car and i see the rpm meter dancing between 300 and 2000 mark. Luckily THings become fine after some time.
- The same thing repeats after another week.
- Yesterday i see the rpm meter settling at 1.1K after some running. When the accelerator is pressed the rpm falls to 200 and the engine stalls unless you move the car with the clutch slightly pressed.
- Once engine is switched off for 10 min everything is normal till a few minutes of running.
- Checked ECU on computer but no errors.
- On the last 40 liters i could run only 300km!!!! So the mileage has taken a good hit.
- Acceleration feels a bit slow once in a while. Not sure if its just a feeling.

I went to the service centre and the guy says he could change the throttle body. HE says that there is nothing to clean in the throttle body. Saw the spare its just a butterfly valve with fixed sensors. The service guys said the older verions had a removable sensor and those could be cleaned. Not sure how true this is but I also did feel that there is nothing really to clean in there.

Last edited by gemithomas : 28th March 2008 at 22:27.
gemithomas is offline   Reply With Quote
Old 28th March 2008, 22:48   #2
Senior - BHPian
 
finneyp's Avatar
 
Join Date: Dec 2005
Location: Bangalore
Posts: 2,619
Thanked: 160 Times
Default

Gemi, just reset the ECU once and see if it works fine.
finneyp is offline   Reply With Quote
Old 28th March 2008, 22:54   #3
Senior - BHPian
 
gemithomas's Avatar
 
Join Date: Jan 2007
Location: Trivandrum
Posts: 2,364
Thanked: 136 Times
Default

Quote:
Originally Posted by finneyp View Post
Gemi, just reset the ECU once and see if it works fine.
No use. Tried that.

Just read this thread
http://www.team-bhp.com/forum/techni...-problems.html (Adventure Mileage and Pickup problems)

Quote:
Originally Posted by rao_battula View Post
More Observations:
1. Car was at idle position. I moved the gear lever to first position, released hand break and release the clutch very slowly. After a certain position of the clutch, I observed the RPM is going down from 600 to 200 before the car moves forward. This is not the case with my Palio.

I seem to be having almost the same problem of rpm going very low when starting to move in first gear. THis causes the engine to stall unless we use half clutch,

Last edited by gemithomas : 28th March 2008 at 22:56.
gemithomas is offline   Reply With Quote
Old 29th March 2008, 22:23   #4
Senior - BHPian
 
gemithomas's Avatar
 
Join Date: Jan 2007
Location: Trivandrum
Posts: 2,364
Thanked: 136 Times
Default Updates

Ok. Here are the updates.

Changed throttle body. The rpm now sticks to around 650 range. Thats cool enough. But there is some strange problem.

Did a few long trips over the past days. The car runs perfectly fine and rpm is normal even after 100km trip. The Strange thing is that on both days when i did a short trip in good traffic. The problem reoccurs. The rpm rises slowly and sticks to 1100 rpm. At that time if we press the acccelerator, the rpm drops to 400 and unless i use half clutch to move the vehicle from stop it stalls. This does not happen while the car is running. It happens when trffic moves so slow and i am forced to move in lower gears with start and stop every other minute.

Hope to get some tips on what you guys think.
gemithomas is offline   Reply With Quote
Old 30th March 2008, 07:42   #5
Awaiting Email Confirmation
 
Join Date: Jun 2005
Location: ERNAKULAM
Posts: 947
Thanked: 317 Times
Default Pay them for fixing the issue.

Very many whom I know allow the service center people to experiment with the car they own. Do not pay them till they fix the problem. You should get back your old throttle body and get a refund too as the problem was not the throttle body in the first place but an issue with one of the sensors( could be anyone)
One of the members in the PUG forum had a similar problem which was rectified by cleaning one of the sensors that fit onto the plastic intake runners that sits on top of the engine. Another member had a cure by replacing the TDC sensor. Best of luck.
Bye and wear your seat belts.
drpullockaran is offline   Reply With Quote
Old 30th March 2008, 09:14   #6
BHPian
 
amitpunjani's Avatar
 
Join Date: Jul 2007
Location: Delhi
Posts: 451
Thanked: 101 Times
Default

Quote:
Originally Posted by gemithomas View Post
Ok. Here are the updates.

Changed throttle body. The rpm now sticks to around 650 range. Thats cool enough. But there is some strange problem.

Did a few long trips over the past days. The car runs perfectly fine and rpm is normal even after 100km trip. The Strange thing is that on both days when i did a short trip in good traffic. The problem reoccurs. The rpm rises slowly and sticks to 1100 rpm. At that time if we press the acccelerator, the rpm drops to 400 and unless i use half clutch to move the vehicle from stop it stalls. This does not happen while the car is running. It happens when trffic moves so slow and i am forced to move in lower gears with start and stop every other minute.

Hope to get some tips on what you guys think.

this the issue i am facing in my Santro as well, the reasonable explanation i got this was that of Stepper motor. This motor serves as an air intake mode whent he butterfly is closed. During the B2b traffic the stepper motors is not able to function properly and gets stuck and this is why you get high rpm.

AMit
amitpunjani is online now   Reply With Quote
Old 2nd April 2008, 15:40   #7
Senior - BHPian
 
gemithomas's Avatar
 
Join Date: Jan 2007
Location: Trivandrum
Posts: 2,364
Thanked: 136 Times
Default

Changed rpm sensor. Still the issue prevails. Is there no one who can help.
gemithomas is offline   Reply With Quote
Old 3rd April 2008, 10:41   #8
Senior - BHPian
 
Join Date: Dec 2004
Location: pune
Posts: 2,088
Thanked: 48 Times
Default

Just curious if you got your fuel injectors cleaned up (decarb)? You should get them checked if not already done.
RX135 is offline   Reply With Quote
Old 15th April 2008, 08:56   #9
Senior - BHPian
 
gemithomas's Avatar
 
Join Date: Jan 2007
Location: Trivandrum
Posts: 2,364
Thanked: 136 Times
Default updates.

Ok. These are the updates. We have changed the following things

- Throttle Body
- Pressure SEnsor
- Ignition Coil and Spark Plugs
- ECU
- Instrument Cluster

After the ignition coil change. the Car has become very silent and the frequency of occurance of the high idle issue has reduced. However it still occured on two occations when i was in very high traffic.

Just wanted to know if the following parts could cause such a behaviour.

- Alternator.
- Oxygen Sensor / Lambda Sensor.
- Catalytic Converter.

Could any of these parts cause the car to idle high after bumper to bumper traffic (probably at low rpms as far as the engine is concerned) and function properly at long drives (probably high rpms as the engine is concerned).

Please pass knowledge on the functioning of the above parts. Maybe it would help in finding some link to rpm determination by ecu

Hope to get some replies atleast this time.
gemithomas is offline   Reply With Quote
Old 15th April 2008, 17:57   #10
BHPian
 
rmonie's Avatar
 
Join Date: Jul 2007
Location: Gurgaon
Posts: 215
Thanked: 43 Times
Default

I am shooting in the dark here but have you checked the Exhaust Gas sensor? Sits on the manifold just before the catcon.
rmonie is offline   Reply With Quote
Old 15th April 2008, 23:07   #11
BHPian
 
jalsa777's Avatar
 
Join Date: May 2006
Location: Mumbai
Posts: 637
Thanked: 1,044 Times
Default

it may be an injector problem.

i had a similar problem on my palio, (just similar, no the same, it useed to idle erratically and miss-fired a bit)
and found out that one of the injectors had died
jalsa777 is offline   Reply With Quote
Old 21st April 2008, 16:55   #12
Rai
BHPian
 
Join Date: Feb 2008
Location: Bangalore
Posts: 82
Thanked: 6 Times
Default Irregular Throttle?

@Gemithomas,
Any Updates on your throttle issue? / Irregular RPM issue?
Rai is offline   Reply With Quote
Old 22nd April 2008, 08:49   #13
Senior - BHPian
 
gemithomas's Avatar
 
Join Date: Jan 2007
Location: Trivandrum
Posts: 2,364
Thanked: 136 Times
Default

Just changed the following yesterday night. Will be checking. Will update in a few days time. THanks.

- Alternator
- Catalytic Converter
- Lambda/O2 Sensor
gemithomas is offline   Reply With Quote
Old 25th April 2008, 16:32   #14
BHPian
 
rao_battula's Avatar
 
Join Date: Nov 2004
Location: Hyderabad, India
Posts: 128
Thanked: 0 Times
Default

Hi Gemi,
Driving the car with this problem is very frustrating. We have leaked the air from Clutch and problem seems gone. It has been 6 months and we have not seen this problem. Try it out and let us know.

-BSR
rao_battula is offline   Reply With Quote
Old 25th April 2008, 16:49   #15
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,953
Thanked: 15,646 Times
Default

Gemi, the list of parts exchanged is really growing long. did you take extended warranty?
tsk1979 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Embarking on an Adventure: My pre-owned Fiat Adventure Samar117 Test-Drives & Initial Ownership Reports 42 10th January 2015 14:29
Fiat Palio Adventure 1.6 - ready to rock ! zaphod Long-Term Ownership Reviews 28 28th November 2007 10:35
New Fiat Adventure Sport @5.58 Lacs merve_extreme The Indian Car Scene 34 6th June 2005 14:46
Fiat Palio Adventure On Road hell_rider The Indian Car Scene 13 17th April 2005 19:38
FIAT brazil launches new Siena & Adventure amit The International Automotive Scene 9 19th March 2004 08:03


All times are GMT +5.5. The time now is 10:48.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks