Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 16th April 2008, 23:48   #91
BHPian
 
carzy's Avatar
 
Join Date: Oct 2007
Location: Mum Ca Mum
Posts: 75
Thanked: 0 Times
Default

It's a great relief to know the fault was minor, I'm personally happy since Safari was in my good books :-) Good luck for the next hundred thousand kms.
carzy is offline   Reply With Quote
Old 17th April 2008, 00:07   #92
Distinguished - BHPian
 
phamilyman's Avatar
 
Join Date: Jul 2007
Location: Gurgaon
Posts: 5,601
Thanked: 3,452 Times
Default

Ddhruv,

Why additives? Simple economics. I quote for bikes - you can calculate for cars. Typical warranty service gets a service station 80-100 bucks MAX. While one bottle of bardahl bike supplement is 110 bucks. Easy peasy cash margins.
phamilyman is offline   Reply With Quote
Old 17th April 2008, 11:40   #93
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,753
Thanked: 7,478 Times
Default

Quote:
Originally Posted by DDDHRUV View Post
I agree its their job but I really appreciate their time and sincere efforts to locate the problem. As they were unable to source the spare immediately they had to replace from the demo SAFARI at the cost of turning back potential SAFARI customers approaching for a test drive.
Very few dealers extend this kind of service, especially for a newly launched vehicle. I think your dealer gave you very good support.
Jaggu is online now   Reply With Quote
Old 17th April 2008, 12:28   #94
BHPian
 
Join Date: Aug 2007
Location: Pune
Posts: 448
Thanked: 6 Times
Default

Hey, Just saw this thread.
Could not stop till I finished reading all the posts.

Ddhruv: Very happy that the fault was located and quite fast (thanks to Google and TBhp). All is well that ends well.

Not so happy that Tata people did not turn up. Like ADC suggested please take it up with them. Also mention about the spares not being available. I think you should insist on a brand new spare (tube) being made available and fitted.

@Dadu: You seem to done some serioooous reading on Turbos by Garrett
kingshukt is offline   Reply With Quote
Old 17th April 2008, 15:12   #95
BHPian
 
Join Date: Nov 2007
Location: Mumbai
Posts: 728
Thanked: 28 Times
Default

I guess its high time that Tatas are pulled up by the consumer courts who will publish this article and many others on front pages of newspapers all describing the agony of buying a Tata. Selling a dime a dozen is not enough, its high time these guys need to be taught a lesson. How many Innovas or high mileage octavias have quality issues like these.
Let the Tata cars rot in Hell !!!!
kavesh55 is offline   Reply With Quote
Old 9th May 2008, 15:40   #96
BHPian
 
bglsrini's Avatar
 
Join Date: Dec 2007
Location: bangalore
Posts: 291
Thanked: 0 Times
Default turbo failure in my safari2.2

Hi,
I saw this thread just now.I had some kind of problem too.
Last week,I started hearing hisssssing noise when i accelerate and the rpm goes above1500.Then when the car is in constant speed the noise is not there.While i was trying to find out, I posted the same in my Thread and as suggested by BHPians,I was analysing and then saw black smoke comming too.I was shattered and my vechile was nearing 15000km service too.
I wanted to find out correctly and then scanned my car and finally saw the service light comming.The power was totally down.I stopped the car and i called Tass and told them and they said it may be a turbo failure.I remembered my sierraturbo days and had the same kind fo problem then with the turbo.So.I prayed and restarted and the light was gone but the safari in underpowered with the noise.So,i drove slowly.

Yesterday morning I left my safari for the problem to be attended and i called the servise advisor now and then to find out what went wrong.Then he confirmed to me that there is some manufacturing defect in TURBO hose and he has to replace it.Then again he said he havnt got it yet. Then he said he has got a new one and he could not fix it and its comming off. And now at 3:00 he confirmed that all is fine and ok.I will be taking my safari by evening today.

Thank god,the problem is solved.

Last edited by bglsrini : 9th May 2008 at 15:46.
bglsrini is offline   Reply With Quote
Old 9th May 2008, 15:51   #97
adc
Senior - BHPian
 
adc's Avatar
 
Join Date: Mar 2007
Location: Kolkata
Posts: 1,346
Thanked: 2,100 Times
Default

Quote:
Originally Posted by bglsrini View Post
Then he confirmed to me that there is some manufacturing defect in TURBO hose and he has to replace it.

Thank god,the problem is solved.

Thats very good news. Who knows, may be turbo hose is the next retrofit circular then from Tata Motors.


Do share your experience on the 15k service, what was done and like, it is the first big service and quite a lot of things are checked.
adc is offline   Reply With Quote
Old 9th May 2008, 16:52   #98
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,956
Thanked: 15,648 Times
Default

Looks like the quality dept of Tata is getting 'hosed'
In 3.0 it was 'oiled'
tsk1979 is offline   Reply With Quote
Old 11th May 2008, 12:29   #99
BHPian
 
bglsrini's Avatar
 
Join Date: Dec 2007
Location: bangalore
Posts: 291
Thanked: 0 Times
Default problem fixed and took delivery

On 9th,I went to Prerana for taking delivery of my vechile and checked with the advisor what the actual problem is.He opened the bonnet and showed a red hose.He said the hose was slipping when acceleration was given resulting in turbo loss/power loss/black smoke.They have changed the hose.He said there was problem in the manufacturing of the hose itself hence the problem.But,Now its fixed with a new one and my BULL is back with power.

part no: 254714605815 - rubber hose(I.C to mainfold)
Attached Images
   
bglsrini is offline   Reply With Quote
Old 11th May 2008, 17:56   #100
Senior - BHPian
 
Join Date: Sep 2007
Location: New Delhi
Posts: 3,083
Thanked: 252 Times
Default

Quote:
Originally Posted by bglsrini View Post
He said there was problem in the manufacturing of the hose itself hence the problem.But,Now its fixed with a new one and my BULL is back with power.

part no: 254714605815 - rubber hose(I.C to mainfold)
So is this now a 'modified' design or is it just that your earlier piece was a defective one?
anupmathur is offline   Reply With Quote
Old 11th May 2008, 20:38   #101
BHPian
 
bglsrini's Avatar
 
Join Date: Dec 2007
Location: bangalore
Posts: 291
Thanked: 0 Times
Default

Quote:
Originally Posted by anupmathur View Post
So is this now a 'modified' design or is it just that your earlier piece was a defective one?
This is after replacement
bglsrini is offline   Reply With Quote
Old 11th May 2008, 21:31   #102
Senior - BHPian
 
Join Date: Sep 2007
Location: New Delhi
Posts: 3,083
Thanked: 252 Times
Default

Quote:
Originally Posted by bglsrini View Post
This is after replacement
Sorry, maybe my question was not clear.
I would like to know whether this new replaced hose is of the same design as the old one, or is it a new modified design that will not keep slipping off like the old one.
anupmathur is offline   Reply With Quote
Old 11th May 2008, 21:47   #103
BHPian
 
bglsrini's Avatar
 
Join Date: Dec 2007
Location: bangalore
Posts: 291
Thanked: 0 Times
Default

Quote:
Originally Posted by anupmathur View Post
Sorry, maybe my question was not clear.
I would like to know whether this new replaced hose is of the same design as the old one, or is it a new modified design that will not keep slipping off like the old one.
oooohhh,its the same design.The hose which was originally in my vechile had a problem.So,this has been only replaced.
bglsrini is offline   Reply With Quote
Old 11th May 2008, 22:24   #104
Awaiting Email Confirmation
 
Join Date: Sep 2007
Location: India
Posts: 1,745
Thanked: 19 Times
Default

lots of die hard beta testers on this forum! and people still say its tata-bashing when someone criticises the Tata QC.
rubber parts or wiring, however insignificant the part may seem, it causes a lot of trouble. tata will continue to do this to its customer's till they are taught a lesson. this kind of blind support for anyone brand will not help it improve, it will just drag it down.

so do the right thing! criticise the company when it deserves it. that will only make things better in the future.
rippergeo is offline   Reply With Quote
Old 11th May 2008, 22:36   #105
Senior - BHPian
 
Join Date: Sep 2007
Location: New Delhi
Posts: 3,083
Thanked: 252 Times
Default

Quote:
Originally Posted by rippergeo View Post
this kind of blind support for anyone brand will not help it improve, it will just drag it down.

so do the right thing! criticise the company when it deserves it. that will only make things better in the future.
Couldn't agree more!
.... by saying that you received exemplary support in that they took a part out from a demo vehicle at the cost of losing prospective buyers!!! C'mon, have a heart. Everyone here is over 18!
Even in failure there is glory!
anupmathur is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Tata Safari Brake Failure. EDIT: Solved tsk1979 Technical Stuff 17 14th January 2014 22:12
New Beast Master (Safari 2.2VTT 4x2) wheelsNsqueals Test-Drives & Initial Ownership Reports 44 5th April 2010 12:50
How I decided on Safari 2.2VTT bkishore_77 Test-Drives & Initial Ownership Reports 24 20th August 2009 17:49
Tata Safari Dicor 2.2VTT Cycus Grey LX avanishphatak Test-Drives & Initial Ownership Reports 40 11th May 2008 17:36
Tata Safari 2.2VTT - Change in prices? itwasntme The Indian Car Scene 16 23rd January 2008 18:37


All times are GMT +5.5. The time now is 04:48.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks