Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 25th April 2008, 11:37   #16
Senior - BHPian
 
shuvd's Avatar
 
Join Date: Nov 2006
Location: Calcutta
Posts: 1,081
Thanked: 4 Times
Default

Disconnect the -ve terminal for 15-20mins. Note: This will only erase all fault codes. If there is something wrong with the system, the light will come on again.
As Ajmat sir said, this usually happens when there is dirt on the sensors. But, do get the car scanned during the next service.
shuvd is offline   Reply With Quote
Old 25th April 2008, 13:50   #17
Senior - BHPian
 
Join Date: Feb 2007
Location: Bangalore
Posts: 1,350
Thanked: 31 Times
Default

Do not play around with the ECU. Its more of an electrician's job than a car mechanic's !! :-)

Get it to your service station and check it out. Most probably its either a loose contact or the sensor has dirt on it. I had the same problem in my Matiz. Once I cross 80 I used to have the Engine check light turn on. It would not come at lower speeds but only come when I cross 80 kmph. It would then stay on until I switch of my car and would reappear when I hit 80 kmph. I went to the garage and they did a fault check. They found out which sensor was giving the problem and found that it was a loose contact. Fixed it and then everything worked fine again. Well they didn't charge me anything for it.
csentil is offline   Reply With Quote
Old 25th April 2008, 14:40   #18
Senior - BHPian
 
ramkya1's Avatar
 
Join Date: Oct 2005
Location: Palakkad, Keral
Posts: 1,817
Thanked: 362 Times
Arrow Go To The Service Centre

Quote:
Originally Posted by zoomingbhat View Post
The light comes on as soon as I cross 150 but the hand brake light i have not come across.
And this light goes of only when I stop and restart the engine.

Btw how to reset the ECU I have no idea
Suggest you don't fiddle around with the ECE settings, go the the authorised service station and let them do a proper scan. Have a job card made out and record the complaint; in case you need to change anything related to the ECE this record will come in handy.

Had something similar with my Fusion when once the battery warning lights appeared on high revving, turned out to be a loose wire to the senser when I took it to the Ford Service Station.

==Ramky
ramkya1 is offline   Reply With Quote
Old 26th April 2008, 12:01   #19
Senior - BHPian
 
gd1418's Avatar
 
Join Date: May 2006
Location: Gurgaon
Posts: 3,578
Thanked: 656 Times
Default

@abhik: with LBM, most of the working systems too fail for some unknown reasons...

Quote:
Originally Posted by low_bass_makker View Post
Maybe the abs stops working after that speeds.
Quote:
Originally Posted by abhik View Post
LBM a safety system is surely not designed to give up on you when you need it the most.
gd1418 is offline   Reply With Quote
Old 26th April 2008, 19:59   #20
BHPian
 
abhik's Avatar
 
Join Date: Aug 2007
Location: New Delhi
Posts: 848
Thanked: 8 Times
Default

Quote:
Originally Posted by gd1418 View Post
@abhik: with LBM, most of the working systems too fail for some unknown reasons...

LBM hope you dont mind a little leg pulling, all meant in good spirit!
abhik is offline   Reply With Quote
Old 29th August 2008, 11:57   #21
BHPian
 
bharatbs's Avatar
 
Join Date: Apr 2006
Location: Bangalore
Posts: 374
Thanked: 108 Times
Default Swift ABS light on

I had given my Swift for 2nd service three days back at the Newly opened Bimal service center in Indiranagar.

The ABS light started switching on when I was driving. I took it back to the service station and they reset the ABS by disconnecting the battery terminals.

It was fine for a day and today again while driving to work the ABS light swtiched on and remained on throughout.

Any idea what is the reason, have they messed up the ABS during service? I have not driven my car in the rain after the service.

Last edited by bharatbs : 29th August 2008 at 11:59.
bharatbs is offline   Reply With Quote
Old 29th August 2008, 22:52   #22
BHPian
 
bharatbs's Avatar
 
Join Date: Apr 2006
Location: Bangalore
Posts: 374
Thanked: 108 Times
Wink

Got the problem rectified today at Bimal Mahadevpura. Very good mech by the name of Arif. he immediately identified the reason in a matter of minutes.

What went wrong: Well the little fella paid a visit to my car and decided to eat the speaker wire connecting to the battery. He also decided to do the same with ABS and EPS wire so both the wires met and that is why the light was coming on.

Lessons learnt: Make sure your speaker wire is covered by a wire cover and make sure the main wire from the battery passes to the ICE through the center of the rubberseal in the engine bay and make sure you apply some mseal and seal it it tight. Otherwise the little hungry fella will come into you car and have some fun.

Well if you are still wondering who the little fella was?
Attached Images
 
bharatbs is offline   Reply With Quote
Old 29th August 2008, 23:41   #23
BHPian
 
BAKIYA_2K12's Avatar
 
Join Date: Nov 2007
Location: CHENNAI
Posts: 190
Thanked: 2 Times
Default

Quote:
Originally Posted by bharatbs View Post
Got the problem rectified today at Bimal Mahadevpura. Very good mech by the name of Arif. he immediately identified the reason in a matter of minutes.

What went wrong: Well the little fella paid a visit to my car and decided to eat the speaker wire connecting to the battery. He also decided to do the same with ABS and EPS wire so both the wires met and that is why the light was coming on.

Lessons learnt: Make sure your speaker wire is covered by a wire cover and make sure the main wire from the battery passes to the ICE through the center of the rubberseal in the engine bay and make sure you apply some mseal and seal it it tight. Otherwise the little hungry fella will come into you car and have some fun.

Well if you are still wondering who the little fella was?


I too had a similar problem one day in the morning when i started my car i saw the ABS and hand break lights on.i called a guy in ford and explained my problem he asked me can you use your hand break and i checked and said yes.then he asked me to bring my car to the service center in the service center my car was checked and lifted in the ramp. to my surprise the wire was eaten by a hungry rat.then they connected it and with a test ride the problem was solved.


But i couldn't leave it i kept nearly ten rat cakes in the places like engine bay and where the ABS wire was eaten and i was feeding them for nearly three day until i could can smell bad in the place.two were dead in the incident till now i did not have any problem.
BAKIYA_2K12 is offline   Reply With Quote
Old 25th September 2008, 11:42   #24
BHPian
 
tabrez02's Avatar
 
Join Date: Nov 2004
Location: Bangalore
Posts: 286
Thanked: 5 Times
Question

Quote:
Originally Posted by low_bass_makker View Post
Same happened with me. Ealier I had VIVA the abs and Hand brake lights come when I exceed speed excess of 160 km/hr. But similar thing happened with my Swift which also has ABS. Maybe the abs stops working after that speeds.
Even my Swift vxi ABS is giving the same problem, sometimes in the city (low speed) also the Handbrake light and the ABS lights on. Then i need to stop the car switch off and switch on, then the lights go off. Is anybody else have this problem in swift and what could be the solution ?
tabrez02 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS light stays ON! Reason? lambuhere1 Technical Stuff 44 31st May 2017 16:30
Fiat Linea: Check Engine light comes on lineattack Technical Stuff 1 2nd July 2012 12:26
ABS light on after windshield film installation in elantra .anshuman Technical Stuff 13 24th December 2009 02:29
Check Engine light comes up in Indica usrivpx Technical Stuff 5 10th June 2009 12:20
Brake warning light comes on while accelerating bottle Technical Stuff 12 22nd December 2008 23:40


All times are GMT +5.5. The time now is 07:37.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks