Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 6th May 2008, 22:44   #16
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,746
Thanked: 7,450 Times
Default

Yup can cause injector problem, per injector 200 to 250 bucks they can charge for cleaning.
Jaggu is online now   Reply With Quote
Old 6th May 2008, 23:38   #17
BHPian
 
Join Date: Apr 2008
Location: Bangalore
Posts: 366
Thanked: Once
Default

jaggu: i just saw your thread about your ikon. so do you know any non company mechanic now? i'm thinking of going to a guy called zetec motors in ejipura. there is another guy called suri in koramangala who i heard worked with rally cars but i still have to get his contact details.
silver_shadow is offline   Reply With Quote
Old 7th May 2008, 00:22   #18
Senior - BHPian
 
iraghava's Avatar
 
Join Date: Oct 2005
Location: Bhaiyyaland
Posts: 8,028
Thanked: 153 Times
Default

Are the vibrations coming from the engine area or the floorboard area?
iraghava is offline   Reply With Quote
Old 14th May 2008, 18:11   #19
Newbie
 
The X Factor's Avatar
 
Join Date: Apr 2004
Location: Mumbai
Posts: 16
Thanked: 0 Times
Default

I had a similar issue with my ikon with the car vibrating a lot at idle (specially with AC on) , lack of power in all gears and subsequently low fuel efficiency ... took her to wasan ford yesterday who blamed it faulty ignition coil, the orignal ford one costs close to 5.5k while local non branded ones were around 1.5-2k ... somehow managed to get the ones that ford uses for 2.2k and so far so good
The X Factor is offline   Reply With Quote
Old 14th May 2008, 20:58   #20
BHPian
 
Arpit's Avatar
 
Join Date: May 2008
Location: NOIDA
Posts: 49
Thanked: 0 Times
Default

Its most likely to be an Engine Mount problem as you have stated that idling RPM is stable at 800-900.
Arpit is offline   Reply With Quote
Old 14th May 2008, 21:01   #21
BHPian
 
Join Date: Sep 2006
Location: Was PB, DL, HR , KA and Now GJ-1
Posts: 247
Thanked: 21 Times
Default

Quote:
Originally Posted by The X Factor View Post
I had a similar issue with my ikon with the car vibrating a lot at idle (specially with AC on) , lack of power in all gears and subsequently low fuel efficiency ... took her to wasan ford yesterday who blamed it faulty ignition coil, the orignal ford one costs close to 5.5k while local non branded ones were around 1.5-2k ... somehow managed to get the ones that ford uses for 2.2k and so far so good
yeah Ignition coil on my Ikon also went kaput & one cylinder was not gettting fired at all but I used to feel only misfiring & drop in pickup/ low fuel efficiency not any vibrations. I picked up the Ingnition coil for 2.4K from somebody known in ford.
pankaj_sachdeva is offline   Reply With Quote
Old 14th May 2008, 21:22   #22
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,746
Thanked: 7,450 Times
Default

Quote:
Originally Posted by silver_shadow View Post
jaggu: i just saw your thread about your ikon. so do you know any non company mechanic now? i'm thinking of going to a guy called zetec motors in ejipura. there is another guy called suri in koramangala who i heard worked with rally cars but i still have to get his contact details.
I had to sell the iKON and move to Swift D and nope not heard of the guys you mentioned.
Jaggu is online now   Reply With Quote
Old 14th May 2008, 21:30   #23
Team-BHP Support
 
.anshuman's Avatar
 
Join Date: Dec 2004
Location: Good-Gaon
Posts: 7,708
Thanked: 8,929 Times
Default

check the coil and the spark plug cables,had a similar issue in my car too.
.anshuman is offline   Reply With Quote
Old 17th May 2008, 12:54   #24
BHPian
 
Arpit's Avatar
 
Join Date: May 2008
Location: NOIDA
Posts: 49
Thanked: 0 Times
Default

Hey Eddy, Whats the update on your vibration Problem ?
Arpit is offline   Reply With Quote
Old 31st May 2008, 17:10   #25
Team-BHP Support
 
Eddy's Avatar
 
Join Date: Apr 2007
Location: Delhi
Posts: 7,402
Thanked: 4,678 Times
Default

Thanks for the inputs guys.

Took it to the Ford authorised ***. They changed the ignition coil and that has solved the problem.

Another 5000 bucks on the credit card bill.
Eddy is offline   Reply With Quote
Old 31st May 2008, 18:28   #26
Senior - BHPian
 
DirtyDan's Avatar
 
Join Date: Jul 2007
Location: Dharamsala
Posts: 1,798
Thanked: 745 Times
Default Right

Quote:
Originally Posted by Eddy View Post
Thanks for the inputs guys.

Took it to the Ford authorised ***. They changed the ignition coil and that has solved the problem.

Another 5000 bucks on the credit card bill.
Ahem! Ahem, I sez. Using the infamous DirtyDan shotgun approach, I got this one right. Sort of.
DirtyDan is offline   Reply With Quote
Old 13th August 2010, 12:03   #27
Senior - BHPian
 
mooza's Avatar
 
Join Date: Oct 2009
Location: Bangalore
Posts: 1,054
Thanked: 243 Times
Default

I have been facing a similar shuddering and shaking of the engine (Ford Ikon Iris, petrol, 1.3 Endura), over the past couple of weeks.

Finally, today my wife called up to say that the problem has worsened and the whole car is shaking . So she got off promptly.

I plan to take the car to Metro Ford in the evening at 4 pm. Hope I can drive it till there with my teeth intact !

Any pointers on self checks that could be done at this stage, before taking it to Metro Ford ?
mooza is offline   Reply With Quote
Old 13th August 2010, 12:32   #28
BHPian
 
Googleman's Avatar
 
Join Date: Aug 2010
Location: Blore/Jmshedpur
Posts: 240
Thanked: 48 Times
Default

I can see lots of guesses in this thread.

@mooza, shuddering has lots of reasons. A solution can be provided by a person who 'knows' about this and sits in the car to experience the vibration.

One of my friend's car would not start. We thought it was a bad fuse so we checked everything but still no hope. We later pushed the car and started it in the 2nd gear. The car would not hold the moment we stepped the foot off the accelerator and would switch off again.

We increased the tuning to keep it started to reach the mechanic and the car started shaking badly. I could see the engine shaking like an old lady's teeth. Later a truck driver came and pushed all the plugs in properly and the car started fine. It was just coz of bad wiring.
Googleman is offline   Reply With Quote
Old 14th August 2010, 08:00   #29
Senior - BHPian
 
mooza's Avatar
 
Join Date: Oct 2009
Location: Bangalore
Posts: 1,054
Thanked: 243 Times
Default

Thanks Googleman, for the reply

Update : the problem has been resolved. The ignition coil had gone kaput. It was replaced at Metro Ford, and the car is now as good as new.

Total cost including labour : Rs. 6,000/-.
mooza is offline   Reply With Quote
Old 14th August 2010, 17:46   #30
Senior - BHPian
 
gd1418's Avatar
 
Join Date: May 2006
Location: Gurgaon
Posts: 3,578
Thanked: 655 Times
Default

Two Ford Ikons reporting ignition coil failure. Something very rare. Coils are known to last long, very long.

My '73 model Amby, sold in '90 had its original Lucas coil intact and working beautifully..
gd1418 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Speedometer Needle: Shaking & vibrating Styler Technical Stuff 12 21st February 2016 16:05
Clutch friction plate hub shaking: Root cause? dhanushs Technical Stuff 32 15th December 2015 20:13
Puzzling (and expensive) problem with Idle Speed ISA in Santro silverbyte Technical Stuff 0 15th July 2009 18:28
IKON 1.3 - Engine Dies, gets back to almost normal !! pkumar Technical Stuff 14 19th January 2009 17:34
Shaking Vehicle while filling petrol - will it help? kdeepakk The Indian Car Scene 70 30th July 2007 11:34


All times are GMT +5.5. The time now is 05:53.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks