Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 26th July 2008, 14:11   #1
BHPian
 
funkydevil's Avatar
 
Join Date: Oct 2007
Location: Dubai, UAE
Posts: 358
Thanked: 80 Times
Default Compressor just wont come on !!!

Hey guys,

Was driving around today morning and noticed something unusual. Hot air was comming out of the vents despite the A/C being on. I switched the car off and on again and tried the A/C once more, but its just giving out hot air like when only the fan is on. I noticed that everytime pushed the A/C button, there was no sound of the compressor comming on.

I've checked everything, all the air flow, temp. dials are in the right position. The A/C was working fine until yesterday. Wonder what's wrong now. The compressor just dosn't come on !!!

Any idea's on what could be the problem???
funkydevil is offline   Reply With Quote
Old 26th July 2008, 14:52   #2
BHPian
 
Join Date: Aug 2005
Location: Bangalore
Posts: 978
Thanked: 5 Times
Default

The most likely/common reasons-
1. A/C compressor clutch fuse blown
2. Problem with compressor clutch relay
santosh.s is offline   Reply With Quote
Old 26th July 2008, 15:25   #3
Senior - BHPian
 
gd1418's Avatar
 
Join Date: May 2006
Location: Gurgaon
Posts: 3,578
Thanked: 655 Times
Default

What car is yours? Check the A/C belt. Maybe it has snapped..
gd1418 is offline   Reply With Quote
Old 26th July 2008, 15:36   #4
BHPian
 
ankitahuja's Avatar
 
Join Date: Oct 2006
Location: Gurgaon & Delhi
Posts: 887
Thanked: 46 Times
Default

It could also be the AC relay. Mine got loose a couple of times (the connection) and the compressor would not go on because of that.

Get the basics checked, it should be something minor.
ankitahuja is offline   Reply With Quote
Old 26th July 2008, 15:42   #5
Senior - BHPian
 
iceman91's Avatar
 
Join Date: Nov 2004
Location: melbourne/bangalore
Posts: 1,958
Thanked: 22 Times
Default

Check the following:
1. A/c relay, fuses etc.
2. Refrigerant (ac gas) this could have leaked out
3. A/c belt
4. A/c switch
iceman91 is offline   Reply With Quote
Old 26th July 2008, 16:33   #6
BHPian
 
funkydevil's Avatar
 
Join Date: Oct 2007
Location: Dubai, UAE
Posts: 358
Thanked: 80 Times
Default

Thanks guys for the reply's,

Will get the folowing checked ASAP......
funkydevil is offline   Reply With Quote
Old 26th July 2008, 17:31   #7
BHPian
 
crackingride's Avatar
 
Join Date: Apr 2008
Location: bangalore
Posts: 267
Thanked: 13 Times
Default compressor woes

you might also want to check wiring/leads for crimping/ corrosion.
my fiat palio displayed the same type of symptoms. the tata motor folks were dead sure they had checked the battery, belt etc etc and that the dash needed to be pulled to get at the thermostat for a replacement job (roughly 4000 in cost).
luckily they couldnt find the part, and in the ensuing wait, i took the car elsewhere. the problem was a loose crimp, nothing more. cost me 150 rupees for labor.
cheers.
crackingride is offline   Reply With Quote
Old 28th July 2008, 14:20   #8
Senior - BHPian
 
KSM-Vtec's Avatar
 
Join Date: Jun 2008
Location: MH-02-India-Bombay-Bandra
Posts: 1,563
Thanked: 437 Times
Default

Hey i did face the same prob last saturday.....it was the relay in my case which had shotted after some rain water getting into it. I agree with what iceman91 says. It should be one of those 4 probs he has suggested. It could also be a loose connection somewhere. Neways you can chk for most of the probs yourself.
KSM-Vtec is offline   Reply With Quote
Old 28th July 2008, 21:13   #9
Senior - BHPian
 
nitrous's Avatar
 
Join Date: May 2004
Location: UAE/Lon/Madras
Posts: 6,966
Thanked: 282 Times
Default

Check AC condenser fan.
Even I had a similar problem and it turned out to be the fan. Replaced it and all was fine.
nitrous is offline   Reply With Quote
Old 30th July 2008, 14:22   #10
Senior - BHPian
 
KSM-Vtec's Avatar
 
Join Date: Jun 2008
Location: MH-02-India-Bombay-Bandra
Posts: 1,563
Thanked: 437 Times
Default

Any updates? have you been able to trace the problem?? Do keep us updated. And best of luck, hope its not a big problem.
KSM-Vtec is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Cedia : Check engine light just wont go away! mav2000 Technical Stuff 13 6th June 2012 16:44
My WagonR wont go beyond 140KMPH!! asad7874 Technical Stuff 35 28th November 2010 23:14
You wont believe which car recorded a 21% increase in sales GTO The Indian Car Scene 8 10th May 2005 15:56
Uh Oh...You wont like to see this Carrera GT GTO The International Automotive Scene 8 15th June 2004 15:25


All times are GMT +5.5. The time now is 05:31.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks