Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 22nd November 2010, 11:44   #2821
Senior - BHPian
 
Join Date: Dec 2007
Location: Dubai
Posts: 3,841
Thanked: 117 Times
Default

Quote:
Originally Posted by manikahuja View Post
...The TASS says drums are covered but not the front discs...

Quote:
Originally Posted by SS-Traveller View Post
Rubbish. Rest assured, discs are as much covered under warranty as drums.
What a set of jokers!

If drums, why not discs?

Give them a ear full! And when you get the feedback form and call, make sure you mention this and how you feel.
HappyWheels is offline   Reply With Quote
Old 22nd November 2010, 11:44   #2822
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,608
Thanked: 14,894 Times
Default

Discs are not just covered under warranty, they are covered under extended warranty as well!
Remember, many TASS people will try to make money even on under warranty items. I have lost quite a bit to Sanya motors Okhla and Automobile Sterling due to this. Do not make my mistakes.
tsk1979 is offline   Reply With Quote
Old 22nd November 2010, 11:55   #2823
Senior - BHPian
 
suman's Avatar
 
Join Date: Sep 2005
Location: Gurgaon
Posts: 4,589
Thanked: 256 Times
Default

Quote:
Originally Posted by manikahuja View Post
Has anybody got their discs replaced under warranty.
On at least two occasions, the last was at around 80k kms IIRC
suman is offline   Reply With Quote
Old 22nd November 2010, 12:22   #2824
BHPian
 
Join Date: May 2006
Location: On the road...
Posts: 173
Thanked: 80 Times
Default

Thanks for the quick responses. I will take them to task now. Great to get so many responses so quickly

Thanks
Traveler is offline   Reply With Quote
Old 22nd November 2010, 13:40   #2825
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,608
Thanked: 14,894 Times
Default

There is a sort of clang type sound, similar to a sound made when you go over a manhole, whenever I march from standstill. This is coming from somewhere in the rear diff
In very silent environments(eg late night) I can hear a faint hum while turning from the rear. However it does not always come.
Something wrong with LSD?
tsk1979 is offline   Reply With Quote
Old 22nd November 2010, 14:00   #2826
Senior - BHPian
 
suman's Avatar
 
Join Date: Sep 2005
Location: Gurgaon
Posts: 4,589
Thanked: 256 Times
Default

Quote:
Originally Posted by tsk1979 View Post
Something wrong with LSD?
The clang when marching from standstill may not necessarily indicate any problem. The hum - I'm not sure. Try taking a sweeping left handed or right handed curve (you know the types when you're getting off a flyover?) & keep an ear open for any clanging or clanking. If there is any, then its time to have the LSD checked.
suman is offline   Reply With Quote
Old 22nd November 2010, 14:02   #2827
BHPian
 
Join Date: May 2007
Location: Delhi/Noida
Posts: 52
Thanked: 6 Times
Default

Looks like you need to get the Trunk lock kit (also called the LSD kit in TASS parlance) changed.
I (and i guess Suman) got this changed as we too had the same noise from the rear when starting from standstill. This sound is more pronounced when you make a left/right turn at slow speeds or when the car moved from stationary when it is parked at an awkward angle (not all four wheels in the same plane)

Quote:
Originally Posted by tsk1979 View Post
There is a sort of clang type sound, similar to a sound made when you go over a manhole, whenever I march from standstill. This is coming from somewhere in the rear diff
In very silent environments(eg late night) I can hear a faint hum while turning from the rear. However it does not always come.
Something wrong with LSD?

Last edited by trance_nut : 22nd November 2010 at 14:05.
trance_nut is offline   Reply With Quote
Old 23rd November 2010, 18:18   #2828
BHPian
 
Join Date: Mar 2007
Location: Gurgaon
Posts: 154
Thanked: Once
Default

I have been having a problem for quite sometime. Somehow it has not been solved.
When I reverse and turn the wheel extreme right, then there is a clang sound from the front. They told me that it had to do with the centre pin. This was tightened and infact a local judgar was done when a extra washer was put. They told me that this is the final solution. After a couple of days of driving it has started again. What I have also noticed now that the turning radius (which as it is not too great in a Safari) has now become even worse.

What is the problem and what is the solution.

Do advice.
Country Road is offline   Reply With Quote
Old 24th November 2010, 10:47   #2829
BHPian
 
verditer's Avatar
 
Join Date: Mar 2010
Location: Hosur, Tamilnadu
Posts: 322
Thanked: 71 Times
Default

There is an iPod connector cable supplied to me with the Safari, but I can't find where I should connect it to the Alpine music system? There isn't any such plug holes.
Can someone tell me how to connect the iPod to the Alpine?
verditer is offline   Reply With Quote
Old 24th November 2010, 11:59   #2830
BHPian
 
stefanm's Avatar
 
Join Date: Aug 2007
Location: Goa
Posts: 212
Thanked: 2 Times
Default

Ok, after 2 years and much to my suprise the Safari is still pretty much working ok, except the interior light above the dashboard falling off for no reason again!

Now the latest thing happend last night whilst driving, suddenly the instument cluster backlight stopped working, I had checked the fuse under the steering column and it is fine, anyone have any ideas, i'm too scared to take it to any tata authorised service station over hear, as too many bits and pieces go missing or are left over in their spare parts bin!

Can anyone advise where to start diagnosis?

Cheers,

Stefan
stefanm is offline   Reply With Quote
Old 24th November 2010, 12:30   #2831
Senior - BHPian
 
anujmishra's Avatar
 
Join Date: Jun 2008
Location: Bangalore
Posts: 1,266
Thanked: 320 Times
Default

Quote:
Originally Posted by verditer View Post
There is an iPod connector cable supplied to me with the Safari, but I can't find where I should connect it to the Alpine music system? There isn't any such plug holes.
Can someone tell me how to connect the iPod to the Alpine?
You need to contact TASS for putting IPod cable connection. Actually port is at the back side of Alpine music system. They will bring from back and IPod side they will keep in glove box for connecting IPod.
anujmishra is offline   Reply With Quote
Old 24th November 2010, 17:35   #2832
BHPian
 
NiTviN's Avatar
 
Join Date: Mar 2009
Location: Bangalore
Posts: 83
Thanked: 6 Times
Default

Quote:
Originally Posted by anujmishra View Post
You need to contact TASS for putting IPod cable connection. Actually port is at the back side of Alpine music system. They will bring from back and IPod side they will keep in glove box for connecting IPod.
You can do it yourself. However you need to have the HU removal keys (normally small metal bands which can be inserted on either side of the HU and pull it out). Once the HU is out you can attach the cable yourself.
NiTviN is offline   Reply With Quote
Old 24th November 2010, 17:36   #2833
BHPian
 
sidcruise79's Avatar
 
Join Date: Aug 2008
Location: New Delhi
Posts: 122
Thanked: Once
Default Ipod connector

Quote:
Originally Posted by anujmishra View Post
You need to contact TASS for putting IPod cable connection. Actually port is at the back side of Alpine music system. They will bring from back and IPod side they will keep in glove box for connecting IPod.
You can actually do it yourself, I did it for mine...
You have to pull out the Alpine Head Unit with the supplied two metal thingies. U dont have to unplug anything, just plug in one end of the cable (the other side of the ipod connector) into the back of the Head Unit, u will find the slot without a problem. Then route the cable into the glove box (there are a lot of big gaps all over) where u can plug in & store your ipod.
sidcruise79 is offline   Reply With Quote
Old 24th November 2010, 18:18   #2834
BHPian
 
rajismine's Avatar
 
Join Date: Sep 2006
Location: Pune
Posts: 514
Thanked: 247 Times
Default

+1 from me. I got my discs changed under extended warranty. However, they said only discs wont be changed and they should put in new pads as well when discs are changed else there could be uneven wear on the discs. The pads are not covered by warranty I was told and they charged me Rs 2100 for them (Labour free under extended warranty :-))
Quote:
Originally Posted by tsk1979 View Post
Discs are not just covered under warranty, they are covered under extended warranty as well!
Remember, many TASS people will try to make money even on under warranty items. I have lost quite a bit to Sanya motors Okhla and Automobile Sterling due to this. Do not make my mistakes.
rajismine is offline   Reply With Quote
Old 25th November 2010, 13:39   #2835
Senior - BHPian
 
anujmishra's Avatar
 
Join Date: Jun 2008
Location: Bangalore
Posts: 1,266
Thanked: 320 Times
Default Engine Jerk Issue update

Today I visited KHT for comprehensive checkup of jerk problem in engine. However in my Safari it is not frequent but occasionally I get that. Service Head of Safari at KHT Ramesh did thorough checkup and checked all vacuum hoses and cleared the sedimenter.

Meanwhile before starting I PMed verditer also as he is facing this issue too frequently. I went for test drive on my Safari with Ramesh for 10 - 12 Kms. Not a single time problem jerk appeared. All acceleration was very smooth. They checked the ECU too and there was no error codes.

By then verditer also reached KHT upon my call and we then went for 20 - 24 Kms of drive on his Safari (Black color EX) along with Ramesh. Not a single time this problem appeared in verditer's Safari as well. While returning verditer himself drove and confirmed there is no jerk. In the today morning itself he felt this problem.

We took 2 - 3 days time and will report to KHT after 2-3 days about the jerk reappearance if any.

KHT Service People were more than generous to help us for our reported issue. They spent 2-2.5 hours just to check the issue. Thanks to them.

Last edited by anujmishra : 25th November 2010 at 13:40.
anujmishra is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Skoda Laura: Problems & solutions thread anandbhat Technical Stuff 1010 24th November 2016 13:48
Tata Safari - Technical Specifications & Feature List Stratos Technical Stuff 11 24th June 2011 20:48
technical aspects in technical driving ram_hyundai Technical Stuff 1 2nd February 2008 21:12


All times are GMT +5.5. The time now is 02:03.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks