Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 15th January 2009, 00:38   #496
Senior - BHPian
 
Join Date: Jul 2008
Location: Bangalore
Posts: 2,018
Thanked: 360 Times
Default

Quote:
Originally Posted by Bull_Twin View Post
No idea if its Turbo hose or what.. but its orange or red colour. The vehicle didnt accept any acceleration and if accelerator is pressed it gives loud hsssss noise.
Have a look at this thread , There is a red colored rubber hose in the picture is it the same ?

http://www.team-bhp.com/forum/techni...er-tubing.html (Turbocharger failure in new safari 2.2VTT(Edit: Solved; only a cracked rubber tubing))

IMHO If it is purely rubber failure then not a serious issue , Ask service center to tighten the metal clamps properly so the rubber hose does not slip.
Changing Turbo charger is not advisable just for rubber failure because factory fitted parts are always better , other with more experience and knowledge may advice here.

Quote:
Originally Posted by Bull_Twin View Post
Another issue which has been reported earlier by many guys is drifting towards left when break is applied. Hope these are not serious.
Drifting towards left is serious , It does not happen at normal speeds and indicates that break pressure is unequal please get it checked and rectified.
amitk26 is offline   Reply With Quote
Old 15th January 2009, 01:03   #497
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,608
Thanked: 14,894 Times
Default

On revving I head "popping" sounds from somewhere behind the dashboard. I have checked sound is not from engine. So the most likely candidate is air bubbles in water circuit. I think this happened while changing thermostat.
Any harmful effects of the same?
tsk1979 is offline   Reply With Quote
Old 31st January 2009, 00:05   #498
BHPian
 
Join Date: Oct 2008
Location: Delhi
Posts: 26
Thanked: 4 Times
Default

Quote:
tsk1979

Its 9pm, on the highway, I see the service light coming on. It stays for 2 seconds, and then goes away. Happens a few times.
Call up the dealer helpline. and he says not to worry.
Quote:

jkdas

Saw service light on for a sec or so. I knew why; was on tsk1979 mode for 3-4days. I get 13kmpl

Back to my driving style. Red lining on lower gears helped push the carbon out after a week.
The service Light was on for 1-2 seconds.. Is it something serious or theres nothing to worry?

Even a slight 'khat' while driving.. reminds me of Team-BHP's Safari niggle list..
Thanks for making us aware of these issues....

Cheeeeers..
Bull_Twin is offline   Reply With Quote
Old 31st January 2009, 00:44   #499
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,608
Thanked: 14,894 Times
Default

Well service light can come for a number of reasons. It could be something mundane like fuel clogging, fixable by high revving, something serious like common rail failure or injector problem(which is the case for mine)
tsk1979 is offline   Reply With Quote
Old 31st January 2009, 00:48   #500
Senior - BHPian
 
harjeev's Avatar
 
Join Date: May 2006
Location: New Delhi
Posts: 1,896
Thanked: 256 Times
Default

I have noticed my cars service coming on once since I have owned it.
And as it came only once I have not really bothered about it

Just praying that even if it does again, it should not be serious and covered under warranty
harjeev is offline   Reply With Quote
Old 31st January 2009, 00:53   #501
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,608
Thanked: 14,894 Times
Default

Normally if there is a problem the service light comes on again and again, and you can often cause it to come on at will since you get to know at what rpm's etc., it comes on.
In your case it came on just once, so don't worry. Just ask them to clear error code at service.
tsk1979 is offline   Reply With Quote
Old 31st January 2009, 10:39   #502
Senior - BHPian
 
Join Date: May 2007
Location: Bangalore
Posts: 3,649
Thanked: 242 Times
Default

If the service light comes on even for a sec, it will be logged by the ECU, ask the T.A.S.S to check using their Diag tool and if it comes frequently or the frequency increases for the same logged DTC, chances of failure of that particular component in the near future are high, get it replaced under warranty.

If its only once, no worries.
dadu is offline   Reply With Quote
Old 31st January 2009, 11:02   #503
Distinguished - BHPian
 
DerAlte's Avatar
 
Join Date: Mar 2007
Location: Bangalore
Posts: 8,063
Thanked: 2,859 Times
Default

Is it OK for the service light to come on before the engine is switched on? In mine, it comes on along with the glow-plug indicator and switches off when the GPI goes off.
DerAlte is offline   Reply With Quote
Old 31st January 2009, 11:14   #504
Senior - BHPian
 
harjeev's Avatar
 
Join Date: May 2006
Location: New Delhi
Posts: 1,896
Thanked: 256 Times
Default

I think that should be normal as this is how it happens in my beast.

My beast is currently off to corbett ( my bro has taken it)
Once he comes back I will take it straight to the service center for a checkup
harjeev is offline   Reply With Quote
Old 31st January 2009, 14:52   #505
Senior - BHPian
 
raj_5004's Avatar
 
Join Date: Jan 2008
Location: Dubai/Mumbai
Posts: 5,049
Thanked: 1,914 Times
Default

hi guys, i think this is the right thread to post this query of mine:

i am from mumbai & we have a safari 2.2 VX 4x2 which we purchased around november 2007. now since my brother who uses this vehicle is shifting, he wants to sell this vehicle. a very close friend of my dad is interested & he is quoting a price of 7.2 lakhs.

now ours is a top end version which is bought for almost 13 lakhs. the SUV has run 45,000 kms. it has never been in an accident and is almost scratchless, kudos to my brother!
so is the quoted price ok?

problems rectified recently by the A.S.S:

* AC evaporator coil replaced
* rear right window was jammed, rectified
* dashboard was rattling, rectified

current issues:

* boot door and front passenger door still rattles.
* DVD screens dont work, was rectified, again conked off.
* slight squeaking can be heard sometimes from the front suspension over rough roads.

now since this person is my dad's friend, he has not been kept in dark & is aware of all these issues.

kindly advise. thanks.

Last edited by raj_5004 : 31st January 2009 at 14:54.
raj_5004 is offline   Reply With Quote
Old 31st January 2009, 16:21   #506
Distinguished - BHPian
 
jkdas's Avatar
 
Join Date: Sep 2005
Location: Thiruvananthapu
Posts: 9,575
Thanked: 1,234 Times
Default

Quote:
Originally Posted by tsk1979 View Post
Normally if there is a problem the service light comes on again and again, and you can often cause it to come on at will since you get to know at what rpm's etc., it comes on.
In your case it came on just once, so don't worry. Just ask them to clear error code at service.
I had it twice. Both when I was on a get more mileage drive (didnt drive above 2k for 50-100kms). The instant I saw the service light, I revved to red lines. Saw lot of smoke when i did that and I hence presume it was coz of carbon clogging.

Quote:
Originally Posted by dadu View Post
If the service light comes on even for a sec, it will be logged by the ECU, ask the T.A.S.S to check using their Diag tool and if it comes frequently or the frequency increases for the same logged DTC, chances of failure of that particular component in the near future are high, get it replaced under warranty.

If its only once, no worries.
I have to ask them to reset it?


Quote:
Originally Posted by DerAlte View Post
Is it OK for the service light to come on before the engine is switched on? In mine, it comes on along with the glow-plug indicator and switches off when the GPI goes off.
I guess it like an engine check you have with MPFI cars.
jkdas is offline   Reply With Quote
Old 31st January 2009, 17:08   #507
Senior - BHPian
 
Join Date: May 2007
Location: Bangalore
Posts: 3,649
Thanked: 242 Times
Default

Quote:
Originally Posted by jkdas View Post
I have to ask them to reset it?
They will clear it after reading the code generated.
dadu is offline   Reply With Quote
Old 31st January 2009, 18:13   #508
BHPian
 
maheshmenon's Avatar
 
Join Date: Aug 2008
Location: Chennai / Bangalore
Posts: 123
Thanked: 4 Times
Smile Service Light

Quote:
Originally Posted by DerAlte View Post
Is it OK for the service light to come on before the engine is switched on? In mine, it comes on along with the glow-plug indicator and switches off when the GPI goes off.
That's just normal, its just a System Self Test before you start the engine.

Cheers
maheshmenon is offline   Reply With Quote
Old 4th February 2009, 11:34   #509
Distinguished - BHPian
 
jkdas's Avatar
 
Join Date: Sep 2005
Location: Thiruvananthapu
Posts: 9,575
Thanked: 1,234 Times
Default

Got this twice!

I unlock the Safari, get in and crank!

No lights, no power,nothing! BLANK!

Try unlocking/locking via remote: no use.

I wait few minutes and things are back to normal but all gets reset (head unit settings etc)

Whats happening?
jkdas is offline   Reply With Quote
Old 4th February 2009, 11:39   #510
Senior - BHPian
 
nitrous's Avatar
 
Join Date: May 2004
Location: UAE/Lon/Madras
Posts: 6,957
Thanked: 247 Times
Default

^^Must be something to do with the Immobiliser module,jkd
nitrous is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Skoda Laura: Problems & solutions thread anandbhat Technical Stuff 1010 24th November 2016 13:48
Tata Safari - Technical Specifications & Feature List Stratos Technical Stuff 11 24th June 2011 20:48
technical aspects in technical driving ram_hyundai Technical Stuff 1 2nd February 2008 21:12


All times are GMT +5.5. The time now is 01:57.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks