Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 8th July 2013, 09:13   #5221
BHPian
 
Join Date: Mar 2006
Location: Mumbai
Posts: 190
Thanked: 14 Times
Default re: The Tata Safari 2.2L Technical / Problems Thread

Quote:
Originally Posted by lodhra View Post


I HAVE ANOTHER PHANTOM PROBLEM


t seems my luck after each service just runs out. First after the above problems were resolved some one hit my windshield with a playing marble and it got cracked

Now second problem which I would require urgent suggestion. During my last visit to TASS they had informed me of an loose connection in the ignition key system and informed me it is not a thing to worry only sometimes the headlights may not turn up or it may show service light . To fix it they may require to change the entire assemble which is not under warranty so do not do anything unless required

Now from yesterday I have a peculiar problem with central locking

1>When i turn the ignition the DOOR OPEN light does not turn off. This is a problem as when one parks the car and presses the LOCK button the car sets of the burglar alarm which is causing nuisance

2>The only way to stop this is to UNLOCK THE CAR, than MANUALLY PRESS THE door lock button on DRIVER SIDE and than close the door. This does not cause any problem

3>I may be going to TASS in few days to replace the windshield but i wanted some definitive inputs from you how to solve this problem

I have checked under the dashboard and there is no cut wiring to the doors. I have checked all other doors too.

Hello

I would like some suggestions on the central locking problem discussed above before I visit TASS , if something could be done on my own. I have learnt from these threads that the ECM for central locking is different and sometimes cleaning the connectors help. If it could be a DIY i would like to try. TASS will push for entire ignition assembly replacement which is not covered under warranty and I am not sure if they do very good job.
So please suggest as I anyways have to go for windshield replacement

Experts please help
lodhra is offline   Reply With Quote
Old 8th July 2013, 11:13   #5222
Senior - BHPian
 
amit_mechengg's Avatar
 
Join Date: Dec 2007
Location: Pune
Posts: 2,306
Thanked: 967 Times
Default re: The Tata Safari 2.2L Technical / Problems Thread

Once the D04 version is flashed onto the ECU on BS4 models, you will very soon get an error P2018, which will not put the engine check light on at all, nor this error will show on the OBD scanners.

When you take your truck back to the TASS after a small run and again hook the ECU it will show you the error. Just clear that error off and you are good to go.

There is no description of the error, but i think its the swirl error.
amit_mechengg is offline   (1) Thanks Reply With Quote
Old 8th July 2013, 19:12   #5223
BHPian
 
Join Date: Mar 2006
Location: Mumbai
Posts: 190
Thanked: 14 Times
Default

Hello

In response to my door open light problem in the car

After much troubleshoot it seems water must have gone nto some door connector and the citcuit is not getting complete and showing door light open. My questions if anyone can help

1) is there a switch in each door which shows door open close command
2) i have tried spraying wd40 in each latch. Will do it again tomm and see if the door open light goes

Anyone having ideas how o fix this. I had called MINDA who are oem for central lock but they said that since car is locking unlocking well its not their problem. The TASS advisor on phone said if possible to spray wd40 in each latch and check else come over. Its raining very heavy here so i would like your opinions about how to fix this door open light .
lodhra is offline   Reply With Quote
Old 8th July 2013, 22:20   #5224
BHPian
 
Join Date: Mar 2006
Location: Mumbai
Posts: 190
Thanked: 14 Times
Default re: The Tata Safari 2.2L Technical / Problems Thread

Just wanted to add to the above

The interior light switch when set to door earlier was not functioning when this happened. I pulled out the diagnostic follow me home fuse and reinstated and the light came on, but it does not go off when the door is closed. I have read somewhere that this switch tells the instrument cluster of Door ajar sign. This is seen with all the three lights of front middle and rear

I have tried putting wd 40 in all door latch. One more thing is before this door ajar thing happened i tested my fog lamp buttons . Now with this error the rear fog lamp button is not working. I pulled out its fuse from under the hood but could not make out a thing. Since its 5A i would replace and see if it works again tomm.

I am just trying my best to figure out what the issue could be so I can be somewhat knowledgable when i go to TASS

so can anyone help me out with this. I have tried reading all threads here and also on the net, but none give any explanation of how to troubleshoot the DOOR AJAR light problem in safari.

Any help appreciated.

Last edited by lodhra : 8th July 2013 at 22:22.
lodhra is offline   Reply With Quote
Old 9th July 2013, 11:06   #5225
BHPian
 
Join Date: Oct 2009
Location: Bangalore
Posts: 103
Thanked: 17 Times
Default re: The Tata Safari 2.2L Technical / Problems Thread

Quote:
Originally Posted by bj96 View Post
Looks like turbo oil return line. Part costs about 450/- and labour about 300/- at TASS. New pipe they fit has a better design. Mine had that leak too. It was slow 1 or 2 drops overnight after driving.

-BJ
Below is the update on the issue I mentioned earlier. TASS diagnosed that the oil leak is exactly due to what you mentioned (turbo oil return line). However, instead of replacing the part they fixed it with some glue and the issue returned soon after the service. So, my friend returned the vehicle back to TASS; hopefully they replace the part this time.

For the issue of errant speedo meter/ service light TASS initially said they could not find anything. However, when insisted after returning the vehicle, now they found that the 'speedo meter gear' has cracks and needs replacement. The part costs 4k approx., so my friend wants to know from experts if this is a correct diagnosis. Also the part is not available with TASS right now, so we are talking about delays as well. Has anyone come across this part failure? If yes please share the cost of repair/ time taken for replacement as well. Any input will be useful in getting this ongoing issue fixed.

Thanks,
Sunil.
sunil_k_u is offline   Reply With Quote
Old 9th July 2013, 15:17   #5226
Distinguished - BHPian
 
saket77's Avatar
 
Join Date: Dec 2012
Location: Ranchi
Posts: 2,948
Thanked: 2,841 Times
Default re: The Tata Safari 2.2L Technical / Problems Thread

Quote:
Originally Posted by sunil_k_u View Post
For the issue of errant speedo meter/ service light TASS initially said they could not find anything. However, when insisted after returning the vehicle, now they found that the 'speedo meter gear' has cracks and needs replacement.

Thanks,
Sunil.
That's probably the worm gear. It can lead to flickering speedo needle, but there can be other factors too. The price looks quite steep at 4k for just the gear! Is is the price for the speedo meter or complete speedo console?

Last edited by saket77 : 9th July 2013 at 15:18.
saket77 is offline   (1) Thanks Reply With Quote
Old 9th July 2013, 18:21   #5227
Senior - BHPian
 
Join Date: May 2007
Location: Bangalore
Posts: 3,649
Thanked: 242 Times
Default re: The Tata Safari 2.2L Technical / Problems Thread

Quote:
Originally Posted by lodhra View Post
Just wanted to add to the above

The interior light switch when set to door earlier was not functioning when this happened. I pulled out the diagnostic follow me home fuse and reinstated and the light came on, but it does not go off when the door is closed. I have read somewhere that this switch tells the instrument cluster of Door ajar sign. This is seen with all the three lights of front middle and rear

I have tried putting wd 40 in all door latch. One more thing is before this door ajar thing happened i tested my fog lamp buttons . Now with this error the rear fog lamp button is not working. I pulled out its fuse from under the hood but could not make out a thing. Since its 5A i would replace and see if it works again tomm.

I am just trying my best to figure out what the issue could be so I can be somewhat knowledgable when i go to TASS

so can anyone help me out with this. I have tried reading all threads here and also on the net, but none give any explanation of how to troubleshoot the DOOR AJAR light problem in safari.

Any help appreciated.
It seems like an electrical problem to me, but you can also check if all the latches are closing properly after you press the lock button on the remote, just take a peek inside from the opoosite window to check if they are closed properly, if they are half closed or pop out, it could be a problem, also check for rear door.
dadu is offline   (1) Thanks Reply With Quote
Old 9th July 2013, 19:29   #5228
BHPian
 
Join Date: Mar 2006
Location: Mumbai
Posts: 190
Thanked: 14 Times
Default

Hello dadu


Thank you so much. I have checked everything, sprayed wd40. The door light does not go off when doors are closed. Also the 10 sec auto lock function after one starts teh car sets in but the door lock just flicker they do not close.


What i have understood is there is some loose connection in the ignition key. Sometimes when i press the key inside hard the door ajar light flickers and goes away. I will show this to tass. They had last time during my service told me there is loose contact in the ignition assembly and it cannot be repaired. One needs to replace the entire assembly which is not under warranty. This defect was from when i bought the car but it came to notice after warranty period.
They told me that occasionally the headlight may not turn up or i may get MIL light but it will go no need to worry

Its just so frustrating o know this small niggles. I will go to TASS as i have to replace my windshield.

Is there something more i should look into

One more thing, since this has happened, the diesel flap button and rear fog lamp does not operate.

So any suggestions from your side and i will tell tass people to double check on those lines.

I go to forest and many times keep my car unattended hence i do not want to go without an immobilizer .

Last edited by lodhra : 9th July 2013 at 19:32.
lodhra is offline   Reply With Quote
Old 9th July 2013, 21:25   #5229
BHPian
 
bj96's Avatar
 
Join Date: Dec 2008
Location: Pune
Posts: 766
Thanked: 117 Times
Default re: The Tata Safari 2.2L Technical / Problems Thread

Quote:
Originally Posted by lodhra View Post
... ignition assembly and it cannot be repaired. One needs to replace the entire assembly which is not under warranty. This defect was from when i bought the car but it came to notice after warranty period.
They told me that occasionally the headlight may not turn up or i may get MIL light but it will go no need to worry
...
I think it is dangerous to drive in this condition (what if headlight goes off suddenly and you are driving in rain/dark?), it may also cause spark/fire etc. Better to get it attended. Don't ignore. If your car is out of warranty, go to outside auto electrician and get it checked in front of you. If the assembly really needs to be changed, get it changed at TASS (again in front of you).

If this is just an issue with door switch/latch (which I doubt, the way you are describing) it can be cleaned/fixed. I had posted a link somewhere in this thread, on how to do it. It is DIY- if you know how to take out door panels.

-BJ
bj96 is offline   (1) Thanks Reply With Quote
Old 16th July 2013, 10:17   #5230
Senior - BHPian
 
Rahulk76's Avatar
 
Join Date: Sep 2005
Location: PNQ
Posts: 1,132
Thanked: 204 Times
Default re: The Tata Safari 2.2L Technical / Problems Thread

Off late the sound exactly similar to this is being heard.


Safari experts any clue to this if this is indeed the timing belt tensioner or something else before i head to TASS?
Rahulk76 is offline   Reply With Quote
Old 19th July 2013, 21:22   #5231
BHPian
 
Join Date: Oct 2009
Location: Bangalore
Posts: 103
Thanked: 17 Times
Default re: The Tata Safari 2.2L Technical / Problems Thread

Quote:
Originally Posted by saket77 View Post
That's probably the worm gear. It can lead to flickering speedo needle, but there can be other factors too. The price looks quite steep at 4k for just the gear! Is is the price for the speedo meter or complete speedo console?

Thanks Saket for the pointer. My friend got his vehicle back with replaced speedo meter gear, speedo meter sensor and one more part which I could not quite catch over the phone when he told me. Anyways, I have asked him to send me a scanned copy of the service bill. I shall upload it here for the benefit of others who get in to similar issues (I sincerely hope no one gets, actually)

The issue looks to be fixed as of now. Though we had to do follow-ups, use the 'complaint button' on Tata Motors website etc for the delay in getting the parts, the car is finally back. My friend agreed to keep me posted on the issue as well.
sunil_k_u is offline   (1) Thanks Reply With Quote
Old 21st July 2013, 21:58   #5232
Senior - BHPian
 
mercedised's Avatar
 
Join Date: Nov 2009
Location: Indore
Posts: 1,054
Thanked: 146 Times
Default re: The Tata Safari 2.2L Technical / Problems Thread

Suddenly, the instrument cluster went dead today, there are no lights (brake, check engine, etc..) neither on switching ON ignition nor on switching ON tha car. I mean no lights, no Kms reading, The ODOmeter is blank, the RPM meter is not working, the speedometer is not running. Although the car starts fine. It happened an hour back, now I am back at home. What might be the problem?

PS: I checked all the fuses inside fuse box near steering, all of them are fine. The only light that works is the High beam light.

Meanwhile, yesterday the silencer pipe got broken from the engine end, and the truck is making meaty TRUCK noise now! I love it, the groan!

Last edited by mercedised : 21st July 2013 at 22:00.
mercedised is offline   Reply With Quote
Old 22nd July 2013, 12:09   #5233
Senior - BHPian
 
Join Date: Jul 2008
Location: Bangalore
Posts: 2,018
Thanked: 360 Times
Default re: The Tata Safari 2.2L Technical / Problems Thread

Folks where can I find the cotton tape sort used to secure/ insulate wires in engine bay and what is the correct name for this ?

I opened engine bay after service and saw an exposed wire coming out of rubber casing. The cotton tape is unwound and the casing is also brittle but I tucked the wire in it for protection. Is it OK to use PVC electrical insulation tape in engine bay ( Steelgrip ) ?

One more question what is the Diesel filter change interval , In my booklet it is given 30K but remember reading somewhere that it was changed to 15K.

Diesel filter is changed by A.S.S but I am thinking of keeping the interval to 30K from now on.
amitk26 is offline   Reply With Quote
Old 22nd July 2013, 14:10   #5234
Senior - BHPian
 
mercedised's Avatar
 
Join Date: Nov 2009
Location: Indore
Posts: 1,054
Thanked: 146 Times
Default re: The Tata Safari 2.2L Technical / Problems Thread

Quote:
Originally Posted by amitk26 View Post
One more question what is the Diesel filter change interval , In my booklet it is given 30K but remember reading somewhere that it was changed to 15K.

Diesel filter is changed by A.S.S but I am thinking of keeping the interval to 30K from now on.
You can use the Steelgrip tape safely. (Make sure you don't get the duplicate one, or Get an Anchor ELECTRICAL Tape).

I change the diesel filter only at 30K kms and the car has run 1.3L kms, I am more worried about the sedimentor it has tobe changed at 1L kms which I have not! This heck thing costs 4.5K at TASC.
mercedised is offline   (1) Thanks Reply With Quote
Old 22nd July 2013, 14:18   #5235
BHPian
 
Prowler's Avatar
 
Join Date: Jul 2008
Location: Madras
Posts: 447
Thanked: 231 Times
Default re: The Tata Safari 2.2L Technical / Problems Thread

Quote:
Originally Posted by mercedised View Post
Suddenly, the instrument cluster went dead today, there are no lights (brake, check engine, etc..) neither on switching ON ignition nor on switching ON tha car. I mean no lights, no Kms reading, The ODOmeter is blank, the RPM meter is not working, the speedometer is not running. Although the car starts fine. It happened an hour back, now I am back at home. What might be the problem?

PS: I checked all the fuses inside fuse box near steering, all of them are fine. The only light that works is the High beam light.

Meanwhile, yesterday the silencer pipe got broken from the engine end, and the truck is making meaty TRUCK noise now! I love it, the groan!
Use a test bulb or a VOM to see if the fuse cluster near the steering has 12 V coming in. Check the fuses in the Engine compartment as well. It may feed the instrument clusters as well the lights inside.

Attend to the silencer pipe ASAP or you will be breathing the exhaust fumes. My earlier TCIC developed a crack in the exhaust pipe in the engine bay and I could sense the fumes. In DICOR, you may not even sense the fumes. Drive with the windows lowered until you attend to this issue.
Prowler is online now   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Skoda Laura: Problems & solutions thread anandbhat Technical Stuff 1010 24th November 2016 13:48
Tata Safari - Technical Specifications & Feature List Stratos Technical Stuff 11 24th June 2011 20:48
technical aspects in technical driving ram_hyundai Technical Stuff 1 2nd February 2008 21:12


All times are GMT +5.5. The time now is 17:34.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks