Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 12th February 2009, 09:46   #541
Senior - BHPian
 
suman's Avatar
 
Join Date: Sep 2005
Location: Gurgaon
Posts: 4,589
Thanked: 256 Times
Default

Quote:
Originally Posted by jkdas View Post
Came home and checked. There is a change in engine noise and air filter things shows RED!
Any excessive smoke (white)? Any tappet clatter?

Also sounds like your air cleaner element is clogged.
suman is offline   Reply With Quote
Old 12th February 2009, 09:47   #542
Senior - BHPian
 
zenx's Avatar
 
Join Date: Oct 2004
Location: Bangalore
Posts: 1,056
Thanked: 65 Times
Default

Clutch slippage at 29k ? Scary. I guess this is covered under warranty as well ?
BTW, when I went to get the LX I'm looking at buying evaluated at Concorde, Begur Road, they mentioned that the noise between 1500-2000 is normal, and the mech called it a "VTT" sound. What exactly causes this - the turbo ? Its not high pitched, but a whup-whup-whup (higher speed than that) kind of rasp. [Oh shucks, its not easy to explain sounds ]
zenx is offline   Reply With Quote
Old 12th February 2009, 13:33   #543
Distinguished - BHPian
 
jkdas's Avatar
 
Join Date: Sep 2005
Location: Thiruvananthapu
Posts: 9,575
Thanked: 1,234 Times
Default

Quote:
Originally Posted by anupmathur View Post
JKDas, this is a classic symptom of clutch slippage!
Does not seem related to a choked air filter.

I couldn't understand what you mean by 'no turbo'.
The air filter clog window showed red.

Quote:
Originally Posted by suman View Post
Any excessive smoke (white)? Any tappet clatter?

Also sounds like your air cleaner element is clogged.
Was late night and hence didnt see. There was no turbo spool sound and it wasnt going above 80kmph.

And

today morning , things are back to normal; there is turbo and the clog check of air filter doesnt show red.

I gave it to TASS and they just called up and said they didnt see anything in their scan. They deleted old service alerts logs and have reset it.

I will be traveling this weekend and that should make it 30K . Will check the rest when I go for the 30k service.

Need some help here. I also saw some grey colored sponge/padding inside the engine cabin. Looked like it fell of from someplace and since I couldnt figure out I pulled it off (think it was torn too and hence was worried). I have asked TASS to check that and put a new one from wherever it fell off. Any idea what this is and from where it fell off? It was kind of dark grey color.
jkdas is offline   Reply With Quote
Old 12th February 2009, 14:00   #544
Senior - BHPian
 
Join Date: Sep 2007
Location: New Delhi
Posts: 3,066
Thanked: 242 Times
Default

Quote:
Originally Posted by jkdas View Post
I also saw some grey colored sponge/padding inside the engine cabin. Looked like it fell of from someplace and since I couldnt figure out I pulled it off (think it was torn too and hence was worried). I have asked TASS to check that and put a new one from wherever it fell off. Any idea what this is and from where it fell off? It was kind of dark grey color.
Is that the colour of the insulation material used on the underside of the bonnet? Quite possibly a piece has fallen off from there.
anupmathur is offline   Reply With Quote
Old 12th February 2009, 14:07   #545
Senior - BHPian
 
Join Date: May 2007
Location: Bangalore
Posts: 3,649
Thanked: 242 Times
Default

Quote:
Originally Posted by jkdas View Post
Need some help here. I also saw some grey colored sponge/padding inside the engine cabin. Looked like it fell of from someplace and since I couldnt figure out I pulled it off (think it was torn too and hence was worried). I have asked TASS to check that and put a new one from wherever it fell off. Any idea what this is and from where it fell off? It was kind of dark grey color.
The Sponge 1 inch strip is from the top on the radiator (width of it).
dadu is offline   Reply With Quote
Old 12th February 2009, 15:29   #546
BHPian
 
dkamath's Avatar
 
Join Date: May 2006
Location: Bangalore
Posts: 525
Thanked: 59 Times
Default

I don't think it's from either the bonnet or the radiator area.
Have seen this PU foam-like material come off from its seating area, quite often, and all i do is stuff it back in place. It's placed below the alternator(?) and along the length of the car, possibly supported by the chassis. Seems more like a heat shield to me. And yes jkdas, it also appears to be torn/split along its length, apparently for no real reason at all, hehe.
dkamath is offline   Reply With Quote
Old 12th February 2009, 15:42   #547
Senior - BHPian
 
Join Date: Dec 2007
Location: Dubai
Posts: 3,841
Thanked: 117 Times
Default

Quote:
Originally Posted by dkamath View Post
I... And yes jkdas, it also appears to be torn/split along its length, apparently for no real reason at all, hehe.
Rats? Do you have rats at your place, JK?
HappyWheels is offline   Reply With Quote
Old 12th February 2009, 22:57   #548
Distinguished - BHPian
 
jkdas's Avatar
 
Join Date: Sep 2005
Location: Thiruvananthapu
Posts: 9,575
Thanked: 1,234 Times
Default

Quote:
Originally Posted by dadu View Post
The Sponge 1 inch strip is from the top on the radiator (width of it).
Will check this tomorrow morning.


Quote:
Originally Posted by dkamath View Post
I don't think it's from either the bonnet or the radiator area.
Have seen this PU foam-like material come off from its seating area, quite often, and all i do is stuff it back in place. It's placed below the alternator(?) and along the length of the car, possibly supported by the chassis. Seems more like a heat shield to me. And yes jkdas, it also appears to be torn/split along its length, apparently for no real reason at all, hehe.
Looks like this one and even the TASS guy said so over the phone and not to worry. I want it back it back though and will get it when i take for 30k service.

Quote:
Originally Posted by HappyWheels View Post
Rats? Do you have rats at your place, JK?
My doberman say's no

The air filter indicator shows read again. I opened it up and didnt feel it to be that clogged. How much will this cost? I intend to replace it on saturday. Wont let my 2.2L gasping for O2.

Last edited by jkdas : 12th February 2009 at 22:59.
jkdas is offline   Reply With Quote
Old 13th February 2009, 11:22   #549
Senior - BHPian
 
suman's Avatar
 
Join Date: Sep 2005
Location: Gurgaon
Posts: 4,589
Thanked: 256 Times
Default

Quote:
Originally Posted by jkdas View Post
The air filter indicator shows read again. I opened it up and didnt feel it to be that clogged. How much will this cost? I intend to replace it on saturday. Wont let my 2.2L gasping for O2.
500 odd rupees, get it changed. It affects the performance as well as the mileage.
suman is offline   Reply With Quote
Old 16th February 2009, 13:11   #550
BHPian
 
Join Date: May 2008
Location: Bangalore
Posts: 31
Thanked: Once
Default Oil Leak

After every long ride of over 100 KM, I noticed oil leak (very slight) from my Safari, below the engine bay. Took it to the TASC last weekend. They've told that the "Assembly Oil Separator" was defective, and they've replaced it under warranty.

I couldn't find any one else reporting this problem, hence mentioning the same.
anilrs is offline   Reply With Quote
Old 16th February 2009, 13:54   #551
BHPian
 
smsrini's Avatar
 
Join Date: Sep 2007
Location: Bangalore
Posts: 959
Thanked: 213 Times
Default KRrr Updates please

Dadu,

What is the experience in the last 10days after changing the EGR valve ?

thanks
Srini
smsrini is offline   Reply With Quote
Old 17th February 2009, 11:35   #552
BHPian
 
Join Date: Oct 2008
Location: Delhi
Posts: 26
Thanked: 4 Times
Default

Quote:
Originally Posted by jkdas View Post

Was late night and hence didnt see. There was no turbo spool sound and it wasnt going above 80kmph.
This is for the 3rd time in 3500KM, Hose Pipe came out again. Result: No turbo.. Max speed 40-60Km/Hr
I am fed up with the temporary tightening of the clamp.. Yesterday night 2AM, guy at Sameer motors Karnal helped me out.

Can somebody please update me what can be wrong. Whenever I take it on a long drive, Highway.. The Hose pipe comes out. What can be replaced in this case?... Bangalore centers seems to replace parts quickly.

Ohhhhhhh Safariiii
Bull_Twin is offline   Reply With Quote
Old 17th February 2009, 12:40   #553
Senior - BHPian
 
Join Date: May 2007
Location: Bangalore
Posts: 3,649
Thanked: 242 Times
Default

Quote:
Originally Posted by smsrini View Post
Dadu,

What is the experience in the last 10days after changing the EGR valve ?

thanks
Srini
Will provide feedback by the end of this week.

Quote:
Originally Posted by Bull_Twin View Post
This is for the 3rd time in 3500KM, Hose Pipe came out again. Result: No turbo.. Max speed 40-60Km/Hr
I am fed up with the temporary tightening of the clamp.. Yesterday night 2AM, guy at Sameer motors Karnal helped me out.

Can somebody please update me what can be wrong. Whenever I take it on a long drive, Highway.. The Hose pipe comes out. What can be replaced in this case?... Bangalore centers seems to replace parts quickly.

Ohhhhhhh Safariiii
You shoudl ask them to make the metal pipe surface jagged or uneven/ rough by using a filer with a "light hand". it wont slip off then.
dadu is offline   Reply With Quote
Old 18th February 2009, 21:55   #554
BHPian
 
Abhiknov's Avatar
 
Join Date: Oct 2008
Location: Gurgaon
Posts: 49
Thanked: 0 Times
Default

3000 kms on my safari....and the following observations
1. At 80+ speed, Driver and opposite side window makes strong hissing sound like the window glass has been left partially open.
2. Steering makes a hissing sound at full tilt on both sides.
3. Dashboard buttons go on and off in different ways. Some remain depressed while on, others come back to original position after on.
4. The vehicle is slightly tilted towards its right side(driver's side)
5. Front window motors sound very strained while rolling up the glass.
6. There is a lot of vibration in lower gears and also if u drop speed in heigher gear and then try and accelerate without changing gears.
7. Gearshift and clutch pedal is harder than expected.
8. Slight pulse is felt in the clutch while removing foot from it or when half depressed
Abhiknov is offline   Reply With Quote
Old 20th February 2009, 20:16   #555
Distinguished - BHPian
 
jkdas's Avatar
 
Join Date: Sep 2005
Location: Thiruvananthapu
Posts: 9,575
Thanked: 1,234 Times
Default

Quote:
Originally Posted by suman View Post
500 odd rupees, get it changed. It affects the performance as well as the mileage.
I asked them to change and said its ok for few more 100s after they cleaned it. Will ask to change at 30k .

Quote:
Originally Posted by Abhiknov View Post
3000 kms on my safari....and the following observations
1. At 80+ speed, Driver and opposite side window makes strong hissing sound like the window glass has been left partially open. [Maybe above 120kmph, not that audible I have ICE on most of the time ]
2. Steering makes a hissing sound at full tilt on both sides. [Still has time, not an issue I guess]
3. Dashboard buttons go on and off in different ways. Some remain depressed while on, others come back to original position after on.[None]
4. The vehicle is slightly tilted towards its right side(driver's side) [Get this checked asap]
5. Front window motors sound very strained while rolling up the glass.[nope]
6. There is a lot of vibration in lower gears and also if u drop speed in heigher gear and then try and accelerate without changing gears.[If you are below the turbo kick-in]
7. Gearshift and clutch pedal is harder than expected.[Nope, need to adjust gears a bit though]
8. Slight pulse is felt in the clutch while removing foot from it or when half depressed[after you have driven for long distance?]
Mine's with 27k on the odo.

On my way back from office, I would have covered 5kms and then no turbo. Pedal to metal to check smoke: Nope! Tacho goes 4k almost max.

I drive for 2 kms or so as its very drivable. Turbo comes back to life after that! Wicked!

I am going to TASS tomorrow and intend to be there when they do the test or whatever.



Almost 27k.
jkdas is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Skoda Laura: Problems & solutions thread anandbhat Technical Stuff 1010 24th November 2016 13:48
Tata Safari - Technical Specifications & Feature List Stratos Technical Stuff 11 24th June 2011 20:48
technical aspects in technical driving ram_hyundai Technical Stuff 1 2nd February 2008 21:12


All times are GMT +5.5. The time now is 02:12.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks