Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 27th April 2016, 13:33   #6196
BHPian
 
Join Date: Apr 2012
Location: Mumbai
Posts: 29
Thanked: 12 Times
Default Re: The Tata Safari 2.2L Technical / Problems Thread

Two most likely causes. First is the air hose from turbocharger is loose or air filter is dirty. .Second could be the fuel filter.
indigo74 is offline   (2) Thanks Reply With Quote
Old 27th April 2016, 18:45   #6197
Senior - BHPian
 
Join Date: Jul 2008
Location: Bangalore
Posts: 2,018
Thanked: 360 Times
Default Re: The Tata Safari 2.2L Technical / Problems Thread

Quote:
Originally Posted by SafariMan View Post
Hi bhpians,

Travelled from Mumbai to Trisshur in my truck a 2007 Nov registered 2.2 VTT Dicor4*2 LX. After resting for 2 days on thr way to Palakkad the enture Joint Bolt, gear box clamp and assemblies gave away and the transmission rod ruptured thr main inlet diesel pipe and made a lot of noise before settling under the silencer.

Got my car towed to Hyson Motors,Thrissur and the atrached estimate has been given. Pls let me know if the prices are correct and/or I should get the work done outside. There are further work on AC electricals and body shop. Please help.
I am not really sure why are they including timing kit and clutch overhaul in the estimate. Your problem does not seem to be related to these parts at all.
amitk26 is offline   Reply With Quote
Old 1st May 2016, 15:49   #6198
BHPian
 
Join Date: Mar 2006
Location: Mumbai
Posts: 190
Thanked: 14 Times
Default Re: The Tata Safari 2.2L Technical / Problems Thread

Hello
I want some advice from gurus
As I had posted few months back that I had to get my engine redone due to broken HLA and busted injectors. Once the engine was done i have driven the car for almost 1200kms. I have not got any trouble but today again the check engine light showed up
The error
P0500

Now as i recollect before my car engine trouble began (bfr engine work was done) this was an error which used to show up on and off. It was not regular but was there
when my injector failed and car lost power this error was always there

Someone first told me that this error has to do with the acceleration of the car and the sensor synchronzation

so I am a bit troubled of this error showing up again. I will be going to Tass asthey told me to come once i have driven 1500 ms but I would like your advice

My car is prone to mice attacks so i regularly check all wires . Currently there are no cuts at injector lines (though the supple is taped up as original wiring was cut by mice earlier before
work done)
Apart from this i do not find any much power loss is car but yes occasionally at idle i find some wobble [though this might be my mind trying to look for phantom errors]

any suggestions
lodhra is offline   Reply With Quote
Old 2nd May 2016, 06:55   #6199
BHPian
 
DrANTO's Avatar
 
Join Date: Jul 2014
Location: Pala/Thiruvalla
Posts: 32
Thanked: 33 Times
Default Re: The Tata Safari 2.2L Technical / Problems Thread

Quote:
Originally Posted by lodhra View Post
I want some advice from gurus
It may be due to a faulty rpm sensor. I had a similar issue with my safari. Replaced rpm sensor (1000rs) and problem solved. Ask your mechanic to check that.


Mod Note: Please avoid quoting the whole post while responding

Last edited by ampere : 2nd May 2016 at 07:22.
DrANTO is offline   (1) Thanks Reply With Quote
Old 2nd May 2016, 06:58   #6200
BHPian
 
DrANTO's Avatar
 
Join Date: Jul 2014
Location: Pala/Thiruvalla
Posts: 32
Thanked: 33 Times
Default Re: The Tata Safari 2.2L Technical / Problems Thread

Quote:
Originally Posted by indigo74 View Post
Two most likely causes. First is the air hose from turbocharger is loose or air filter is dirty. .Second could be the fuel filter.
Thank you so much for the advice indigo74

My problem was due to a dirty air filter. The beast is now running fine and revving all the way upto 4000rpm.
DrANTO is offline   (1) Thanks Reply With Quote
Old 2nd May 2016, 18:58   #6201
BHPian
 
Join Date: Mar 2006
Location: Mumbai
Posts: 190
Thanked: 14 Times
Default Re: The Tata Safari 2.2L Technical / Problems Thread

Quote:
Originally Posted by DrANTO View Post
It may be due to a faulty rpm sensor.
If i do not get it replaced soon does it cause any engine trouble running or one i can ignore ?
lodhra is offline   Reply With Quote
Old 2nd May 2016, 19:09   #6202
BHPian
 
DrANTO's Avatar
 
Join Date: Jul 2014
Location: Pala/Thiruvalla
Posts: 32
Thanked: 33 Times
Default Re: The Tata Safari 2.2L Technical / Problems Thread

Quote:
Originally Posted by lodhra View Post
If i do not get it replaced soon does it cause any engine trouble running or one i can ignore ?
I don't have the technical knowledge to answer your question with 100% confidence. But all I can tell you is, I drove my beast for around 1000km with a faulty sensor before replacing it. My trusted mechanic says it is okay to do so unless you try to redline your car engine.

regards
DrANTO is offline   (1) Thanks Reply With Quote
Old 2nd May 2016, 22:42   #6203
BHPian
 
Join Date: Apr 2012
Location: Mumbai
Posts: 29
Thanked: 12 Times
Default Re: The Tata Safari 2.2L Technical / Problems Thread

Quote:
Originally Posted by DrANTO View Post
Thank you so much for the advice indigo74

My problem was due to a dirty air filter. The beast is now running fine and revving all the way upto 4000rpm.
Glad to see a Safari making its owner happier.You are welcome.
indigo74 is offline   (1) Thanks Reply With Quote
Old 5th May 2016, 13:12   #6204
BHPian
 
HappyRoadie's Avatar
 
Join Date: Jun 2010
Location: Lucknow
Posts: 408
Thanked: 70 Times
Default Re: The Tata Safari 2.2L Technical / Problems Thread

Hi guys, I own a Tata Safari Dicor LX purchased in 2011. Today when I started my car MIL (Malfunction Indicator Lamp) started glowing and remained like this throughout. It did not stop glowing. I only had to travel a short distance so I kept driving the Safari although the manual suggests that one should stop driving and contact TATA workshop.

There's one more issue that I'm facing. I don't know if it's related with the above mentioned issue or not but while driving suddenly the accelerator stops responding i.e. car stops accelerating. After a while it starts accelerating. It happened many times today. Few months back I had noticed that car was jerking while driving but today this new issue has cropped up. And just for information 4 months back i got the clutch replaced.
HappyRoadie is offline   Reply With Quote
Old 5th May 2016, 14:10   #6205
BHPian
 
Ravindra M's Avatar
 
Join Date: Mar 2009
Location: Bangalore
Posts: 258
Thanked: 192 Times
Default Re: The Tata Safari 2.2L Technical / Problems Thread

Quote:
Originally Posted by HappyRoadie View Post
Hi guys, I own a Tata Safari Dicor LX purchased in 2011. Today when I started my car MIL (Malfunction Indicator Lamp) started glowing and remained like this throughout......one more issue that I'm facing. I don't know if it's related with the above mentioned issue or not but while driving suddenly the accelerator stops responding ....
Looks like issue with the accelerator pedal sensor. Please get it checked at Tata service centre asap. Loss of acceleration is safety critical.

Last edited by Ravindra M : 5th May 2016 at 14:11. Reason: spelling correction
Ravindra M is offline   Reply With Quote
Old 6th May 2016, 00:05   #6206
BHPian
 
ankur_gupta10's Avatar
 
Join Date: Jul 2009
Location: New Delhi
Posts: 196
Thanked: 48 Times
Default Re: The Tata Safari 2.2L Technical / Problems Thread

Accelerator sensor is also linked to brake sensor. Faced this issue in my new safari long back. Brake sensor needed to be screwed A bit more. Get car scanned

Quote:
Originally Posted by HappyRoadie View Post
Hi guys, I own a Tata Safari Dicor LX purchased in 2011. Today when I started my car MIL (Malfunction Indicator Lamp) started glowing and remained like this throughout. It did not stop glowing. I only had to travel a short distance so I kept driving the Safari although the manual suggests that one should stop driving and contact TATA workshop.

There's one more issue that I'm facing. I don't know if it's related with the above mentioned issue or not but while driving suddenly the accelerator stops responding i.e. car stops accelerating. After a while it starts accelerating. It happened many times today. Few months back I had noticed that car was jerking while driving but today this new issue has cropped up. And just for information 4 months back i got the clutch replaced.
ankur_gupta10 is offline   Reply With Quote
Old 6th May 2016, 09:14   #6207
BHPian
 
HappyRoadie's Avatar
 
Join Date: Jun 2010
Location: Lucknow
Posts: 408
Thanked: 70 Times
Default Re: The Tata Safari 2.2L Technical / Problems Thread

Thanks a lot guys for pointing out the issue. Could you also please tell me what is causing the MIL to glow. What could be the issue. I read in manual that if this lamp glows then there must be a problem with the emission system.
HappyRoadie is offline   Reply With Quote
Old 7th May 2016, 13:22   #6208
Senior - BHPian
 
Join Date: Jul 2008
Location: Bangalore
Posts: 2,018
Thanked: 360 Times
Default Re: The Tata Safari 2.2L Technical / Problems Thread

Quote:
Originally Posted by HappyRoadie View Post
Thanks a lot guys for pointing out the issue. Could you also please tell me what is causing the MIL to glow. What could be the issue. I read in manual that if this lamp glows then there must be a problem with the emission system.
It means ECU has recorded some error code.
If you have an OBD2 dongle you can find what iis error code and thus point to the root cause


Take it to TASS ASAP if you do not have OBD2 dongle to read the error code.
amitk26 is offline   Reply With Quote
Old 8th May 2016, 11:05   #6209
BHPian
 
sandeepc83's Avatar
 
Join Date: May 2013
Location: Goa
Posts: 35
Thanked: 16 Times
Default Re: The Tata Safari 2.2L Technical / Problems Thread

Hello,
I own a dicor 2.2LX 2012 model. Been a good ownership till now.Great drives, adventures and memories. The plastic cladding on the side has been fading off for sometime. Now it looks really ugly and shows prominently. I checked with SRMT vizag regarding body colour paint for the cladding. They quoted about 35k and is well beyond my budget. I am not really particular about body colour paint but I just want to cover up the faded cladding. Is there anyway of renewing the cladding or getting rid of the fading? Im posting some pics....
Attached Thumbnails
The Tata Safari 2.2L Technical / Problems Thread-wp_20160508_10_56_45_pro.jpg  

The Tata Safari 2.2L Technical / Problems Thread-wp_20160508_10_56_59_pro.jpg  

The Tata Safari 2.2L Technical / Problems Thread-wp_20160508_10_57_24_pro.jpg  

The Tata Safari 2.2L Technical / Problems Thread-wp_20160508_10_57_38_pro.jpg  

The Tata Safari 2.2L Technical / Problems Thread-wp_20160508_11_10_27_pro.jpg  


Last edited by sandeepc83 : 8th May 2016 at 11:17.
sandeepc83 is offline   Reply With Quote
Old 8th May 2016, 12:19   #6210
BHPian
 
smsrini's Avatar
 
Join Date: Sep 2007
Location: Bangalore
Posts: 959
Thanked: 213 Times
Default

35k you can paint the whole safari.

Try a good painter outside, or a vinyl wrap..

Can't you replace the cladding only those pieces that are really bad,?

Last edited by smsrini : 8th May 2016 at 12:20.
smsrini is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Skoda Laura: Problems & solutions thread anandbhat Technical Stuff 1010 24th November 2016 13:48
Tata Safari - Technical Specifications & Feature List Stratos Technical Stuff 11 24th June 2011 20:48
technical aspects in technical driving ram_hyundai Technical Stuff 1 2nd February 2008 21:12


All times are GMT +5.5. The time now is 05:27.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks