Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 24th August 2008, 09:43   #1
BHPian
 
Join Date: Oct 2005
Location: Michigan,USA
Posts: 448
Thanked: 78 Times
Default Strange problem with Petra - Radiator fan

Hello All,
Offlate I am facing a strange problem with my Petra.
I noticed that while at idle,the fan noise was different(some vibrations could be heard) and I could feel those vibrations in the accelarator pedal as well.
However the idle RPM remained normal(RPM used to remain around 850-900 at idle) and also Temp gauge also showed normal reading.
I started noticing this only after my Chennai-Coimbatore-Chennai run last week.

I took the car to Concorde motors y'day.After checking the car,they informed me that this behaviour is due to someay in the fan blades and also due to dust accumulating on the fan blades.As a result of this ,I have this vibrations now.They told me that there is nothing to worry about this.

Has anyone ever faced this.If the dust is a reason,is there a way to clean it?
My car is a 2004 April model Fiat Petra 1.6
-Jey

Last edited by jraj : 24th August 2008 at 09:44. Reason: more info
jraj is online now   Reply With Quote
Old 24th August 2008, 10:19   #2
Senior - BHPian
 
Join Date: Jul 2004
Location: Madurai
Posts: 1,006
Thanked: 645 Times
Default

Hate to say this, but a lot of Siennas and Palios have their electric fans failing at around the 60K Km mark. How much has your car done?
jyobeb is offline   Reply With Quote
Old 24th August 2008, 11:29   #3
BHPian
 
Join Date: Oct 2005
Location: Michigan,USA
Posts: 448
Thanked: 78 Times
Default

mine has done 41,xxx.
I asked the Concorde guys,if I should change it.They said not required now.I enquired the price and the fan assembly costs 9k.
I am worried as I am planning to undertake Chennai-Tuticorin-Chennai trip in 2 weeks.
jraj is online now   Reply With Quote
Old 24th August 2008, 12:18   #4
Senior - BHPian
 
madan80's Avatar
 
Join Date: Jan 2006
Location: Santa Clara, CA
Posts: 1,356
Thanked: 73 Times
Default

i get this vibration when i put my blower on 4, else if it is between 0 nd 3there are no vibrations.
madan80 is offline   Reply With Quote
Old 24th August 2008, 12:19   #5
BHPian
 
Join Date: Jan 2008
Location: ludhiana
Posts: 197
Thanked: 3 Times
Default

hi jraj i also have a may 2004 petra done 80000km. i had a similar noise from fan the agency said dust and said cleaned with water hose but it persisted later the fan jammed it was due to the worn out bearings. so either get the fan changed or take it to a electrician and get the fan opened and change its bearings which was done by my electrician and its still workming ok. the preferred thing would be get the fan replaced but depending on availability and price the repair also works
rupinder is offline   Reply With Quote
Old 24th August 2008, 13:31   #6
BHPian
 
toiingg's Avatar
 
Join Date: Oct 2006
Location: Calcutta
Posts: 601
Thanked: 70 Times
Default

Quote:
Originally Posted by jraj View Post
Hello All,
Offlate I am .......
.....Has anyone ever faced this.If the dust is a reason,is there a way to clean it?


Check this link out. http://www.team-bhp.com/forum/techni...tml#post892284 (Strange Overheating problem with my OHC)
toiingg is offline   Reply With Quote
Old 24th August 2008, 13:40   #7
Senior - BHPian
 
Join Date: Sep 2007
Location: New Delhi
Posts: 3,083
Thanked: 252 Times
Default

Quote:
Originally Posted by madan80 View Post
i get this vibration when i put my blower on 4, else if it is between 0 nd 3there are no vibrations.
Isn't he talking about the radiator fan?
Maybe, I'm missing something?
anupmathur is offline   Reply With Quote
Old 24th August 2008, 13:46   #8
BHPian
 
Join Date: Oct 2005
Location: Michigan,USA
Posts: 448
Thanked: 78 Times
Default

@toiigng:Thanks for this information.
Will try the technique you had mentioned.
However in my case,the temp never raises..its stays normal.but will defly try what you suggested and see if the vibrations go off
-Jey
@anupmathur:yes.I am talking about the radiator fan

Last edited by jraj : 24th August 2008 at 13:50. Reason: more info
jraj is online now   Reply With Quote
Old 24th August 2008, 14:00   #9
BHPian
 
Join Date: Jan 2008
Location: ludhiana
Posts: 197
Thanked: 3 Times
Default

Quote:
Originally Posted by madan80 View Post
i get this vibration when i put my blower on 4, else if it is between 0 nd 3there are no vibrations.
mr madan your problem is of the blower ac fan where as his problem is cos of radiator fan
btw your problem is cos of dust accumulated under dash board get ur ac serviced and dust removed which is done after removing the dashboard that will resolve it .it happened to my car also .plus it will make the blower noiseless and also improve the cooling
rupinder is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Should the radiator fan be running all the time? weejai Technical Stuff 21 10th September 2017 16:35
Radiator cooling fan problem? rajivanoj Technical Stuff 5 20th August 2009 21:48
Ikon 1.8 Radiator Fan not Working!! Born 2 Be Wild Technical Stuff 4 13th April 2009 00:29
Fiat Petra - Radiator Fan Noise Rai Technical Stuff 3 11th March 2009 18:08
Radiator Fan Blues tsk1979 Technical Stuff 14 29th October 2007 17:31


All times are GMT +5.5. The time now is 17:42.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks