Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 26th August 2008, 11:28   #1
BHPian
 
Join Date: Jul 2007
Location: Mysore
Posts: 58
Thanked: 0 Times
Default Fiat Palio 1.6GTX 2002

1.I have a peculiar problem with my fiat palio GTX, the engine starts heating up and then the fan starts running it starts cooling down but the fan doesnt cut off even after i put the engine off

2. The fuel injector sign comes on in between driving sometimes.


Can someone help me with this please.....
Ramkumar is offline   Reply With Quote
Old 26th August 2008, 11:34   #2
BHPian
 
mahadev_kc's Avatar
 
Join Date: Apr 2006
Location: Bengaluru
Posts: 318
Thanked: 24 Times
Default

Quote:
Originally Posted by Ramkumar View Post
1.I have a peculiar problem with my fiat palio GTX, the engine starts heating up and then the fan starts running it starts cooling down but the fan doesnt cut off even after i put the engine off

2. The fuel injector sign comes on in between driving sometimes.


Can someone help me with this please.....
Some loose connection for sure. Get it checked with engine analyser that is with any service center. Even for me fuel injector sign comes ON some times whenever the AC is switched on, and fan will always be running after you switch on the AC, which was narrowed down to some loose connection with fan. After they tightened it, no more fuel injector sign. If you see fuel injector sign, your car performance will go down. So, check with engine analyser.
mahadev_kc is offline   Reply With Quote
Old 26th August 2008, 11:38   #3
BHPian
 
Join Date: Jul 2007
Location: Mysore
Posts: 58
Thanked: 0 Times
Default

Quote:
Originally Posted by mahadev_kc View Post
Some loose connection for sure. Get it checked with engine analyser that is with any service center. Even for me fuel injector sign comes ON some times whenever the AC is switched on, and fan will always be running after you switch on the AC, which was narrowed down to some loose connection with fan. After they tightened it, no more fuel injector sign. If you see fuel injector sign, your car performance will go down. So, check with engine analyser.
Thank you I will have to check it up with Concorde motors here in Bangalore.

What you are describing is my exact problem. Where did you get it corrected, i am planning to visit concorde motors at Kengeri this week to correct it.

Are there any more such known problem which i can take precaution against?
Ramkumar is offline   Reply With Quote
Old 26th August 2008, 17:06   #4
BHPian
 
Join Date: Jul 2007
Location: Mysore
Posts: 58
Thanked: 0 Times
Default

Quote:
Originally Posted by Ramkumar View Post
Thank you I will have to check it up with Concorde motors here in Bangalore.

What you are describing is my exact problem. Where did you get it corrected, i am planning to visit concorde motors at Kengeri this week to correct it.

Are there any more such known problem which i can take precaution against?
Just now got a call from Tata motors Mumbai and they were telling some part like temperature sensor must have gone kaput

Any ideas anyone???
Ramkumar is offline   Reply With Quote
Old 26th August 2008, 17:18   #5
Team-BHP Support
 
Join Date: Feb 2004
Location: Bangalore
Posts: 11,892
Thanked: 9,728 Times
Default

Reason fan stays on is to cool engine to avoid a vapour lock. Fiats and Renaults let this run on after the car is switched off
ajmat is offline   Reply With Quote
Old 26th August 2008, 17:39   #6
BHPian
 
Join Date: Jul 2007
Location: Mysore
Posts: 58
Thanked: 0 Times
Default

Quote:
Originally Posted by ajmat View Post
Reason fan stays on is to cool engine to avoid a vapour lock. Fiats and Renaults let this run on after the car is switched off
Do this mean that the car is normal and i dont have to do anything? He was telling me that there are 2 temp sensor one is near the radiator and 1 near the head.
Ramkumar is offline   Reply With Quote
Old 26th August 2008, 22:09   #7
BHPian
 
Join Date: Dec 2007
Location: Hyderabad
Posts: 48
Thanked: 27 Times
Default

Hi Ram,

U wud do well to welcome me to ur club, as u mite hav guesed by now, I am facing similar problems with my 2003 Palio S10.

Frankly speaking, i am not too concerned about the first issue, my mech in Hyd (Solar Auto) says that in Palio, the fan keeps running after the engine is off and is nothing peculiar.

But the second issue has become a major headache. The injector signal, especially after driving for a fair distance, suddenly comes on without any warning. The car loses all its pick up and makes a gurgling sound.....the injector signal stays on for a few seconds sm times and at its worst, a few minutes.

I initially tried stopping the car, giving it a break by switching it off for sm time. Thats wasnt a permanent solution. My other strategy was giving accelerator even whenever the injector pops on, so the car keeps goin with tht burble and vry slowly, the injector pops off after sm time and doesnt recur for the day atleast.

I wouldnt say this is a regular problem, it's an occassional issue...which recurs when u least expect it to, making it even more irritating.

Unfortunately, despite my best efforts, the problem never cropped up whenever I gave it to my mech. Recently, my mech cleaned the injectors and changed the spark plugs too. The issue still lingers.

Fiat experts......Help!!!

Mite not be an engine threatening issue, but very irritating neverthless...

If one of u have/had got the problem resolved permanently, please let me know hw u guys went abt it so that i cud advise my mech to go the same way.

Thanks again guys....
Flash777 is offline   Reply With Quote
Old 26th August 2008, 23:00   #8
BHPian
 
RedMM340's Avatar
 
Join Date: Apr 2008
Location: on the move
Posts: 459
Thanked: 23 Times
Default

Quote:
Originally Posted by Ramkumar View Post
1.I have a peculiar problem with my fiat palio GTX, the engine starts heating up and then the fan starts running it starts cooling down but the fan doesnt cut off even after i put the engine off

2. The fuel injector sign comes on in between driving sometimes.


Can someone help me with this please.....
1. The engine is supposed to heat up when it runs.
2. If you think that it is getting too hot, can you tell us the temperature?
3. The Palio fan is supposed to run for 10 or 15 seconds after engine shut off to prevent heat build up.
4. What else happens when the fuel injector lights up? Is there is loss of power, does the engine misfire, does the light stay on, if so how long?

More details are needed. I have had similar issues, but if you give me more details, I can try to figure out what is happening with your car.

Thanks,
RedMM340 is offline   Reply With Quote
Old 27th August 2008, 10:30   #9
BHPian
 
Join Date: Jul 2007
Location: Mysore
Posts: 58
Thanked: 0 Times
Default

Quote:
Originally Posted by RedMM340 View Post
1. The engine is supposed to heat up when it runs.
2. If you think that it is getting too hot, can you tell us the temperature?
3. The Palio fan is supposed to run for 10 or 15 seconds after engine shut off to prevent heat build up.
4. What else happens when the fuel injector lights up? Is there is loss of power, does the engine misfire, does the light stay on, if so how long?

More details are needed. I have had similar issues, but if you give me more details, I can try to figure out what is happening with your car.

Thanks,
Hi

In my Case

the engine temperature crosses just above the halfway mark. Then if I switch the AC off it starts dropping or sometimes it drops by itself. There is no definitive pattern.

When the injector comes on there is no problems at all. It just stays there but there is no loss in power or abnormal sound.

I believe flash777 seems to have a loss in power.

I havent seen the injector on for last 2 days after i did a few things

1. Did a total engine flush out
2. flushed out the old engine oil and used totally new oil
3. added an additive to prevent carbon deposit
4. cleaned the injectors
5. put new spark plugs

dont know which of these has stopped the injector light coming on (or it may come on in a another few days)

But the temperature problem remains.
Ramkumar is offline   Reply With Quote
Old 27th August 2008, 17:21   #10
BHPian
 
Join Date: Jul 2007
Location: Mysore
Posts: 58
Thanked: 0 Times
Default

Quote:
Originally Posted by Ramkumar View Post
1.I have a peculiar problem with my fiat palio GTX, the engine starts heating up and then the fan starts running it starts cooling down but the fan doesnt cut off even after i put the engine off
2. The fuel injector sign comes on in between driving sometimes.
Can someone help me with this please.....
Sometime back I got a call from Concorde motors and spoke to a gentleman by name Mr.Vinayak Badami.

He seems to have diagnosed the problem on phone. He says there are 2 fans which come on at various temperatures, the 1st at 89 deg and 2nd at 101. he feels my 1st fan is not coming on probably because of a faulty relay. That is why my temperature does not cross the halfway mark as the 2nd fan comes on at that point.

I would be meeting him on friday to get my car put under a scanner.
Ramkumar is offline   Reply With Quote
Old 28th August 2008, 02:09   #11
BHPian
 
RedMM340's Avatar
 
Join Date: Apr 2008
Location: on the move
Posts: 459
Thanked: 23 Times
Default

Ramkumar,

Sounds like you may have the temp issue diagnosed. But there is only one fan that has 2 speeds. There is a relay, and a resistor near the base of the fan that control the fan.

Just have the tech run through all the scanner checks and not skip any of the available tests. The scanner will turn on the fan at low speed and high speed and the tech will verify that the fan is running or not at the correct speed.

Good luck with getting the issue sorted out, and please report back what you find out after scanning.

Regards,
RedMM340 is offline   Reply With Quote
Old 28th August 2008, 21:47   #12
BHPian
 
Join Date: Dec 2007
Location: Hyderabad
Posts: 48
Thanked: 27 Times
Default

Quote:
4. What else happens when the fuel injector lights up? Is there is loss of power, does the engine misfire, does the light stay on, if so how long?
Dear Ram,

As I specified in mty post earlier, yes,

1. There is a loss of power, making a gurgling sound
2. The engine does misfire.
3. The light stays on for around 30 secs generally or at its worst for a few minutes.

Request you to share your experiences when countered with similar issues.
Flash777 is offline   Reply With Quote
Old 29th August 2008, 13:15   #13
BHPian
 
RedMM340's Avatar
 
Join Date: Apr 2008
Location: on the move
Posts: 459
Thanked: 23 Times
Default

Quote:
Originally Posted by Flash777 View Post
Dear Ram,

As I specified in mty post earlier, yes,

1. There is a loss of power, making a gurgling sound
2. The engine does misfire.
3. The light stays on for around 30 secs generally or at its worst for a few minutes.

Request you to share your experiences when countered with similar issues.
Flash,
I had this same issue with my GTX, and it turned out to be a defective ignition coil and a bad spark plug wire.

Diagnosis is very easy: When the engine is misfiring, pull out one ignition wire from the coil, hold is very close to the contact, and look for a spark. Do this one by one and if there is no spark between the wire connector and coil, the coil is not providing power for that wire.

Be careful as it is high voltage.

Also Ohm out each wire and make sure that the resistance is similar.
RedMM340 is offline   Reply With Quote
Old 30th August 2008, 16:05   #14
BHPian
 
Join Date: Dec 2007
Location: Hyderabad
Posts: 48
Thanked: 27 Times
Default

Dear Red MM,

Thanks a lot for your suggestion. I think your advise regarding the ignition coil should do the trick for engine misfiring. However, I had a query, how does the injector problem relate to the engine misfire? Are they correlated? Coz, my major prob is te injector prob...

However, I shall first of all ask my mech to check the ignition coil as advised by you and revert to u abt the results very soon.

Thanx a lot!!!
Flash777 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
My buying and ownership experience of Palio 1.6GTX bkishore_77 Test-Drives & Initial Ownership Reports 50 9th October 2010 13:05
palio 1.6gtx doubt pawan Technical Stuff 36 7th May 2007 03:55
Does anyone have Palio 1.6GTX interior pannels? merve_extreme Shifting gears 0 13th April 2005 02:07
looking for used palio 1.6gtx or baleno heavy_foot Shifting gears 10 12th July 2004 14:56
new palio 1.6gtx /used Vtec :which is better speedsatya Shifting gears 12 8th June 2004 04:23


All times are GMT +5.5. The time now is 22:02.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks