Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 3rd October 2008, 15:37   #1
BHPian
 
Join Date: Sep 2007
Location: Bangalore
Posts: 77
Thanked: 2 Times
Default My NHC clutch making a squeaking noise on release

Gurus,
My NHC clutch makes a squeaking noise when released. It becomes quite audible when the windows are rolled up. The service guys say that it is a lubrication issue, but was not able to fix it in the last two services . It is a 2004 model and the current mileage is 32000. Any clue anyone?
battada is offline   Reply With Quote
Old 4th October 2008, 13:12   #2
BHPian
 
Monaro's Avatar
 
Join Date: Jun 2007
Location: Noida
Posts: 120
Thanked: 48 Times
Default

I've had similar issues with my NHC aswell, the squeaking noise is indeed a lubricating issue and it generally happens during the rainy season.

I even got the pedals replaced under warranty when the lubricating didn't help either... but after 3-4months ..its back again at its squeaking best, but only when it rains!
Monaro is offline   Reply With Quote
Old 4th October 2008, 15:18   #3
GTO
Team-BHP Support
 
GTO's Avatar
 
Join Date: Feb 2004
Location: Bombay
Posts: 47,700
Thanked: 89,121 Times
Default

Same here with my OHC! The clutch squeaking noise can get ANNOYING, but nothing that a simple cable lubrication job can't sort out.
GTO is offline   Reply With Quote
Old 4th October 2008, 17:06   #4
Senior - BHPian
 
Lukeskywalker's Avatar
 
Join Date: Feb 2006
Location: Bangalore
Posts: 1,396
Thanked: 1,149 Times
Default

Don't know about the OHC, but in my Santro the squeaking noise did not disappear on lubrication but changing the clutch cable did the trick.
Cheers,
Hari.
Lukeskywalker is offline   Reply With Quote
Old 6th October 2008, 11:17   #5
BHPian
 
Join Date: Sep 2007
Location: Bangalore
Posts: 77
Thanked: 2 Times
Default

Thanks friends. I will try all options in my next service.
I guess we should put it up in some of our ownership reviews.
battada is offline   Reply With Quote
Old 6th October 2008, 11:20   #6
BHPian
 
Join Date: Sep 2007
Location: Bangalore
Posts: 77
Thanked: 2 Times
Default

I am not sure if this slightly off topic but, I have a squeaking noise also from the door panel when the door is opened and closed. Tried getting it lubricated in various service checks but it seems to reappear every 4-5 months. Thanks for your help guys. TBHP rocks!!
battada is offline   Reply With Quote
Old 6th October 2008, 12:22   #7
BHPian
 
menonrajesh's Avatar
 
Join Date: Mar 2006
Location: Bangalore
Posts: 210
Thanked: Once
Default

In my Swift's case, no squeaking sound - but there is a distinct 'tak' sound when I release the clutch. Sounds like some metal plate is tapped.It is not there always, but produced most of the times.3 'tries' at Pratham Service with no results. Now I am planning to check it up with Suraksha along with my 25k service.
menonrajesh is offline   Reply With Quote
Old 6th October 2008, 12:53   #8
Senior - BHPian
 
esteem_lover's Avatar
 
Join Date: Jul 2006
Location: Madras/Py
Posts: 7,554
Thanked: 445 Times
Default

Happens all the time in my esteem too. Lubricating the clutch cable works for a while, replacing the cable totally eliminates the sound.
esteem_lover is offline   Reply With Quote
Old 6th October 2008, 13:15   #9
Senior - BHPian
 
alpha1's Avatar
 
Join Date: Apr 2007
Location: P00NA
Posts: 1,625
Thanked: 962 Times
Default

Cleaning and lubrication of cluthc cable.
Very simple job, any roadside mechaninc can do.

No need to go to service center for this.
alpha1 is offline   Reply With Quote
Old 6th October 2008, 16:46   #10
SLK
Senior - BHPian
 
SLK's Avatar
 
Join Date: Feb 2004
Location: DL XX XX XXXX
Posts: 1,290
Thanked: 185 Times
Default

Yup... In my wagon R too.... not in the NHC though!!

A temporary solution is to spray WD40 on BOTH sides of the clutch cable and on the paddle spring. Why WD40?... b'coz its easier to spray with the nozzle.

Otherwise a few drops of engine oil would solve the issue for a much longer period... but its kinda impossible to get that oil into that place... and direction.
SLK is offline   Reply With Quote
Old 18th December 2008, 23:45   #11
BHPian
 
parimal_g's Avatar
 
Join Date: Aug 2007
Location: MUMBAI
Posts: 435
Thanked: 174 Times
Unhappy Clutch Noise

My 48000km old Palio D is also also facing same problem while pressing and releasing the clutch two strange sound comes ,one is from inside the car from the clutch lever its sounds like some air is getting released and other is coming from the hood like kirrrr kiirrrrr..some what hissing sound ....ow cars is behaving fine..what could be the problem.........???
parimal_g is offline   Reply With Quote
Old 19th December 2008, 10:03   #12
BHPian
 
parimal_g's Avatar
 
Join Date: Aug 2007
Location: MUMBAI
Posts: 435
Thanked: 174 Times
Default Clutch noise

But Palio has Hydrolic System for the clutch so Oiling will not help....help required urgently
parimal_g is offline   Reply With Quote
Old 9th November 2009, 12:24   #13
BHPian
 
pragya's Avatar
 
Join Date: Oct 2009
Location: pune
Posts: 38
Thanked: 2 Times
Default

i am also facing nearly similar problem in my zen estilo. My car has done 10,000 KM, I donot hear any considerable noise rather feel like the clutch gets stuck for just fraction of second.
What can be the issue.
pragya is offline   Reply With Quote
Old 28th November 2009, 22:17   #14
BHPian
 
bj96's Avatar
 
Join Date: Dec 2008
Location: Pune
Posts: 779
Thanked: 127 Times
Unhappy wagonr clutch squeak

Quote:
Originally Posted by SLK View Post
Yup... In my wagon R too.
A temporary solution is to spray WD40 on BOTH sides of the clutch cable
Is there a permanent (or a near permanent) solution to this? It is less than 6 months since I replaced the clutch cable on my 2002, 47k odo wagonr, but the squeak is back after the "fayhan" deluge few weeks ago. A generous dose of wd40 at a nearby workshop did quieten it for a few days but the squeak has returned. I want a solution, preferably a DIY.
Many thanks,
-BJ
bj96 is offline   Reply With Quote
Old 29th November 2009, 02:01   #15
BHPian
 
Join Date: Nov 2009
Location: Bangalore
Posts: 908
Thanked: 296 Times
Default

I'm not sure, but doesn't the NHC have a hydraulic clutch system? Maybe you need to check that.
Also see that the carpet is not in the way.
wildsdi5530 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Squeaking noise - What could it be? namit Technical Stuff 23 21st February 2014 11:42
Belt squeaking noise even after replacement rajivanoj Technical Stuff 24 28th January 2014 06:27
First gear clutch release operation in MPFI cars - clarification needed! gigatech2006 Technical Stuff 57 26th October 2009 13:50
Squeaking sound from the clutch satan_crazy Technical Stuff 39 7th September 2009 15:29
Swift DDIS ABS humming sound during initial release of the clutch. tush Technical Stuff 12 25th August 2009 23:41


All times are GMT +5.5. The time now is 12:20.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks