Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 15th January 2009, 23:53   #136
BHPian
 
Ford Rocam's Avatar
 
Join Date: Feb 2005
Location: Mumbai-India
Posts: 880
Thanked: 16 Times
Default

Quote:
Originally Posted by amit_mechengg View Post
the problem has been solved. i had to change the IAC valve. spent 6 hours to find out the exact problem. then swapped the IAC from other car and it worked. so i changed the IAC valve. now there is no rpm dropping whatsoever.

i suggest you all that please dont open your throttle body for cleaning unless and untill really required. the IAC is very delicate part with a sealed bearing. once you spray the cleaner onto it, the bearing looses its lubrication and accuracy and all sorts of idling problem crop up.
Glad your problem is solved at last, it would have been rectified much earlier if you had not missed post# 78
Ford Rocam is offline   Reply With Quote
Old 16th January 2009, 00:38   #137
Senior - BHPian
 
amit_mechengg's Avatar
 
Join Date: Dec 2007
Location: Pune
Posts: 2,411
Thanked: 1,541 Times
Default

Quote:
Originally Posted by Ford Rocam View Post
Glad your problem is solved at last, it would have been rectified much earlier if you had not missed post# 78
the IAC flow duty and the operation of the IAC valve even when keenly observed looks damn perfect. the tech2 also showed that IAC is perfect. it was hard to convince the MUL people to swap a IAC valve from other car onto mine for testing purpose, they felt that when tech2 is showing correct results i am a moron to ask them and waste their time for IAC valve swapping.
amit_mechengg is offline   Reply With Quote
Old 16th January 2009, 07:46   #138
Senior - BHPian
 
vikram_d's Avatar
 
Join Date: Jul 2006
Location: Bangalore
Posts: 2,380
Thanked: 936 Times
Default

Good that your problem has been finally solved.
vikram_d is online now   Reply With Quote
Old 7th April 2011, 11:39   #139
BHPian
 
Join Date: Dec 2009
Location: Mumbai
Posts: 54
Thanked: 9 Times
Default Re: Strange Behavior of my ALTO, Expert's Advice needed

Quote:
Originally Posted by arpandiv View Post
Amit, I have a spare TB assembly including all sensors and IAC valve. Feel free to pick it up from Mumbai for testing purposes.However its of the alto 1.1.

I think you need to check the fuel pump also.
Hi Arpandiv,

Could you lend me the TB assembly for the Alto 1.1? I am having idling issues with the car and need to troubleshoot the same.

Regards,

IndianV2
indianv2 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disturbing behavior by a driver in Bangalore rameshspassion Street Experiences 21 28th May 2010 11:06
Abnormal clutch pedal behavior? lordofgondor Technical Stuff 6 13th March 2009 12:51
Expert Advice Needed: Audio System for Ikon(Budget 20 K) mohit_moh In-Car Entertainment 5 18th November 2007 20:45
Shameful behavior - 15 bikers beat up war veteran in a fit of road rage DriverR Shifting gears 11 24th September 2007 10:49


All times are GMT +5.5. The time now is 18:45.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks