Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 18th October 2008, 19:46   #1
BHPian
 
aerohit's Avatar
 
Join Date: Aug 2007
Location: India
Posts: 877
Thanked: 576 Times
Default Swift Transmission Cable Play

Whenever i shift from first to second, the feeling is horrible. It feels plasticy-clicky type and ruins the driving pleasure and shifting experience.

I have had this problem for 2 years, Mandovi rejected it as Normal. (since then i have stopped going to Mandovi)

After opening the center console so many times, and removing the entire shifter housing and studying the problem, I have finally discovered the problem lies with the shifter cable itself.

There is a slack (play) in the cable (right side-up down cable). The cable isnt entirely a cable. The cable ends are joint with a metal pipe (see pic). This is where the play is (aprox 10 mm play). Now I dont know how to reduce the play, between the cable and the metal pipe joint itself.

The only solution may be to get a new cable. If anyone knows any solution let me know.

I also want to know how to remove the cable from the Transmission on a Swift. They are not coming out. The design is not simpler as a Honda.


Sample pic
Attached Images
 

Last edited by aerohit : 18th October 2008 at 19:48.
aerohit is offline   Reply With Quote
Old 10th December 2008, 20:44   #2
BHPian
 
aerohit's Avatar
 
Join Date: Aug 2007
Location: India
Posts: 877
Thanked: 576 Times
Default

anyone?

Also, does anyone know how to pull off he cable out of the Transmission?

It looks like there is come kind of luck nut, not sure.
aerohit is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Mercedes Benz 300D (W123 series): Manual Transmission to Automatic Transmission. wartikars Post-War 5 3rd January 2014 12:39
Need Help - Swift clutch -how much play ?? emkay456 Technical Stuff 0 9th May 2009 15:56
Sony Unilink cable (bus audio cable) issue philipreji In-Car Entertainment 1 3rd January 2009 16:32
Long HDMI cable in pune And HD play question hrishig Gadgets, Computers & Software 7 19th September 2008 14:39


All times are GMT +5.5. The time now is 20:43.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks