Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 31st March 2005, 22:45   #16
BHPian
 
jigarmuni's Avatar
 
Join Date: Jan 2005
Location: Mumbai
Posts: 139
Thanked: 0 Times
Default

Dude, this is surely a clutch problem.... and the baleno clutch does go off pretty early also i have heard!! Just replace ur clutch and everythiung will be okay!!
jigarmuni is offline   Reply With Quote
Old 1st April 2005, 04:52   #17
Team-BHP Support
 
Rehaan's Avatar
 
Join Date: Feb 2004
Location: Bombay
Posts: 22,373
Thanked: 22,588 Times
Default

Hey Zaphod,

Am i right to assume that when u did a 2nd-3rd upshift and the revvs just kept rising and you let off the gas the clutch would then engage at some point on its own...... or did you have to reclutch and reslot in 3rd?

My guess is
1. Pressure plates
2. Sticky clutch cable etc

cya
R
Rehaan is offline   Reply With Quote
Old 1st April 2005, 07:09   #18
BHPian
 
Join Date: Sep 2004
Location: NO IDeA/Madurai
Posts: 236
Thanked: Once
Default

Quote:
Am i right to assume that when u did a 2nd-3rd upshift and the revvs just kept rising and you let off the gas the clutch would then engage at some point on its own...... or did you have to reclutch and reslot in 3rd?
yup, - If i let off the gas the clutch would eventually engage ..

Now today being a friday and the weekend coming up , I wont be taking th ecar in as theyre already quite busy with routine car servicing so I'll hand it in on Monday.

thanks for all the advice guys, I'll get back to you once the service station has a look at it - I'll be sure to mention to them what suggestions i've received here.

thanks everyone , I hope o can get this sorted out.

zaphod
zaphod is offline   Reply With Quote
Old 1st April 2005, 13:49   #19
Senior - BHPian
 
jesal's Avatar
 
Join Date: Apr 2004
Location: Mumbai
Posts: 2,322
Thanked: 5 Times
Default

i had the same problem with the accent on the expressway. i got the chip changed i forgot what its called. from hyundai it comes for 2k. problem never came again
jesal is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine stalling at low revs / idle kaushik_s Technical Stuff 37 4th March 2014 16:24
Swift D-Clutch/Gear Problem : Competent Motors unable to solve the clutch shudder Eddy Technical Stuff 48 8th September 2013 23:03
Revs not dropping during gear change ! normally_crazy Technical Stuff 22 8th March 2009 18:57
Problem with Clutch - Clutch cylinder replaced! Hats off to Talera Motors! Chevy_lover Technical Stuff 0 24th September 2008 14:13
revs too high during fst 5 mins... babe_on_wheels Technical Stuff 4 16th March 2006 17:09


All times are GMT +5.5. The time now is 04:44.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks