Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 22nd October 2008, 18:08   #1
BHPian
 
alias's Avatar
 
Join Date: Feb 2008
Location: ಬೆಂಗಳೂರು
Posts: 334
Thanked: 6 Times
Default 2002 Zen - Engine light on!!!

Hi all,
I need the your advice
Today while driving to work suddenly a light in the Speedo console lit up
I think itís the engine light how ever I am not sure and following this the Speedo meter stopped functioning.
I am not sure that could have caused it and follow the Speedo the steering started feeling very hard as if it was normal steering (though my cars supposed to have power steering)
I stopped the car for a while but as soon as I start the car the light comes back on,.
Attaching a picture of the light thatís come on.
Kindly advice
Regards
Asif
Ps I plan to take it to Suzuki *** however due to my busy schedule I will be able to take it only on Saturday till then I need the car to drive me to work every day.
BTW itís a 2002 Zen lxi.
Attached Images
 
alias is offline   Reply With Quote
Old 22nd October 2008, 18:18   #2
Senior - BHPian
 
vikram_d's Avatar
 
Join Date: Jul 2006
Location: Bangalore
Posts: 2,380
Thanked: 936 Times
Default

Yes that is the check engine light. You will have to take it to a MASS and have the ECU scanned for trouble codes using the Tech 2 scanner. That will tell what the problem with the car is.
vikram_d is offline   Reply With Quote
Old 22nd October 2008, 18:29   #3
BHPian
 
ankitahuja's Avatar
 
Join Date: Oct 2006
Location: Gurgaon & Delhi
Posts: 887
Thanked: 46 Times
Default

@alias - http://www.team-bhp.com/forum/techni...ml#post1009045 (Engine Malfunction Light ON in OHC. pls advise!)

Check out this link, I had the EXACT same problem, though the sensor has not been replaced till now.

Do post what you find in the scan on Saturday.
ankitahuja is offline   Reply With Quote
Old 22nd October 2008, 18:33   #4
BHPian
 
DueLLeR's Avatar
 
Join Date: May 2005
Location: Vashi / Navi Mumbai
Posts: 189
Thanked: 61 Times
Default

Looks like the EPS has failed. I don't understand what would make the speedo to go kaput. Take it to MASS and have them check it. If I were you, I'd avoid using the car when the light is ON. Good luck!

Cheers!
DueLLeR
DueLLeR is offline   Reply With Quote
Old 22nd October 2008, 18:44   #5
BHPian
 
alias's Avatar
 
Join Date: Feb 2008
Location: ಬೆಂಗಳೂರು
Posts: 334
Thanked: 6 Times
Default

Quote:
Originally Posted by vikram_d View Post
Yes that is the check engine light. You will have to take it to a MASS and have the ECU scanned for trouble codes using the Tech 2 scanner. That will tell what the problem with the car is.
Quote:
Originally Posted by ankitahuja View Post
@alias - http://www.team-bhp.com/forum/techni...ml#post1009045 (Engine Malfunction Light ON in OHC. pls advise!)

Check out this link, I had the EXACT same problem, though the sensor has not been replaced till now.

Do post what you find in the scan on Saturday.
Quote:
Originally Posted by DueLLeR View Post
Looks like the EPS has failed. I don't understand what would make the speedo to go kaput. Take it to MASS and have them check it. If I were you, I'd avoid using the car when the light is ON. Good luck!

Cheers!
DueLLeR


[SIZE=3][FONT=Times New Roman]Thanks for the info guys,[/FONT][/SIZE]
[SIZE=3][FONT=Times New Roman]Really appreciate it [/FONT][/SIZE]
[FONT=Times New Roman][/FONT]
[SIZE=3][FONT=Times New Roman]How ever is there a difference between power steering and eps[/FONT][/SIZE]
[FONT=Times New Roman][/FONT]
[FONT=Times New Roman][SIZE=3]and is there a connection between power steering and Speedo meter.[/SIZE][/FONT]
alias is offline   Reply With Quote
Old 22nd October 2008, 19:09   #6
Senior - BHPian
 
vikram_d's Avatar
 
Join Date: Jul 2006
Location: Bangalore
Posts: 2,380
Thanked: 936 Times
Default

EPS stands for Electronic Power Steering. So they are both the same. Don't know about link between speedo and power steering.
vikram_d is offline   Reply With Quote
Old 22nd October 2008, 19:44   #7
BHPian
 
rohan_fonseca's Avatar
 
Join Date: Jan 2006
Location: Panaji
Posts: 984
Thanked: 4 Times
Default

Speed sensor malfunction. Get that checked.
rohan_fonseca is offline   Reply With Quote
Old 22nd October 2008, 19:57   #8
BHPian
 
alias's Avatar
 
Join Date: Feb 2008
Location: ಬೆಂಗಳೂರು
Posts: 334
Thanked: 6 Times
Default

Quote:
Originally Posted by rohan_fonseca View Post
Speed sensor malfunction. Get that checked.

thanks for the reply
however does that have nay thing to do with the power steering
are they interconnected???
alias is offline   Reply With Quote
Old 22nd October 2008, 21:21   #9
BHPian
 
Ford Rocam's Avatar
 
Join Date: Feb 2005
Location: Mumbai-India
Posts: 880
Thanked: 16 Times
Default

Quote:
Originally Posted by alias View Post
thanks for the reply
however does that have nay thing to do with the power steering
are they interconnected???
Could be, After specific Vehicle speed the the power steering gets deactivated. just like in hydraulic. here its electronic, looks like some sensor issue & like vikram said, getting a high scan done should give you the root cause of problem.
Ford Rocam is offline   Reply With Quote
Old 22nd October 2008, 22:11   #10
BHPian
 
ankitahuja's Avatar
 
Join Date: Oct 2006
Location: Gurgaon & Delhi
Posts: 887
Thanked: 46 Times
Default

Quote:
Originally Posted by rohan_fonseca View Post
Speed sensor malfunction. Get that checked.

Is that possible to throw up the EML in an OHC?
ankitahuja is offline   Reply With Quote
Old 23rd October 2008, 01:01   #11
Senior - BHPian
 
autopsyche's Avatar
 
Join Date: Nov 2004
Location: New Delhi, India
Posts: 1,516
Thanked: 14 Times
Default

Im pretty sure its the VSS (Vehicle Speed Sensor) on the gearbox which has died. It will result in a non functional speedo and a check engine light.
autopsyche is offline   Reply With Quote
Old 23rd October 2008, 01:07   #12
BHPian
 
alias's Avatar
 
Join Date: Feb 2008
Location: ಬೆಂಗಳೂರು
Posts: 334
Thanked: 6 Times
Default

Quote:
Originally Posted by autopsyche View Post
Im pretty sure its the VSS (Vehicle Speed Sensor) on the gearbox which has died. It will result in a non functional speedo and a check engine light.

thanks for the info sir

could you tell me how much would that sensor cost??

and

Thanks for the guidance all
I did do a bit of research on the issue and found the manual online on maruti site
And attaching what I found




It says that it’s the some things wrong with the emission control system
Well now the question is what this emission control system is
And what does it have to do with the eps of the car
Attached Images
File Type: bmp malin.bmp (770.7 KB, 443 views)

Last edited by alias : 23rd October 2008 at 01:19.
alias is offline   Reply With Quote
Old 23rd October 2008, 01:43   #13
BHPian
 
alias's Avatar
 
Join Date: Feb 2008
Location: ಬೆಂಗಳೂರು
Posts: 334
Thanked: 6 Times
Default

and sir can i drive the car with the light on?

please advice
alias is offline   Reply With Quote
Old 23rd October 2008, 09:55   #14
BHPian
 
Join Date: Sep 2008
Location: Delhi
Posts: 48
Thanked: Once
Default

Alias,

1. Check the fuse of the EPS
2. Get your car scanned
3. Check (and if possible replace) the relay of Radiator Fan.
Khandelwal is offline   Reply With Quote
Old 23rd October 2008, 09:58   #15
BHPian
 
im_srini's Avatar
 
Join Date: Sep 2006
Location: Portland
Posts: 956
Thanked: 368 Times
Infractions: 0/1 (5)
Smile

Hi, I think Arush is right - your Vehicle Speed Sensor (VSS) has gone kaput, leading to the MIL turning on, your speedo not working, & your EPS shutting off.

Even if you don't have a Tech-2, there's a coupler in the engine-bay which can be used to diagnose the issue. In fact, the image you've posted shows how it's done...

Name:  MonitorCoupler.jpg
Views: 1767
Size:  26.3 KB

A particular terminal in the coupler is called the diagnostics-switch-terminal & when grounded, flashes the error code using the MIL ! The VSS is one of the sensors that can turn on the MIL, others include MAP, ECT, & TPS...

Last edited by im_srini : 23rd October 2008 at 10:00.
im_srini is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Vista Tdi - Engine oil and the Check engine light turns ON skartik2 Technical Stuff 4 27th August 2009 14:50
Need one good ICE setup for my zen 2002 ~~VinZ~~ Shifting gears 1 27th September 2007 02:13
Zen 2002 model 12" rim available (5 numbers) ~~VinZ~~ Shifting gears 1 25th September 2007 20:36
Jan 2002 Maruti Zen Lxi for sale the real Big B Shifting gears 2 7th September 2007 23:04
Upgrading my 2002 Zen LXi Zensible Modifications & Accessories 12 28th October 2005 08:49


All times are GMT +5.5. The time now is 19:11.

Copyright ©2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks