Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 3rd January 2009, 23:45   #1
Newbie
 
Join Date: Oct 2008
Location: Bangalore
Posts: 23
Thanked: 0 Times
Default Strange Noise from LHS front suspension Swift

HI All,

I am facing a strange problem from the front suspension (LHS) in the swift ZXI. Every time the car rides over a small crater ( Blore Roads) its makes a heavy metal to metal banging noise like a metal plate sitting on another. Strangely when both wheels go over any crater, the same noise is not heard. Also the vehicle feels a little uncomfortable on the braking issue since I have observed the sound. The vehicle makes a screeching noise every time the brakes are "jammed"

The vehicle has done just over 14K in 2.2 years and predominantly driven inside the city, no off roading as well. I had got the wheel aligned and balanced a couple of days before and the mechanic said the wheels looked fine. Just a thought that till date only the left front wheel had a puncture ( twice).

I had indicated to the service guy @ Mandovi JP Nagar last time @ service, but was told that every thing was normal. Also the sound was not to be heard for two days after service.

Confused !!
viana is offline   Reply With Quote
Old 4th January 2009, 00:08   #2
BHPian
 
white_vdi's Avatar
 
Join Date: Sep 2008
Location: new delhi
Posts: 842
Thanked: 17 Times
Default

i know what you are talking about. i faced the same problem. the mechanic tightened some bolt behind the wheel. dont remember whats it called but the issue was resolved.
its behind the disc, parallel to the ground. a small 3in long part that has bolts on either side. lift the car up on a lift and you can see it.
white_vdi is offline   Reply With Quote
Old 4th January 2009, 07:27   #3
BHPian
 
palioman's Avatar
 
Join Date: Oct 2007
Location: Dubai
Posts: 53
Thanked: Once
Default

Yeah, I had the same problem too, the mechanic tightened something and since then I have not observed it..but by God the car rattles !
palioman is offline   Reply With Quote
Old 4th January 2009, 08:30   #4
BHPian
 
Join Date: Jul 2007
Location: mysore
Posts: 101
Thanked: 87 Times
Default

hi
pls check lower arm and tie rod end. possible tie rod being defective is high.
nutmello is offline   Reply With Quote
Old 4th January 2009, 19:45   #5
Senior - BHPian
 
Join Date: Sep 2006
Location: zxc
Posts: 3,394
Thanked: 658 Times
Default

do you hear any noise while turning.
SirAlec is offline   Reply With Quote
Old 4th January 2009, 20:46   #6
BHPian
 
syedhafeez's Avatar
 
Join Date: Oct 2008
Location: Hyderabad
Posts: 972
Thanked: 330 Times
Default

Quote:
Originally Posted by SirAlec View Post
do you hear any noise while turning.
if you are hearing noise while turning then it could also be that the drive shaft has been damaged
syedhafeez is offline   Reply With Quote
Old 4th January 2009, 21:14   #7
Senior - BHPian
 
aaggoswami's Avatar
 
Join Date: May 2007
Location: Vadodara
Posts: 4,675
Thanked: 1,427 Times
Default

To me it looks something related to lower arms. My friend's Swift had same problem. But in case of lower arm play or something, the inner side of tyre will be chewed up if not checked. Any noticable drop in ride quality ? If so, get the lower arm replaced. Else dont worry, any mechanic will fix it.
aaggoswami is offline   Reply With Quote
Old 6th January 2009, 01:10   #8
Newbie
 
Join Date: Oct 2008
Location: Bangalore
Posts: 23
Thanked: 0 Times
Default

I have noticed that the overall ride quality is stiff, the car does not take well to the bumps. Is this also related to braking? I am quite scared to drive this since the car makes a screeching noise on small sudden braking.
viana is offline   Reply With Quote
Old 12th January 2009, 16:34   #9
BHPian
 
aerohit's Avatar
 
Join Date: Aug 2007
Location: India
Posts: 883
Thanked: 592 Times
Default

viana - any update on the fix?
aerohit is offline   Reply With Quote
Old 13th January 2009, 16:24   #10
BHPian
 
aerohit's Avatar
 
Join Date: Aug 2007
Location: India
Posts: 883
Thanked: 592 Times
Default

Quote:
Originally Posted by viana
Hi Aerohit,

I am traveling and not around to have it checked. Need to take it to check on the same. The issues still remains.

Are you facing similiar issues ??
yes I have similar issue, but there is no sound as you say

In my case something feels lose on the left front side, there is a play and slight clunking feeling when going over rough rouds. Something is definitely broken. The Shock may be bad too.

Also, when i over sharp/small speedbumps and not slow down, there will be a "pop" sound from front suspension.
aerohit is offline   Reply With Quote
Old 19th January 2009, 11:11   #11
Newbie
 
Join Date: Oct 2008
Location: Bangalore
Posts: 23
Thanked: 0 Times
Default

Taking it to the mechanic today. lets c.... will lift it up and check if the bolt issue is correct. Will update you
viana is offline   Reply With Quote
Old 19th January 2009, 14:09   #12
BHPian
 
Atlblkz06's Avatar
 
Join Date: Jan 2009
Location: Atlanta
Posts: 166
Thanked: 6 Times
Default

Don't let those lazy bums tell you that "nothing is wrong". They like to use that excuse to get away from work!

It sounds like a suspension component is loose. Just FYI - its possible that your car may require a re-alignment depending on the cause of your troubles. Make sure you bring this up when you talk to them.

Good luck!
Quote:
Originally Posted by viana View Post
Taking it to the mechanic today. lets c.... will lift it up and check if the bolt issue is correct. Will update you
Atlblkz06 is offline   Reply With Quote
Old 23rd January 2009, 18:19   #13
BHPian
 
aerohit's Avatar
 
Join Date: Aug 2007
Location: India
Posts: 883
Thanked: 592 Times
Default

hi Viana, please update
aerohit is offline   Reply With Quote
Old 2nd March 2009, 16:00   #14
BHPian
 
d_himan's Avatar
 
Join Date: Nov 2006
Location: Bombay
Posts: 728
Thanked: 591 Times
Default

exactly the same issue! Dont hear it normally, but when the front left wheel goes into deep potholes at 30-40kmph, there's this sickening 'thud'. Mine is a Oct 06 VXi.

Will ask MASS see if:
1. Bolt behind front disc can be tightened
2. Problem with suspension lower rod - tie-rod end
3. Strut bush kit
4. Stabilizer bar

hopefully, this would make me sound 'knowledgeable' enough for them to do a detailed inspection.The last time 'round, the SA said 'its normal sir'. On second thoughts, is this actually normal swift behaviour?

Also, I think all these parts are covered in EXTENDED WARRANTY. Could someone confirm please?

Last edited by d_himan : 2nd March 2009 at 16:07.
d_himan is offline   Reply With Quote
Old 4th March 2009, 19:36   #15
BHPian
 
invincible7's Avatar
 
Join Date: Feb 2007
Location: Delhi NCR
Posts: 644
Thanked: 131 Times
Default

Ok this may sound funny, my car ZXi has just done 1700 kms in not even a months time now and i have already done the first service which was due at 1000kms.

Now after the first service some funny kind of sounds i can hear from the dashboard and they are not regular. One is which comes right from the AC vent which is left to the driver side (front), and it makes a electic hizz sound and then goes away after some time. This is not even regular, may come one day and vanish for next couple of days and then suddenly will reappear.

Second is a sound which comes like a ringing metal, which is now becoming regular and today i got to hear a sound while going over the bad roads like of a thermocole being twisted..

All these are coming from the dasboard but are not regular.

I have once shown it to the service center supervisor but strangely and coincendently the sounds never appered when he was driving to check all these sounds.

So now i am in a dilema as to how to get them sorted out.
invincible7 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Jarring noise front brand new left front speaker skrules In-Car Entertainment 13 26th December 2011 10:53
strange suspension noise on my ANHC raghu230506 Test-Drives & Initial Ownership Reports 8 15th August 2010 11:51
Stubborn LHS noise in my Ford Fiesta krish3 Indian Car Dealerships 35 1st March 2010 20:50
Strange humming noise from my Safari(EDIT: Solved, window was open hence the noise) himanshugoswami Technical Stuff 14 14th May 2008 15:00


All times are GMT +5.5. The time now is 00:25.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks