Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 15th January 2009, 11:13   #1
Newbie
 
Ulysses's Avatar
 
Join Date: Jun 2008
Location: Noida
Posts: 2
Thanked: 0 Times
Exclamation Spooky Indica Turbo-need experts help!!!

Dear Pals,
It’s a great interactive site and I am regular visitor. I am from Noida. I need your help to get the answer of this issue;

I have an Indica V2 TCIC DlG, 2006 model. The car has a peculiar problem, the horn, indicator lights and the radiator fan fuses repeatedly getting blown off since last one year. Each time the TATA service station guys ( I have visited almost all in south Delhi & Noida) changes the fuse and gives various explanation ranging from loose wire, horn short circuit ( I use only Bosch horns) or wrong fuse been fitted.

But I don’t understand why the problem can not be permanently solved. I also got the wiring checked and it was found OK. The problem also occurs in a typical manner, for example first the horn will stop working when the car is running. But after the engine is stopped for 10-15 minutes, it will resume working. This will go for a couple of days before the horn will permanently stop working.

Similarly, the AC compressor suddenly stops working when the car is on move and the blower is working. After blowing non-cooled air for 25-30 minutes, it will resume. This will go on for some time and then first the radiator fan fuse blows and then the ac compressor clutch magnet relay blows off. The indicator lights go off when the hazard light switch is on for some time. Many times, after starting the engine, none of the accessories (head lamp, power window, horn etc) works. If the engine is switched off and on again, everything starts working again.

I have checked the battery, its ok, the alternator is also ok. I have been utterly disturbed with these nagging problems, and yet to find any satisfactory answer from any TATA service station in Delhi. I am planning to take the matter up with TATA Motors, but before that if any one of you can enlighten me on what’s happening in my car I shall be very much grateful.

Sharbendu

Last edited by v12 : 15th January 2009 at 14:22.
Ulysses is offline   Reply With Quote
Old 15th January 2009, 12:59   #2
Senior - BHPian
 
greenhorn's Avatar
 
Join Date: Apr 2007
Location: TN-14
Posts: 6,837
Thanked: 1,315 Times
Default

try the TIUG - you might get some useful help there too
greenhorn is online now   Reply With Quote
Old 15th January 2009, 14:04   #3
Senior - BHPian
 
trrk's Avatar
 
Join Date: Feb 2004
Location: Alleppey, Kerala
Posts: 2,113
Thanked: 12 Times
Default

Hi,

That really looks like an electrical problem only.

Since you have exhausted the local service stations, check this message.

Yahoo! Groups

The message is about Sameer Motors, Karnal. TIUG members in Delhi / NCR area do regularly visit this place for service.

Talk to them and see if they can help you.

I am too far away to offer other than this!
trrk is offline   Reply With Quote
Old 15th January 2009, 14:47   #4
GTO
Team-BHP Support
 
GTO's Avatar
 
Join Date: Feb 2004
Location: Bombay
Posts: 47,706
Thanked: 89,160 Times
Default

Get in touch with Tata Motors and push for a brand new wiring harness. It is obviously a case of electrical wiring gone wrong at the time of production. However, get the new harness installed at another (more competent) dealer.
GTO is offline   Reply With Quote
Old 15th January 2009, 15:39   #5
Newbie
 
Ulysses's Avatar
 
Join Date: Jun 2008
Location: Noida
Posts: 2
Thanked: 0 Times
Default

Quote:
Originally Posted by GTO View Post
Get in touch with Tata Motors and push for a brand new wiring harness. It is obviously a case of electrical wiring gone wrong at the time of production. However, get the new harness installed at another (more competent) dealer.
Hi GTO,
thanks for your suggestion. However the harness was actually changed in 2007, when the first time the AC compressor clutch magnet relay got blown. The car was under warranty, and the dealer got the harness from pune and took whole 10 days to fit it.
Ulysses is offline   Reply With Quote
Old 15th January 2009, 16:14   #6
GTO
Team-BHP Support
 
GTO's Avatar
 
Join Date: Feb 2004
Location: Bombay
Posts: 47,706
Thanked: 89,160 Times
Default

In that case, he has done a terrible job. Please look for another dealer!
GTO is offline   Reply With Quote
Old 15th January 2009, 23:23   #7
Senior - BHPian
 
Join Date: Mar 2006
Location: goa
Posts: 1,066
Thanked: 52 Times
Default

If the harness was changed they service guy must have screwed up some place and wrong or loose connection some place.
Also get the rad fan motor checked, the motor many have worn bushes and this loads the motor, which in turns pulls more amps than allowed and since the rad fan and compressor is on one circuit[for protection form over heating] the fuses blow in sequence.
Also the situation with the compressor switching off and turning on is due to a loose relay or a defective relay[common problem], the compressor relay is separate from the blower relay.
dinar is offline   Reply With Quote
Old 16th January 2009, 01:35   #8
Senior - BHPian
 
AbhiJ's Avatar
 
Join Date: Jun 2008
Location: Kolkata
Posts: 1,298
Thanked: 462 Times
Default

I had similar problems with my indica (long gone now)

The fuse box actually melted and the plastic bit fused together!! The whole fuse box was changed (at my cost :( )

All problems were solved when the car earthing was checked. Apparently there was some major problem with earthing and on solving that all electrical problems went away.

p.s. I am only telling you what my dealer told me... I have no idea about its genuineness...
AbhiJ is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Spooky Experiences : Share them here dadudeonfire Shifting gears 722 28th November 2017 20:32
Photoshop experts !!!! need a small help !! maxbhp Modifications & Accessories 25 17th December 2009 23:58
Need help from experts on my Pulsar 150 DTSI cruiser_1982 Motorbikes 3 4th January 2009 21:07
Spooky CAR AD.. spdfreak Shifting gears 2 26th January 2006 22:45


All times are GMT +5.5. The time now is 00:45.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks