Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 10th April 2010, 07:41   #541
Senior - BHPian
 
Join Date: Feb 2010
Location: Pune
Posts: 1,233
Thanked: 338 Times
Default

@amitwlele

I have not had any issues with the turbo (touch wood). If it has already been identified as a turbo problem, please do get it rectified ASAP. Your car is still in warranty right.[/quote]


Yup it is still under warranty. The service engineer mentioned that in case they are not able to rectify the issue they would replace the Turbo with no cost to me. I hope they stick to their word. I must say that my experience with the dealer has not been great. Would keep you posted. Thanks
amitwlele is offline   Reply With Quote
Old 10th April 2010, 17:50   #542
BHPian
 
Join Date: Nov 2009
Location: Goa
Posts: 94
Thanked: 14 Times
Default

maybe you have the child Lock switch of that door checked...might help!
boohooper is offline   Reply With Quote
Old 10th April 2010, 22:53   #543
BHPian
 
Join Date: Jul 2009
Location: Bangalore
Posts: 194
Thanked: 49 Times
Default

Hi, I am at 15000 kms and was wondering if it might be a good idea to get an oil change. I drive in bangalore and with the slow traffic and extra strain on engine, was thinking might be a good idea. Any thoughts? Anyone done a change at 15K?
The other option might be to wait for until 18500 and get an early 20K service done. What do you think guys?
vista_qjd is offline   Reply With Quote
Old 16th April 2010, 13:49   #544
BHPian
 
NFS-II's Avatar
 
Join Date: Jun 2007
Location: Bangalore
Posts: 53
Thanked: 2 Times
Default

Hello guys, required this small clarification. In my Vista Aqua, if you switch off the engine when the defogger is on, the defogger light (green indicator) continues to glow and wouldn't turn off even after pressing the button again. Does this happen in all your cars too?
NFS-II is offline   Reply With Quote
Old 19th April 2010, 12:03   #545
BHPian
 
Maverick1977's Avatar
 
Join Date: Aug 2007
Location: Mumbai
Posts: 832
Thanked: 249 Times
Default

Quote:
Originally Posted by greenhorn View Post
problem with the relays? try replacing the relays ( the regular headlamp relays and flasher relays are seperate)
Guys the problem has been detected to the combo switch. The same will hopefully be replaced by Tata Motors shortly.
Problem detected, solution provided, awaiting parts for problem resolution.

1 more thing I learnt at TASS is cases of damage to AC condensers being caused due to faulty horn placement. If any one of you has fitted double horn then it would be prudent to check if the same are not touching the condenser grill. Cases of the horn damaging the condenser due to lose nuts & horn continuously hitting the fins. This thing is NOT COVERED UNDER warranty so if the damage is done be ready to shell out big bucks.
Maverick1977 is offline   Reply With Quote
Old 19th April 2010, 16:52   #546
BHPian
 
Join Date: Dec 2008
Location: Pune
Posts: 553
Thanked: 214 Times
Default

Quote:
Originally Posted by amitwlele View Post
Hi All,

I have a Vista Qjet which is about 11 months old. I have already done 20K Kms and just got the fourth servicing done. Lately i have been facing an issue in acceleration. While driving up on any slope (not a very steep gradient) the acceleration suddenly dies for 1-2 seconds and then again it is ok. This repeats continuosly. The car typically is either in the 3rd or 4th gear. I mentioned this issue during the fourth servicing and the engineer got it checked. He mentioned that its got to do with the Turbo and would need more detailed check. The engineer also experienced the same issue on a test ride.

Wanted to ask the group if anyone has faced the same issue in the Vista and known resolution for it.

Thanks in advance

Amit
Same problem I am feeling on slopes. Tomorrow I am giving my car for servicing and try to checkout Turbo. Apart from this at 3000 rpm engine makes very very loud sound, sounds like something imbalanced. I am feeling that Turbo is the culprit.
sushantr5 is offline   Reply With Quote
Old 21st April 2010, 13:44   #547
BHPian
 
Join Date: Dec 2008
Location: Pune
Posts: 553
Thanked: 214 Times
Default

Quote:
Originally Posted by sushantr5 View Post
Same problem I am feeling on slopes. Tomorrow I am giving my car for servicing and try to checkout Turbo. Apart from this at 3000 rpm engine makes very very loud sound, sounds like something imbalanced. I am feeling that Turbo is the culprit.
Yesterday I have given my car for servicing. Service center is analyzing the problem of sudden power loss.

First they tried out by replacing Fuel filter, then they tried to reproduce the problem with their pure Diesel, then they checked turbocharger and finally they have zeroed down on injectors. They are saying 100% problem is with injectors. If so they will replace them under warranty.
sushantr5 is offline   Reply With Quote
Old 22nd April 2010, 02:30   #548
BHPian
 
Join Date: Jan 2010
Location: Surat/Mumbai
Posts: 201
Thanked: Once
Default

Quote:
Originally Posted by sushantr5 View Post
Yesterday I have given my car for servicing. Service center is analyzing the problem of sudden power loss.

First they tried out by replacing Fuel filter, then they tried to reproduce the problem with their pure Diesel, then they checked turbocharger and finally they have zeroed down on injectors. They are saying 100% problem is with injectors. If so they will replace them under warranty.
Problem with the injectors so soon? Doesn't sound right.
Johnny_ is offline   Reply With Quote
Old 22nd April 2010, 04:36   #549
BHPian
 
nithinnarayanan's Avatar
 
Join Date: Oct 2007
Location: Bangalore Kannur Manipal
Posts: 237
Thanked: 5 Times
Default

Quote:
Originally Posted by sushantr5 View Post
Yesterday I have given my car for servicing. Service center is analyzing the problem of sudden power loss.

First they tried out by replacing Fuel filter, then they tried to reproduce the problem with their pure Diesel, then they checked turbocharger and finally they have zeroed down on injectors. They are saying 100% problem is with injectors. If so they will replace them under warranty.

Have you checked the Air filter ?
Also the Air intake for any blockage ?
nithinnarayanan is offline   Reply With Quote
Old 22nd April 2010, 11:52   #550
BHPian
 
Join Date: Dec 2008
Location: Pune
Posts: 553
Thanked: 214 Times
Default

Quote:
Problem with the injectors so soon? Doesn't sound right.
This was expected to happen earlier as my intercooler was damaged and I did not know it for almost 15000 KMs. I used to complain about black smoke to a service center where I used to give my car. They could not identify the problem. When I changed my Service Center for 30k kms they saw my intercooler damaged and changed intercooler and said that your injectors will suffer due to this. Now at 40k kms service while checking for Sudden Power loss they identified that injectors are having some problem.

Vista has some design faults. Bumper is very close to radiator and intercooler, same like Fords new Figo. Even small push to bumper from front could cause damage to these parts. Thats why you see in Indigo Manza's front bumper is protruded more to front side. Another fault in design is, pipe leading from intercooler to turbo charger is very low and has very good probability of hitting to ground on rough road. This causes intercooler damage. In the first batch of Vista this pipe was rigid. Nowadays this pipe has some flexible portion so that it could mild the cause of damage.

Quote:
Originally Posted by nithinnarayanan View Post
Have you checked the Air filter ?
Also the Air intake for any blockage ?
That was the very first step. Sorry I did not mentioned it in earlier post.
sushantr5 is offline   Reply With Quote
Old 22nd April 2010, 15:01   #551
BHPian
 
Maverick1977's Avatar
 
Join Date: Aug 2007
Location: Mumbai
Posts: 832
Thanked: 249 Times
Default

This is not a problem per se, but I feel that Tata's should seriously consider giving a roof light at the back & also include a light in the luggage compartment. Both of them have been included in the Manza but sadly dropped off in the Vista. This I feel is very unfair but in the name of cost cutting dont find it to be uncommon.
Has any one done an after market fitment of any additional lighting in their Vista? Surprisingly the TASS has never been able to give me a good enough solution for the light in the luggage area but have indicated that it will be absolutely impossible to fit a roof light on the rear. 1 lame solution was to have a reading lamp & use it as a rear cabin+luggage light.
Maverick1977 is offline   Reply With Quote
Old 27th April 2010, 10:28   #552
BHPian
 
NFS-II's Avatar
 
Join Date: Jun 2007
Location: Bangalore
Posts: 53
Thanked: 2 Times
Default

Hello guys,
this is specially for those who have issues with the suspension;

At the first service, Tata motors have replaced under warranty the "bearing block(front antiroll bar)" in my Vista as I had complained them about a peculiar sound which used to come from the front suspension after negotiating a road hump. I was told by the service engineer that there is a directive given to them to replace this unit for all Vistas irrespective of whether the owner complains about this or not.
NFS-II is offline   Reply With Quote
Old 27th April 2010, 11:03   #553
Senior - BHPian
 
deepclutch's Avatar
 
Join Date: Oct 2008
Location: Muvattupuzha
Posts: 1,120
Thanked: 109 Times
Default

I sometimes Hear a Whining like Noise from the Left Rear Suspension.This Happens after someone leaving the left rear Passenger Seat.Is this a Common thing?
This happens only randomly.Anyone?
deepclutch is offline   Reply With Quote
Old 27th April 2010, 13:23   #554
BHPian
 
NFS-II's Avatar
 
Join Date: Jun 2007
Location: Bangalore
Posts: 53
Thanked: 2 Times
Default

Quote:
Originally Posted by deepclutch View Post
I sometimes Hear a Whining like Noise from the Left Rear Suspension.This Happens after someone leaving the left rear Passenger Seat.Is this a Common thing?
This happens only randomly.Anyone?
Deepclutch, the same might be true for the rear suspension too. If your car is under warranty I suggest you mention this to the TASC and get it sorted at the earliest.
NFS-II is offline   Reply With Quote
Old 27th April 2010, 15:30   #555
BHPian
 
Join Date: Jan 2010
Location: Surat/Mumbai
Posts: 201
Thanked: Once
Default

Quote:
Originally Posted by NFS-II View Post
Deepclutch, the same might be true for the rear suspension too. If your car is under warranty I suggest you mention this to the TASC and get it sorted at the earliest.
What exactly needs to be replaced? And would they replace it irrespective of the year of production? I mean, we have one which we bought just four months ago. And not sure whether there's a similar noise or not.
Johnny_ is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fiat Palio MJD - Known Problems Ice Technical Stuff 304 23rd October 2016 13:31
Help Required Indica Vista Safire or Indica Vista TDI Logical Hatchbacks 63 30th October 2011 08:57


All times are GMT +5.5. The time now is 08:03.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks