Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 4th May 2010, 16:14   #571
Newbie
 
Join Date: Nov 2009
Location: BELGAUM
Posts: 11
Thanked: 0 Times
Default Rear Suspension

Quote:
Originally Posted by fifthwheel View Post
I got all kinds of noises from the rear of my AURA QUADRA starting 6th month. First the TASS changed the bushes in the LH side & last week got my RH raer shocks replaced (both under warranty). In fact I was worried when I was getting lots of squeeking noises from the rear RH, resembling some kind of bearing noise. Thank god, it's only the noise from the shocks. The kind of support I get from the TASS is excellent & the kind of envious looks I get from the MARUTI customers is unbearable.

Guys, incidentally my VISTA is coing to celebrate 1st anniversary tomorrow. 18000kms & still wearing the roads & tires
I have done 4800 kms / 6 months on my vista quadrajet aura. I am frequently experiencing a 'good' THUD sound in the rear (prominently in the rear left) while descending a rumble strip (speed Breaker) or a step 2-3 inches deep. (available at the TASS entrance gate !) even at a speed below 15-20 kms. I have faced this since a long time. During first service, they replaced the rear shox and problem was minimized (almost gone.) Now i am experiencing it again since a month or so. But during Second service (4-5 days back), TASS people took a stand that 'this is a common problem to all vistas', 'see this car makes more noise than your's..'.....etc. and did not do anything about it.
What can/should i do now ?
However i am waiting for TML's call about service feedback.
hysys is offline   Reply With Quote
Old 4th May 2010, 17:12   #572
BHPian
 
Join Date: Jan 2010
Location: Surat/Mumbai
Posts: 201
Thanked: Once
Default

Quote:
Originally Posted by hysys View Post
I have done 4800 kms / 6 months on my vista quadrajet aura. I am frequently experiencing a 'good' THUD sound in the rear (prominently in the rear left) while descending a rumble strip (speed Breaker) or a step 2-3 inches deep. (available at the TASS entrance gate !) even at a speed below 15-20 kms. I have faced this since a long time. During first service, they replaced the rear shox and problem was minimized (almost gone.) Now i am experiencing it again since a month or so. But during Second service (4-5 days back), TASS people took a stand that 'this is a common problem to all vistas', 'see this car makes more noise than your's..'.....etc. and did not do anything about it.
What can/should i do now ?
However i am waiting for TML's call about service feedback.
15-20 kmph is a good speed to be going through the speed breaker. I don't think anything's wrong with the car.
Johnny_ is offline   Reply With Quote
Old 6th May 2010, 09:34   #573
BHPian
 
NFS-II's Avatar
 
Join Date: Jun 2007
Location: Bangalore
Posts: 53
Thanked: 2 Times
Default

Quote:
Originally Posted by hysys View Post
I am frequently experiencing a 'good' THUD sound in the rear (prominently in the rear left) while descending a rumble strip (speed Breaker) or a step 2-3 inches deep. (available at the TASS entrance gate !) even at a speed below 15-20 kms.
Hysys, there is a chance that this sound is from the fuel in fuel tank. in most of the cars you hear this sound when the tank is 3/4th full. Observe if this is the case in yours too.
NFS-II is offline   Reply With Quote
Old 27th May 2010, 18:21   #574
BHPian
 
Join Date: Jul 2009
Location: Bangalore
Posts: 194
Thanked: 49 Times
Default

Hi Guys, I hit a rod while reversing today and broke the rear windsheild glass. Called the windsheild experts and they quoted 3900/-. They say the glass for vista is expensive.
Isnt that quite expensive? TAS quoted around 5K with labor for the replacement.
Anyone here has any experiences around replacing this glass? Any why should it be so expensive?
vista_qjd is offline   Reply With Quote
Old 27th May 2010, 19:06   #575
BHPian
 
Join Date: Dec 2008
Location: Pune
Posts: 553
Thanked: 214 Times
Default

Quote:
Originally Posted by vista_qjd View Post
Hi Guys, I hit a rod while reversing today and broke the rear windsheild glass. Called the windsheild experts and they quoted 3900/-. They say the glass for vista is expensive.
Isnt that quite expensive? TAS quoted around 5K with labor for the replacement.
Anyone here has any experiences around replacing this glass? Any why should it be so expensive?
I think that is because of Rear Demister.
sushantr5 is offline   Reply With Quote
Old 27th May 2010, 23:01   #576
BHPian
 
Join Date: Jul 2009
Location: Bangalore
Posts: 194
Thanked: 49 Times
Default

The cost breakup was as follows - 1900 for the glass, 800 for the glue and 1000//- for installation. Fixing it seemed fairly easy, scrape the remaining glass pieces and apply the glue and slap the new windscreen on.
The 1000/- for installation seemed fairly expensive. Next time would recommend others to bargain this down.
vista_qjd is offline   Reply With Quote
Old 27th May 2010, 23:28   #577
Senior - BHPian
 
Join Date: Sep 2006
Location: zxc
Posts: 3,394
Thanked: 658 Times
Default

what make is the adhesive? I think he is quoting just double.
SirAlec is offline   Reply With Quote
Old 28th May 2010, 09:32   #578
BHPian
 
faridsahmed's Avatar
 
Join Date: Nov 2009
Location: Chennai
Posts: 150
Thanked: 8 Times
Default

In cases where you not not too sure about the price quoted by a certain TASC - then why not ask few other TASCs ?
I think that this might give you a fair idea.
This is just what I would have done in my case.
faridsahmed is offline   Reply With Quote
Old 28th May 2010, 10:11   #579
BHPian
 
Join Date: Jul 2009
Location: Bangalore
Posts: 194
Thanked: 49 Times
Default

The TASC (concorde bangalore) were quoting around 5500/- including labour and also two days time to complete the work.
vista_qjd is offline   Reply With Quote
Old 28th May 2010, 10:42   #580
BHPian
 
faridsahmed's Avatar
 
Join Date: Nov 2009
Location: Chennai
Posts: 150
Thanked: 8 Times
Default

What version is your vehicle?
Terra , Aqua or Aura? The reason for asking is :
the rear glass has a hole for rear wiper + demister.

If you provide me the details - i"ll call up a TASC in Pune and ask them the rates right away.
faridsahmed is offline   Reply With Quote
Old 28th May 2010, 13:45   #581
BHPian
 
Join Date: Jul 2009
Location: Bangalore
Posts: 194
Thanked: 49 Times
Default

Aqua - Quadrajet, with the demister, but no rear wipers.
vista_qjd is offline   Reply With Quote
Old 28th May 2010, 15:58   #582
Senior - BHPian
 
greenhorn's Avatar
 
Join Date: Apr 2007
Location: TN-14
Posts: 6,838
Thanked: 1,318 Times
Default

seems par for the course . the rear glass for my indica DLG (with demister) cost me 1.9K

sealent was another 1k

bill details here
http://www.team-bhp.com/forum/long-t...ml#post1513425
greenhorn is online now   Reply With Quote
Old 31st May 2010, 17:22   #583
BHPian
 
schitre05's Avatar
 
Join Date: Apr 2009
Location: Mumbai
Posts: 431
Thanked: 81 Times
Default

Recently I have been hearing a lot of squeaking noise in my vista's air conditioner at 1st and 2nd position of the blower, as soon as I increase the speed to the 3rd position the noise disappears. is changing the blower the only remedy?

I know that vista's brakes are not great but it seems they have further deteriorated any chance of getting them replaced under warranty?

The engine guard beneath the body shudders a lot while the car starts to get in to motion, previously this had been pointed out to the TASC, they just tightened few screws and the shuddering disappeared for some time, only to come back.

The vista is now due for its second service at 10k kms
schitre05 is offline   Reply With Quote
Old 3rd June 2010, 22:58   #584
Senior - BHPian
 
Join Date: Apr 2007
Location: noida
Posts: 1,049
Thanked: 297 Times
Default

Guys my 6 year old Indica DLS ( 94 K Km)has been guzzling fuel ( 11kpl with AC) and the accelration is also poor. The car starts easily enough. Would like your opinion as to what could be the reason. Should I get the compression checked or is the fuel pump the suspect. TSK 1979 your suggestions would be most welcome.
rajneeesh is offline   Reply With Quote
Old 4th June 2010, 15:41   #585
BHPian
 
gurudutt's Avatar
 
Join Date: Jan 2010
Location: Bangalore
Posts: 352
Thanked: 128 Times
Default Poor Mileage.

Hi Guys,
I have been getting very poor mileage in my Vista Quadrajet. I always check full tank to full tank and have never got more than 13 KMPL (with A/C on always). She has already done around 2400 kms. I noticed a lot of black smoke from her exhaust and prerana motors service station cleaned the air filter and reset the car ECU, now the black smoke is gone but the mileage is still bad, i got 11 after that. I had been to mysore once and i got just 14. Any info/help is seriously appreciated.
gurudutt is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fiat Palio MJD - Known Problems Ice Technical Stuff 304 23rd October 2016 13:31
Help Required Indica Vista Safire or Indica Vista TDI Logical Hatchbacks 63 30th October 2011 08:57


All times are GMT +5.5. The time now is 20:03.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks