Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 17th November 2013, 20:36   #1216
BHPian
 
amit_purohit20's Avatar
 
Join Date: May 2006
Location: mumbai
Posts: 557
Thanked: 466 Times
Default Re: Indica Vista - list of Known problems

I used to think that the Fiat MJD Engine was a reliable and proven workhorse. But it seems a lot of people are having issues with this engine. I have seen engine timing chain break at just 35k kms in one of the Vista.

Are the engine issues equal in Maruti Swift? I seriously doubt that Fiat MJD engine issues are more in Tata vehicles as compared to Maruti. Is it something to do with manufacturing difference between Maruti and Tata? I suppose the drawings remain the same for both the engines but there might be difference in quality and fitment between TATA and MARUTI make FIAT MJD engines.

This really needs a thought.
amit_purohit20 is offline   Reply With Quote
Old 18th November 2013, 08:11   #1217
Senior - BHPian
 
extreme_torque's Avatar
 
Join Date: Feb 2005
Location: Melbourne
Posts: 3,546
Thanked: 1,317 Times
Default Re: Indica Vista - list of Known problems

Quote:
Originally Posted by amit_purohit20 View Post
I used to think that the Fiat MJD Engine was a reliable and proven workhorse. But it seems a lot of people are having issues with this engine. I have seen engine timing chain break at just 35k kms in one of the Vista.

Are the engine issues equal in Maruti Swift? I seriously doubt that Fiat MJD engine issues are more in Tata vehicles as compared to Maruti. Is it something to do with manufacturing difference between Maruti and Tata? I suppose the drawings remain the same for both the engines but there might be difference in quality and fitment between TATA and MARUTI make FIAT MJD engines.

This really needs a thought.
Not sure if even that it the case. Maruti sources some of its MJD engine from Fiat Powertrains India.
extreme_torque is online now   (1) Thanks Reply With Quote
Old 18th November 2013, 13:36   #1218
BHPian
 
amit_purohit20's Avatar
 
Join Date: May 2006
Location: mumbai
Posts: 557
Thanked: 466 Times
Default Re: Indica Vista - list of Known problems

Quote:
Originally Posted by extreme_torque View Post
Not sure if even that it the case. Maruti sources some of its MJD engine from Fiat Powertrains India.
If I am not wrong it was only the wiring harness and ECU chip which was being sourced by Maruti from Fiat which was manufactured by TATA.

I think Maruti makes all the mechanical parts of the engine either in its own manesar factory and some parts it outsources from vendors. Assembly again for the engine is done at Manesar plant.

So just wanted to know whether both side these engines fare the same or is it different in different vehicles.

I might be wrong but somehow I get the feel that Fiat engines in Tata vehicles have more problem than Maruti vehicles. I need to do more research or it might be a wrong hunch but something which we need our thoughts to ponder for sure.
amit_purohit20 is offline   Reply With Quote
Old 18th November 2013, 14:14   #1219
Newbie
 
Join Date: Oct 2007
Location: Hyderabad
Posts: 20
Thanked: 18 Times
Default Re: Indica Vista - list of Known problems

As far as I know, Maruti makes all of its 75 bhp diesel engines and pays royality fee to Fiat.

They probably source the 90bhp engine from Tata Fiat JV (only in terms of engine manufacturing)

I may be wrong on the 90bhp information though.

As regards the power loss issue, with Fiat MJD engines. I found numerous threads on fiat forum out side India too which had similar problems reported.

What is surprising though is that this is supposed to be a decade old engine and still Fiat has not bothered to rectify some of this long running issues...

Probably there is no incentive of improving the quality when customers are lapping up there current junk in such huge numbers...
Mahendraps is offline   Reply With Quote
Old 18th November 2013, 14:30   #1220
rkg
Senior - BHPian
 
Join Date: Apr 2005
Location: bangalore
Posts: 1,041
Thanked: 543 Times
Default Re: Indica Vista - list of Known problems

Quote:
Originally Posted by amit_purohit20 View Post
If I am not wrong it was only the wiring harness and ECU chip which was being sourced by Maruti from Fiat which was manufactured by TATA.

I think Maruti makes all the mechanical parts of the engine either in its own manesar factory and some parts it outsources from vendors. Assembly again for the engine is done at Manesar plant.

So just wanted to know whether both side these engines fare the same or is it different in different vehicles.

I might be wrong but somehow I get the feel that Fiat engines in Tata vehicles have more problem than Maruti vehicles. I need to do more research or it might be a wrong hunch but something which we need our thoughts to ponder for sure.
This is what many of Indians believe, in spite of obvious facts. Maruti sources engines from TATA-FIAT JV. This problem of powerless was also reported in many Swifts. Only one has to search the net. But many of us think maruti is GOD and hence could /can not do any wrong

http://www.business-standard.com/art...1900023_1.html
http://articles.economictimes.indiat...et-swift-dzire
rkg is offline   Reply With Quote
Old 18th November 2013, 20:13   #1221
Newbie
 
Join Date: Oct 2011
Location: Chennai
Posts: 20
Thanked: 7 Times
Default Re: Indica Vista - list of Known problems

Quote:
Originally Posted by bajica View Post
Hello all,

This reply is with regards to recent problems of people experiencing loss of power.
I had too faced this issue long back (around 2 yrs), but then I observed that this particular issue was faced when I moved from city traffic to highway driving. The thing I noticed particularly was that the air outside is much cooler than the air in the city.
Hence I deduced that the ECU's air sensor would need sometime to adjust the fuel flow according to the fresh cool air thus giving the loss of power.

This was my observation from my VISTA experience.
Hope this might have helped someone.
Thank you for sharing your experience. The issue happened again last weekend and this time i was driving in the Namakkal - Karur highway (GQ) and it occured only once at around 3.30PM. I could clearly replicate the issue in 5th gear at around 2K rpm, when the speed approached 80 to 90. I could feel the car shaking and the steering vibrating for few seconds. It was too hot outside and the AC was on, with just 2 passengers including me. Heck, I was able to replicate it even when i was driving alone in the evening without AC. So this does not seem to be an issue with the load.
I have a few questions,
1) So when you faced this issue, did you take it to the service center?
2) Didn't you face this issue in the past 2 years?
3) General question: Can you share your experience with the car so far in a short summary.

(Too many questions, pardon my curiosity)



Quote:
Originally Posted by Mahendraps View Post
Here is further update on this issue.

I approached KHT motors service center for identification and rectification :

Thank you for sharing your experience. Some how, while my return to Chennai yesterday, I was not able to replicate the issue
However, I was able to accelerate in 5th gear only after 65 kms of my journey. Let me explain how I tried to replicate the issue,

While I approached the highway, car has already done 65Kms (Speed was below 70), I was in second gear. I reached the highways, moved to gears 2-3-4-5. I told the other 2 passengers to be watchful for any vibrations. Pressed the accelerator gradually, rpm raised from 1.5K, 1.6, 1.7, 1.8, 1.9, 2K, 2.1K, 2.2K, 2.3K, 2.4K - speedo was already at 100.
No vibrations, Nothing. The car pulled cleanly without any fuss.

The other 2 passengers were looking at me like 'What happened to this guy!'

After reading your story, Now, I am more confused if I need to take it to the TATA service center this weekend.
DriveAddict is offline   Reply With Quote
Old 20th November 2013, 09:35   #1222
Newbie
 
bajica's Avatar
 
Join Date: Jan 2010
Location: Mumbai
Posts: 23
Thanked: 5 Times
Default Re: Indica Vista - list of Known problems

Quote:
Originally Posted by DriveAddict View Post
3) General question: Can you share your experience with the car so far in a short summary.
I have not faced this issue for a long time. I have not done anything for the same i.e.not shown to any service center or changed anything.
As for my experience, I love this car. After 5 yrs and 45K+ kms, it is still running good. Most of my drives include highway runs of 500Km at a stretch. It is quite a good car and fulfills my requirements to the dot. No major servicing cost or repairing cost.
bajica is offline   (1) Thanks Reply With Quote
Old 20th November 2013, 12:37   #1223
Newbie
 
Join Date: Oct 2007
Location: Hyderabad
Posts: 20
Thanked: 18 Times
Default Re: Indica Vista - list of Known problems

Quote:
Originally Posted by DriveAddict View Post

After reading your story, Now, I am more confused if I need to take it to the TATA service center this weekend.
I did talk to Tata Motors representative Mr. Raghavendra, and he did update me that this is a known issue and need to be rectified.

I will be re-visiting the service centre when Mr. Raghavendra will be present and he will work with the KHT Motors folks to identify the root cause.

I will post the updates thereafter.
Mahendraps is offline   (1) Thanks Reply With Quote
Old 21st November 2013, 12:47   #1224
BHPian
 
Arun.K's Avatar
 
Join Date: Jun 2011
Location: Coimbatore
Posts: 120
Thanked: 47 Times
Default Re: Indica Vista - list of Known problems

Quote:
Originally Posted by amit_purohit20 View Post
I have seen engine timing chain break at just 35k kms in one of the Vista.
Timing chain was changed in one of our Vista around 70000 KMs due to abnormal noise. Now at 140000 Kms, the same kind of noise started. Seems like again timing chain kit need a replacement. The estimation given by TASC was Rs. 10000/- approx and 1 1/2 days work.

Mahendraps and DriveAddict do you feel the loss of power around 1900 RPM in other gears? I have the problem in my Vista right from 5000 KMs. It has run 43000 KMs now. Loss of power can be felt more in 2nd and 3rd gear when it crosses 1900 RPM. TASC people tried many options but couldn't solve it. Finally they say everything is normal. Now I got used to the problem. The other Vista in our family absolutely doesn't have this power loss problem.


My Vistaís heater inlet hose (HVACís) coupling got damaged resulting in coolant leakage. Tried with M-Seal first, even then there was mild seeping of coolant. So it was changed. The final bill inclusive of labour was Rs. 653/-. In addition to the above work, I asked the TASC guys to do a general check up of the suspension, oils and left brake caliper noise. Noise was arrested by placing a shim. All these jobs were done free of cost.
Indica Vista - list of Known problems-heaterhose.jpg   <div style=
Arun.K is offline   (2) Thanks Reply With Quote
Old 21st November 2013, 15:50   #1225
Newbie
 
Join Date: Oct 2007
Location: Hyderabad
Posts: 20
Thanked: 18 Times
Default Re: Indica Vista - list of Known problems

Thanks for your valuable input Arun, in my case I have observed loss of power only in 5th gear and yes around 1900 RPMs. I did not observed this problem in 4th gear though, and the vehicle could pull easily to 100KMph in 4th gear. I did not try in lower gears though.

On a different note though, it was during last trial post the service (i.e. rectify engine power loss problem), to observe similar behaviour of loss of power in 4th gear too in around 1800 - 2100 rpm range when the white smoke issue cropped up, or may be it would have happened any ways due to faulty servicing. Now I cannot say conclusively.


During my last interaction with the service centre folks, I did apprise them with details of this issue and did let them know specifically that this is a known issue with fiat engine, still they chose to turn a blind eye and in turn worsened the existing issue.

Last edited by Mahendraps : 21st November 2013 at 16:06.
Mahendraps is offline   (1) Thanks Reply With Quote
Old 21st November 2013, 18:57   #1226
Newbie
 
Join Date: Oct 2011
Location: Chennai
Posts: 20
Thanked: 7 Times
Unhappy Re: Indica Vista - list of Known problems

Quote:
Originally Posted by Arun.K View Post
Mahendraps and DriveAddict do you feel the loss of power around 1900 RPM in other gears?
Thank you for sharing your experience. I feel the loss of power around 1900 RPM only in 5th gear. Normally, I shift gears 1-2-3-4-5 once the rpm touches 2000. Hence I can confirm this happens only after shifting from 4-5. After every shift the rpm falls to ~1500. As I press the accelerator, gradually it climbs to 2000. Just before the needle touches 2000, I feel the loss of power and the vibrations only in 5th gear. The other day, the same happened at around 2100 to 2300 in 5th gear. I have never crossed 2500 rpm so far.
DriveAddict is offline   (1) Thanks Reply With Quote
Old 21st November 2013, 19:18   #1227
Senior - BHPian
 
greenhorn's Avatar
 
Join Date: Apr 2007
Location: TN-14
Posts: 6,838
Thanked: 1,317 Times
Default Re: Indica Vista - list of Known problems

Funnily enough, I am facing the same issue in my First gen indica turbo (6 years, 67K Kms). This problem cropped up at around 37K kms, and still hasnt gone away. I can rev upto 3K Rpm, but speed doesnt go above 120 in 5th . All the mechanics say that it is normal indica ageing. Surprised to find the same in the QJD engine.

Last edited by greenhorn : 21st November 2013 at 19:28.
greenhorn is offline   Reply With Quote
Old 23rd November 2013, 12:43   #1228
BHPian
 
Arun.K's Avatar
 
Join Date: Jun 2011
Location: Coimbatore
Posts: 120
Thanked: 47 Times
Default Re: Indica Vista - list of Known problems

Quote:
Originally Posted by Mahendraps View Post
I have observed loss of power only in 5th gear and yes around 1900 RPMs.
Quote:
Originally Posted by DriveAddict View Post
I feel the loss of power around 1900 RPM only in 5th gear.
To be precise, once it crosses 30 kmph in 2nd gear, 45 in 3rd gear, and 70 in 4th gear the power loss issue crops up. Moreover, the engine noise alone increases but pickup drops. And this happens occasionally and remains for sometime. So quick gear up-shift is required for overtaking, at times it's annoying. Interestingly, if the car is parked in hot sun for sometime, there is no problem with the pickup / power loss. Even ECU scanning didn't give any error.
Arun.K is offline   Reply With Quote
Old 23rd November 2013, 13:13   #1229
BHPian
 
discoverwild's Avatar
 
Join Date: May 2009
Location: Coimbatore
Posts: 682
Thanked: 950 Times
Default Re: Indica Vista - list of Known problems

Hi Arun,

Since we live in the same town, you could probably drop by and try mine. Never had any issues so far. Almost done 39K kms as of yesterday.
discoverwild is offline   (1) Thanks Reply With Quote
Old 24th November 2013, 13:07   #1230
BHPian
 
dhondusaxena's Avatar
 
Join Date: Nov 2007
Location: Greater Noida
Posts: 108
Thanked: 41 Times
Default

This loss of power issue is a regular one. Generally happens after a cold start and as you gradually increase speed at the speed of 80/90 there feels as if the power is coming and going. If you throttle hard/clear this speed range you may not evem notice this at all but it is quite evident if one plans to stay in this speed range with a very light press on the accelerator.

I have had this issue since the time I bought the car in 2012 and I noticed the same in my father's Manza too. Didn't see this in my brother's Vista though.

TASS engineer told me it was because of cold start, but their GM told me it is the turbo exchange point.
dhondusaxena is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Fiat Palio MJD - Known Problems Ice Technical Stuff 304 23rd October 2016 13:31
Help Required Indica Vista Safire or Indica Vista TDI Logical Hatchbacks 63 30th October 2011 08:57


All times are GMT +5.5. The time now is 09:27.

Copyright ©2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks