Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 11th April 2009, 01:51   #1
BHPian
 
Born 2 Be Wild's Avatar
 
Join Date: Apr 2008
Location: DILLI
Posts: 385
Thanked: 162 Times
Default Ikon 1.8 Radiator Fan not Working!!

Hi Guys Today while Driving my Ikon 1.8 In rush hour traffic with the A/c on the cooling which till date has been exceptional suddenly reduced tremendously. Also the temp needle started rising slowly, and voila there was a slight burning smell like plastic and a small amount of smoke frm the bonnet.

I pulled over Popped the hood of the car and saw the radiator Fan was not working also there was no smoke but was a small burning smell like plastic. By now the Temp nedle was around 3/4 mark.

Traffic had eased up by now and i hit the ring road so was able to drive home at around 60kph with the temp needle never crossing the half was mark

Checked the fuses next to the battery and the 60 amp fuse is blown.
Born 2 Be Wild is offline   Reply With Quote
Old 11th April 2009, 02:18   #2
BHPian
 
Born 2 Be Wild's Avatar
 
Join Date: Apr 2008
Location: DILLI
Posts: 385
Thanked: 162 Times
Default

Guys could you please advise on the current situation as to what can be at fault and the costs involved.

Also i am looking at a decent workshop other that the FOrd centres to get this repaired as i have had nasty experiences at Ford, So if you guys could suggest a decent Workshop In delhi Or NCR i would be obliged.

[ Mods am sorry hit enter by mistake and could not complete the post tried editng but 20 mins had elapsed hence the second post]
Born 2 Be Wild is offline   Reply With Quote
Old 12th April 2009, 00:39   #3
GTO
Team-BHP Support
 
GTO's Avatar
 
Join Date: Feb 2004
Location: Bombay
Posts: 47,716
Thanked: 89,176 Times
Default

Me thinks it's a wiring / electrical problem, hence you got the burning smell of plastic. That's why your fuse went off as well. Have an expert go through the entire electrical network, especially focusing on the cooling system. If the temp didn't go over 1/2 or 3/4, your engine should be safe.

Search through the forum got recommended shops up north.
GTO is offline   Reply With Quote
Old 12th April 2009, 19:54   #4
BHPian
 
Born 2 Be Wild's Avatar
 
Join Date: Apr 2008
Location: DILLI
Posts: 385
Thanked: 162 Times
Default

Quote:
Originally Posted by GTO View Post
Me thinks it's a wiring / electrical problem, hence you got the burning smell of plastic. That's why your fuse went off as well. Have an expert go through the entire electrical network, especially focusing on the cooling system. If the temp didn't go over 1/2 or 3/4, your engine should be safe.

Search through the forum got recommended shops up north.
Even i think its something to do with faulty wiring somewhere, the issue is to find a competent mechanic who doesnt rip me off because am still studying and have a tight budget

Any how i went to south city ford in noida and the service advisor looked at the car for 5 mins an gave me an estimate of 8000/rs . On my asking whats wrong he said that they have to replace the radiator fan motor as its not working.

Tried searching the forum but didnt find anything on reccomended workshops in NCR delhi. Guys am desperate now so if any one of you knows of a decent mechanic please let me know.
Born 2 Be Wild is offline   Reply With Quote
Old 13th April 2009, 00:29   #5
BANNED
 
Join Date: Nov 2008
Location: New Delhi
Posts: 690
Thanked: 152 Times
Infractions: 0/1 (5)
Default

Ask any car electrician to check whether radiator fan is working by disconnecting the fan coupler and connecting it directly to battery this way you will know atleast the fan is well .After that you can decide anything else .
Trust_In_Thrust is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Should the radiator fan be running all the time? weejai Technical Stuff 21 10th September 2017 16:35
Radiator fan - Low speed not working MadRash Technical Stuff 7 2nd April 2014 13:50
Urgent: Fiat Palio 1.2 Radiator Fan Not Working extreme_torque Technical Stuff 13 27th May 2010 12:01
Strange problem with Petra - Radiator fan jraj Technical Stuff 8 24th August 2008 14:00
Radiator Fan Blues tsk1979 Technical Stuff 14 29th October 2007 17:31


All times are GMT +5.5. The time now is 11:42.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks