Go Back   Team-BHP > Under the Hood > Technical Stuff

Thread Tools Search this Thread
Old 27th April 2009, 23:54   #1
Join Date: May 2006
Location: Bangalore
Posts: 13
Thanked: 0 Times
Default Injection System Indicator

The injection system indicator on my console of Petra D keeps ON when key is moved to ignite. The indicator is supposed to go OFF after few seconds, but instead stays ON. If I crank up the engine, there is random injection of fuel, and obviously the engine is not smooth, running at low ratios.

However, if I start the engine, switch it off and turn the key to ignite, the indicator is normal (goes off after few seconds) and all's well.

In short, the time duration between two cranks should be less than 30 seconds, for normal operation of injection.

Has anyone faced this problem? When asked the service centre to fix this, the estimate of expense was Rs.25000!! Any other solutions??
abut_16 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Skoda Advisory - Rapid's Fuel Injection System VeyronSuperSprt Technical Stuff 2 2nd July 2015 10:31
2015 MotoGP Safety Car - BMW M4 with water injection system for cooler (intake) air syedhafeez The International Automotive Scene 0 17th February 2015 02:52
Common Rail Diesel Injection System dhanushs Technical Stuff 20 31st July 2011 20:22
Baleno : Turbo + Direct Lpg Injection System = V_E_R_Y Satisfied neo_trace Modifications & Accessories 13 29th January 2007 18:48
Tuned port fuel injection kakx Technical Stuff 4 17th April 2004 14:37

All times are GMT +5.5. The time now is 00:47.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks