Go Back   Team-BHP > Under the Hood > Technical Stuff

Thread Tools Search this Thread
Old 10th November 2009, 15:47   #16
Senior - BHPian
Gansan's Avatar
Join Date: May 2009
Location: Chennai
Posts: 3,389
Thanked: 830 Times


How long has this light been on? I would suggest that you check the tightness of the nuts in the battery terminals first. If it does not go off, have it checked asap.

As soon as my Alto came back to the show room post registration, one day prior to the actual delivery date, I took it out for a spin accompanied by a guy from the showroom. All dash board lights went off after I cranked the engine, released hand brake and started rolling, except this one light! I did not know what light it was and asked my companion, who told me not to worry and continue driving. As soon as we returned to the show room, he told me to switch off the engine, took out a spanner and tightened the very nuts I have mentioned above. Thereafter the light went off as soon as the engine was cranked, and the problem has not returned.
Gansan is online now   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
5009 KMS-A'bad-Calicut-Bangy-Hyd-Aur'Bad-A'Bad-Report ramkya1 Travelogues 48 4th August 2010 00:04
A bad bad bad night for me.... Ranjan Sharma Street Experiences 38 8th April 2010 12:02
Can indicator/wiper levers be swapped in Skoda? silverbyte Modifications & Accessories 5 2nd July 2009 09:04
My accident - Bad brakes, bad rain, bad luck... vezj420 Street Experiences 41 22nd May 2007 10:49

All times are GMT +5.5. The time now is 19:24.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks