Go Back   Team-BHP > Under the Hood > Technical Stuff

Thread Tools Search this Thread
Old 5th August 2009, 10:09   #16
MindSpeeDs's Avatar
Join Date: Mar 2007
Location: hyderabad
Posts: 115
Thanked: 78 Times

Apologies for not updating this thread earlier.

Strange things happen! Existing water pump is absolutely fine, removed the thermostat valve
(was in bad shape). Issue solved!

No clue as to why the increase in RPM was working though.
MindSpeeDs is offline   Reply With Quote
Old 5th August 2009, 11:59   #17
Team-BHP Support
tsk1979's Avatar
Join Date: Feb 2005
Location: New Delhi
Posts: 22,555
Thanked: 14,830 Times

Ahh the valve.
Its obvious. The valve was partially clogged.
When you rev the engine the water pump pressure also increases, hence flow was okay. so with clogged valves which open partially, many times water flow is not optimal at low rpms.
tsk1979 is offline   Reply With Quote

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Overheating Issue cnaganathan Technical Stuff 66 15th January 2013 13:07
Very Strange Overheating Issue, Please Help johnruben Technical Stuff 34 3rd December 2010 02:22
Major error in Autocar March issue & Overdrive April issue as well Guna Shifting gears 20 11th May 2010 11:15
Performance issue for Lancer Diesel bibin999 Modifications & Accessories 2 21st July 2008 17:41
Engine Idling Issue 2fast4u Technical Stuff 10 5th February 2007 12:55

All times are GMT +5.5. The time now is 21:42.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks