Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 8th June 2016, 12:32   #511
BHPian
 
90Horses's Avatar
 
Join Date: May 2014
Location: Bangalore
Posts: 105
Thanked: 33 Times
Default Re: Some quality niggles & Issues in Fiat Punto

Quote:
Originally Posted by nkrishnap View Post
Get the engine C mount checked and also the A and B mounts, my guess is its gone. Replace it and it should be fine.

Also on the rpm jumping issues, a week alternator can cause this. Get that checked too.
Thanks I will get the mounts checked. How an alternator could lead to the rpm jump issue?
90Horses is online now   Reply With Quote
Old 8th June 2016, 12:34   #512
Distinguished - BHPian
 
nkrishnap's Avatar
 
Join Date: May 2006
Location: Bangalore
Posts: 3,233
Thanked: 3,409 Times
Default Re: Some quality niggles & Issues in Fiat Punto

Quote:
Originally Posted by 90Horses View Post
Thanks I will get the mounts checked. How an alternator could lead to the rpm jump issue?
I am still finding the reason why it would, but it does. A faulty alternator was causing the rough and unstable idling on my friend's Linea. Once the alternator was fixed it was sorted out.
nkrishnap is online now   (1) Thanks Reply With Quote
Old 8th June 2016, 19:00   #513
BHPian
 
Join Date: Aug 2009
Location: Bangalore
Posts: 51
Thanked: 23 Times
Default Re: Some quality niggles & Issues in Fiat Punto

Quote:
Originally Posted by BulZire View Post

Thanks much for the reference, I will defintely get in touch with them. The SE in Vecto is Prem.
I still remember him. AVOID PREM FROM VECTO MOTORS AT ANY COST..dont let him come near your car. I have had bad experiences with him.

1. I showed him uneven wear on one of the rear tyre..for which he told me that the suspension needs to be replaced..and will cost 18K. He showed my few photos in his mobile telling that he shot them when the care was jacked. it was some picture of a cover for the suspension spring..any common man would fall prey to his argument and agree with him.
when I got my car checked with other knows mechanic. he told me that the suspension is alright..went ahead and replaced it with a spare tyre..till now, I have done 5K on it and i do not see uneven wear anymore..it was a tyre fault..not suspension.
2. He called me and told me that the brake pads may last another 1K, so i replaced them. when I checked them they still have half life left. My car had done just 28K Kms.
3. He had few double billing like Brake cleaning = 400+ brake pad installation = 500+

I left the service station in shock, the I need to spend 18K on suspension..If I meet him again, he is going to get a nice one from me..

Last edited by sad:) : 8th June 2016 at 19:03.
sad:) is offline   (1) Thanks Reply With Quote
Old 8th June 2016, 19:15   #514
BHPian
 
Join Date: Aug 2009
Location: Bangalore
Posts: 51
Thanked: 23 Times
Default Re: Some quality niggles & Issues in Fiat Punto

Quote:
Originally Posted by 90Horses View Post
Hey guys, i need your advice. Recently i have changed my tyres to yoko earth1 with stock profile 195/60/15. After tyre change i feel some sort of shake while i drive in 2nd or 3rd staring from 12krpm to 18k rpm. This shake can be felt inside the car. Initially I thought it was balancing or alignment issue, have done a/b thrice and checked for alloy bend but everything reg tyres was fine.

After repeated tests I figured out, the wobble/shake happens only if the engine rpm is b/w 12-18k rpm and gear is in 2nd or 3rd.

I'm losing peace of mind and I am unable to enjoy my new set of tyres, I request you guys to help me with this issue.

Sai
One of my friend had a similar problem. He was unable to find out the reason for this for a long time and was annoying..you feel it only on a particular speed. he almost concluded that the axle may be bend and he needs to replace it. He raised this issue with tyre manyfacturer that this probelm has started only after he installed new tyre..finally it was concluded the tyre had a weak patch which was causing this problem. When you are at a particular speed, the timing is such that the effect of this weak tyre is clearly noticeable (kind of resonance). his faulty tyre was replaced under warranty.

Please check for any patch wear on your tyre..any particular are on the tyre wearing fast or showing signs of weakness.

Other option, give a try replacing tyre one by one with a spare one. I you see any good results, then you know that the tyre is culprit.

Last edited by sad:) : 8th June 2016 at 19:20.
sad:) is offline   Reply With Quote
Old 24th June 2016, 14:07   #515
BHPian
 
Join Date: Jan 2016
Location: Deutschland
Posts: 27
Thanked: 47 Times
Default Re: Some quality niggles & Issues in Fiat Punto

Recently I bought an used Grande Punto 1.4 8v 77PS petrol in Germany which was already driven for 145000 kms.

Following are the niggles which found in the used car:
1. Rear parcel tray clips got broken. Bought it from eBay and fixed it. Cost: 10
2. Cover for small fuse box on top of the battery is not there. Bought it from eBay and fixed. Cost: 22
2. AC was not working at all. Took it to the workshop and it seems AC refrigerant is empty. Refilled it in the workshop. Cost: 50
3. AC cooling is very minimal even if outside temperature is 25 degC. I suspected that the pollen filter might be blocked. So when I tried to open it I found out that the clip on the top of the black filter cover is broken and the cover is hanging because of which the cold air is leaking there and hence less cooling through the vents. Now ordered the cover through a Fiat dealer. It is not available online. Cost: 22

I find that these small plastic parts are very difficult to buy from internet and its very expensive if ordered through dealer.
gopi_rm is offline   Reply With Quote
Old 24th June 2016, 22:59   #516
BHPian
 
Join Date: Jan 2016
Location: Deutschland
Posts: 27
Thanked: 47 Times
Default Re: Some quality niggles & Issues in Fiat Punto

Hi Guys,

As I mentioned in my previous post, the cover of the pollen filter is broken and hanging. When AC is switched on, the coldness of the air coming out of the vents is very less and hence if I set the blower to full speed then air is neither cold nor hot.

Is it an issue due to the hanging pollen filter cover or due to any leak in the AC circuit?
Please give your opinion.
gopi_rm is offline   Reply With Quote
Old 11th October 2016, 16:39   #517
BHPian
 
BulZire's Avatar
 
Join Date: Nov 2010
Location: Bangalore
Posts: 346
Thanked: 130 Times
Default Re: Some quality niggles & Issues in Fiat Punto

Guys, need help in diagnoising a issue in Blue&Me.

Since morning, the USB is not getting detected. Also, there is no operation happening or nothing is displayed in console when i click main menu button in steering.
But my phone is paired and receive calls without issue. I don't see any problem in other steering mounted controls.

Please suggest if there is workaround i can try myself to fix this before taking to FASS.
BulZire is offline   Reply With Quote
Old 14th October 2016, 11:22   #518
Senior - BHPian
 
sandeepmohan's Avatar
 
Join Date: Feb 2010
Location: Bangalore
Posts: 1,805
Thanked: 1,332 Times
Default Re: Some quality niggles & Issues in Fiat Punto

Quote:
Originally Posted by BulZire View Post
Guys, need help in diagnoising a issue in Blue&Me.
It is possible that the usb device has failed. Check if Blue N me controls work by unplugging the drive. Do so after shutting down the car, unplugging the device and re starting the engine.

Plug the usb device on a computer to check that it works. Check if you read and play back content from your computer.

If the usb drive is found to be working on your computer, then the last option is to disconnect the negative terminal on the battery (no tools required), wait for fifteen minutes and reconnect. You will have to set the date and time again. Now check if Blue N Me works with the drive plugged in.

I have had a few instances of Blue N Me acting up. Disconnecting the negative terminal on the battery solved all problems related to Blue N Me.

Last edited by sandeepmohan : 14th October 2016 at 11:24.
sandeepmohan is offline   (1) Thanks Reply With Quote
Old 17th October 2016, 15:21   #519
BHPian
 
BulZire's Avatar
 
Join Date: Nov 2010
Location: Bangalore
Posts: 346
Thanked: 130 Times
Default Re: Some quality niggles & Issues in Fiat Punto

Quote:
Originally Posted by sandeepmohan View Post
I have had a few instances of Blue N Me acting up. Disconnecting the negative terminal on the battery solved all problems related to Blue N Me.
I tried all that you have suggested except disconnecting the negative terminal on the battery. Nothing helped and took the car to Vecto on saturday.
They did run the diagnostics and reset Blue&Me software. All fine now and was Charged 400Rs for this.
Later i felt that i should have tried disconnecting the battery also.I will keep this mind if Blue&Me shows some problem in future.
BulZire is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Black Punto MJD - 30400 KM Completed - Some issues ~~VinZ~~ Long-Term Ownership Reviews 9 21st April 2011 18:37
Swift VDI+ABS or Fiat Punto MJD or New Fabia 1.2 Diesel. Edit- Booked Fiat Punto MJD magnanimousdude Hatchbacks 59 27th October 2010 13:18


All times are GMT +5.5. The time now is 14:12.

Copyright 2000 - 2016, Team-BHP.com
Proudly powered by E2E Networks