Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 28th November 2009, 10:46   #16
BHPian
 
Join Date: Aug 2007
Location: Bangalore
Posts: 82
Thanked: 9 Times
Default

Guys Any Suggestions

I had taken it to one the FIAT Mechanics in Bangalore. He did put it to Analyser tests. No Error Codes or anything. He checked up the engine and said one of the "Cylinders" to be not working!! Is this right? He said if the car is still under warranty its better to take it to the Service Center.

Anybody has any suggestions on this? The car is just 1.5 Years old. Has run just below 10K. What should i do next? I am confused.
bond_bhai is offline   Reply With Quote
Old 28th November 2009, 11:31   #17
BHPian
 
vdiatech's Avatar
 
Join Date: Mar 2009
Location: Bangalore
Posts: 413
Thanked: 7 Times
Default

check ignition coil/plugs/leads and then a compression test of the cylinders. Do you see any particular sparkplug cable juddering while idling ?

I think if its the cylinder then you are probably looking at replacing pistons and rings. I hope it does not come to it and is just the plugs or coil.

chers
vdiatech is offline   Reply With Quote
Old 18th December 2009, 17:44   #18
BHPian
 
Join Date: Aug 2007
Location: Bangalore
Posts: 82
Thanked: 9 Times
Default

Another Update -
The car is now in Concorde Motors, Mysore Road. And here is the issue -
2 Damaged Pistons
one of the "Valves" Bent!

And this is a one year old car! A complete disaster. Although it will be repaired under warranty still, it sucks to get a piece with manufacturing defect! No idea how i am supposed to react to this :(
bond_bhai is offline   Reply With Quote
Old 18th December 2009, 17:47   #19
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,752
Thanked: 7,476 Times
Default

Ouch thats quite a damage, any idea how this happened?

Did you drive in any flooded street and stall, just checking?
Jaggu is offline   Reply With Quote
Old 18th September 2010, 20:35   #20
JVH
Senior - BHPian
 
JVH's Avatar
 
Join Date: Aug 2008
Location: Bangalore
Posts: 1,021
Thanked: 148 Times
Default

Bumping up an old thread for 2 reasons. First, was wondering what's the status of the repair work and secondly I met Ashwin a.k.a Bond_bhai @ Gowri Automobiles

So, Ashwin, what's the status? We couldn't chat today for obvious reasons and would like to know where things stand.
JVH is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help needed : Toyota Corolla 2004 Random Startup problem singh.amrit Technical Stuff 15 21st December 2016 12:45
Renault Duster 110 : THUD sound & vibration on engine startup noelravin Technical Stuff 6 21st January 2013 13:26
New Honda City (NHC - August 2004, 68,000KM) - Engine Shakes On Startup - Need Advice anandpadhye Technical Stuff 9 19th December 2009 01:02
Old Honda City 1.5 Engine vibrations gsubash Technical Stuff 26 15th July 2007 12:10
The curse has fallen upon Rossi! turbo_v12 Int'l Motorsport 10 24th May 2006 01:26


All times are GMT +5.5. The time now is 10:24.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks