Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 10th November 2009, 12:35   #1
BHPian
 
Join Date: Oct 2005
Location: @ Driver's Seat @
Posts: 683
Thanked: 57 Times
Default Swift : Sudden Surge in Power during accl and Kut kut sound at Braking

Hi
my swift has completed 5000 km till date and no issues with it until now.

What I have observed recently is that when the vehicle is accelerated smoothly at any gears, I see a sudden surge in power at around 1800 rpm. I couldnt make out the why it is happening. Was thinking fuel is the culprit. But till date, my swift drank only shell super. No fuel contamination is ruled out. What could be the things that needs to be looked at ? Planning to visit the MASS sometime this month.

Another issue is that I use engine braking in sync with brake. Now a days, I am getting a kut kut sound when I use the said combination. Even without engine brake, I still get the sound. What could be the reasons for the same.

Can you kindly guide me on these issues. I dont ride clutch anytime.
lambuhere1 is offline   Reply With Quote
Old 10th November 2009, 12:39   #2
Senior - BHPian
 
shankar.balan's Avatar
 
Join Date: Apr 2008
Location: BLR
Posts: 8,027
Thanked: 5,325 Times
Default

is the sound emanating from the engine during engine braking Or from the brakes at the time of application. please let us know if this sound emanates from the front of the car near the wheels - because it could be a tie-rod end, front suspension bush problem.
On a car thats done only 5000 km this ought not to be the case but it is worth checking.
shankar.balan is offline   Reply With Quote
Old 10th November 2009, 12:42   #3
BHPian
 
Sprucegoose's Avatar
 
Join Date: Jan 2006
Location: Mumbai
Posts: 311
Thanked: 38 Times
Default

could also be the engine mounting, but thats only if you hear the kat kat sound during accleration & while engine braking
Sprucegoose is offline   Reply With Quote
Old 10th November 2009, 13:01   #4
BHPian
 
Join Date: Oct 2005
Location: @ Driver's Seat @
Posts: 683
Thanked: 57 Times
Default

Quote:
Originally Posted by shankar.balan View Post
is the sound emanating from the engine during engine braking Or from the brakes at the time of application. please let us know if this sound emanates from the front of the car near the wheels - because it could be a tie-rod end, front suspension bush problem.
On a car thats done only 5000 km this ought not to be the case but it is worth checking.
Quote:
Originally Posted by Sprucegoose View Post
could also be the engine mounting, but thats only if you hear the kat kat sound during accleration & while engine braking
Sound comes from the engine compartment. and definitely not from the brakes.

Its a definite kat kat sound and not the squeeling sound from the brakes.

Any idea about the sudden surge in power
lambuhere1 is offline   Reply With Quote
Old 10th November 2009, 13:07   #5
Team-BHP Support
 
bblost's Avatar
 
Join Date: Jul 2007
Location: Hyderabad
Posts: 9,650
Thanked: 6,662 Times
Default

Is your swift a diesel.
Are you confusing this surge with the Turbo switching on.
bblost is offline   Reply With Quote
Old 10th November 2009, 13:50   #6
BHPian
 
Join Date: Oct 2005
Location: @ Driver's Seat @
Posts: 683
Thanked: 57 Times
Default

Nope honey. Mine is petrol one.

Thanks for your attention
lambuhere1 is offline   Reply With Quote
Old 10th November 2009, 14:40   #7
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,746
Thanked: 7,449 Times
Default

Check how your air intakes are, including filter and throttle body. Also check if all the spark plugs, wires are in good shape.

As far as deceleration sound is concerned, rule out if anything is stuck inside the brake disc cover or if there is any issue with calipers. Hope its not a broken tooth from the tranny? Better get it checked.
Jaggu is online now   Reply With Quote
Old 10th November 2009, 15:01   #8
Senior - BHPian
 
esteem_lover's Avatar
 
Join Date: Jul 2006
Location: Madras/Py
Posts: 7,554
Thanked: 445 Times
Default

Since the car is in warranty (I presume it is), get it to the MASS. Try resetting the ECU to eliminate the initial sluggishness. (Just MHO)

Quote:
Originally Posted by lambuhere1 View Post
Nope honey. Mine is petrol one.

Thanks for your attention
esteem_lover is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
2007 Indica Xeta: Engine losing power all of a sudden and regaining power after mins mohandas Technical Stuff 17 3rd May 2016 07:37
Surge Suppression required between car battery power supply and media player anthiltg Technical Stuff 27 11th October 2011 14:05
Annoying 'Power surge on hub-port' pop-up! Jayabusa Gadgets, Computers & Software 0 17th September 2010 15:48
High Pitched sound from my Civic during braking ? sunnysideup Technical Stuff 10 5th July 2010 11:02
Sudden Cedia Surge?? pooshnark The Indian Car Scene 56 24th July 2008 19:27


All times are GMT +5.5. The time now is 18:53.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks