Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 27th November 2009, 10:28   #1
BHPian
 
anarchist's Avatar
 
Join Date: Dec 2005
Location: Chicago / Namma Bengaluru
Posts: 371
Thanked: 2 Times
Question Getz CRDi stalling

Hi,

This has happened twice as yet, yesterday evening was once and today morning again the similar problem.

My car has got the following:
1. I have Pete's installed with K&N stock replacement filter (+1 setting)

2. use regular IOC diesel but the last tankful as high speed diesel at ioc pump which I frequent (1 amongst the 3 ioc pumps which I regularly use)

3. The music & and the aircon was on both these times and the car was stationary for over 8 hours both the time mentioned.

4 The car was in motion for around 20 minutes and the car stalled

When I tried starting the car without switching off my ICE the car did not start, I switch off the ICE and the aircon and try starting, I could get the car started but after cranking 3 times in each case. The problem hasnt reoccured after that.

I need your suggestions as what may be the issue with my l'il monster
anarchist is offline   Reply With Quote
Old 27th November 2009, 11:08   #2
Senior - BHPian
 
planet_rocker's Avatar
 
Join Date: Sep 2006
Location: Bong-land
Posts: 2,320
Thanked: 366 Times
Default

It is better to crank with the electrical items switched off (HL, ICE, AC...).

Since it has not occured again, i think there is any reason to worry. take care and drive safe.
planet_rocker is offline   Reply With Quote
Old 27th November 2009, 11:17   #3
Team-BHP Support
 
tsk1979's Avatar
 
Join Date: Feb 2005
Location: New Delhi
Posts: 22,955
Thanked: 15,648 Times
Default

One question, do you wait for the glow plug light to go off before cranking?
tsk1979 is offline   Reply With Quote
Old 27th November 2009, 11:39   #4
BHPian
 
anarchist's Avatar
 
Join Date: Dec 2005
Location: Chicago / Namma Bengaluru
Posts: 371
Thanked: 2 Times
Default

Yep I do that every time and also wait for the red n blue lights to go off before I start except when I have to start with the blue light on when the engine is cold.

As I said the problem occurred y day and today morning and it definitely doesn't mean its over and this wont come back to haunt me in the middle of Bangalore traffic nightmare on Sarjapur road.

Once a couple a months ago rats chewed away the Pete's connector wires but I managed to put them back together, I check if its the same case this time but all wires look intact in the engine bay. I know its safer to take it to HASS, but I want to wait till this happens again and I will surely be off to the HASS with the pete's box removed. :(
anarchist is offline   Reply With Quote
Old 27th November 2009, 16:19   #5
BHPian
 
live2drive's Avatar
 
Join Date: Oct 2008
Location: New Delhi
Posts: 525
Thanked: 25 Times
Default

This can happen due to a clogged fuel filter. Anarchist, when was the fuel filter changed? And how much has your car done?
live2drive is offline   Reply With Quote
Old 27th November 2009, 16:32   #6
BHPian
 
Sideways's Avatar
 
Join Date: Nov 2004
Location: Madras - India
Posts: 641
Thanked: 18 Times
Default

In addition to what live2drive has said, do you have the habit of fillling in fuel after the tank is nearly empty or do you fill up earlier? Try to avoid filling up after the tank is nearly empty.

Another issue might also be air in the fuel line. You will have to bleed the fuel line to get the air out.
Sideways is offline   Reply With Quote
Old 29th November 2009, 22:02   #7
BHPian
 
anarchist's Avatar
 
Join Date: Dec 2005
Location: Chicago / Namma Bengaluru
Posts: 371
Thanked: 2 Times
Default

Well to answer both ur questions, my car has run 22k, and its been 2k since the car was serviced and I always fill fuel as soon as the needle goes to the last line before the empty sign (I am not sure thats the right way to put it though) and the top up is always 30 litres max to full tank with the autostop cutting in. I will need to check the fuel filter and the fuel line, hope to make it to the HASS to check it up tomorrow
anarchist is offline   Reply With Quote
Old 29th November 2009, 22:19   #8
Senior - BHPian
 
kpzen's Avatar
 
Join Date: Oct 2004
Location: Faridabad
Posts: 5,545
Thanked: 1,599 Times
Default

Did u get the Fuel filter changed during the 20k service ?
kpzen is offline   Reply With Quote
Old 30th November 2009, 16:25   #9
BHPian
 
anarchist's Avatar
 
Join Date: Dec 2005
Location: Chicago / Namma Bengaluru
Posts: 371
Thanked: 2 Times
Default

Yes the fuel filter was changed, today morning my car stalled 3 times in my 1 hour drive to work :(, I will not be able to go to HASS tomorrow too as I will be busy in meetings all day.
anarchist is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Letz Getz Started (Hyundai Getz CRDi)- UPDATE: 40000, new alloys, tires!!! (page 30) ph03n!x Long-Term Ownership Reviews 598 6th November 2012 00:02
Winters are here : Getz CRDi getz some iCe! aZa In-Car Entertainment 68 22nd December 2010 00:23
Verna Crdi Vs GetZ Crdi. EDIT : Finalising on Getz! aks_karthik Hatchbacks 74 17th May 2009 10:22
Does selling 06 Getz GLE and buying a Getz CRDI or GLX with ABS make any sense? rm_arjuna Hatchbacks 16 26th April 2009 21:30
Stalling/Stopping issues with Accent Viva CRDi mobike008 Technical Stuff 12 19th April 2008 12:21


All times are GMT +5.5. The time now is 18:08.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks