Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 7th December 2009, 23:26   #1
BHPian
 
bullboy's Avatar
 
Join Date: Sep 2006
Location: Trivandrum
Posts: 577
Thanked: 35 Times
Default Ford Ikon TDCI - sound from engine

My ikon Tdci is giving a whinnying sound from the engine at around 1200 rpm .The A*S*S ,kairali ford till now has no clue of the issue and they replaced water pump .coolant and tightened the pullies etc .I had to visit the service center 4 times for this issue .Every time they sorts out the issue and after running for a few kilometers say 200-300, the sound is recurring .
I now have no clue on what to do.
bullboy is offline   Reply With Quote
Old 8th December 2009, 01:04   #2
Senior - BHPian
 
Join Date: Sep 2006
Location: zxc
Posts: 3,394
Thanked: 658 Times
Default

Its still in warranty. Please mentioned the oddo reading.

The sound is on idle or while in motion.
SirAlec is offline   Reply With Quote
Old 8th December 2009, 07:24   #3
Distinguished - BHPian
 
condor's Avatar
 
Join Date: Jun 2006
Location: Speed-brkr City
Posts: 10,736
Thanked: 4,311 Times
Default

Where is the sound coming from ? Is the sound consistent with any thing you do ?

What kind of speakers do you have ?
condor is online now   Reply With Quote
Old 8th December 2009, 07:38   #4
Distinguished - BHPian
 
phamilyman's Avatar
 
Join Date: Jul 2007
Location: Gurgaon
Posts: 5,601
Thanked: 3,451 Times
Default

check for alternator whine first!
phamilyman is offline   Reply With Quote
Old 8th December 2009, 09:38   #5
BHPian
 
bullboy's Avatar
 
Join Date: Sep 2006
Location: Trivandrum
Posts: 577
Thanked: 35 Times
Default

It has covered little over 12700 kms .The sound is heard only at lower rpms between 1000-1500 rpm. There is no sound when idling .or the engine is running (in fact i feel it is too hard to hear).When the car is idle when the rpm is increased just above 1000 rpm the sound is heard and dissappears (or becomes muted because of engine sound) above the 1500 mark.
There is no ice or speakers installed ,except seat covers,tints and horns everything is stock.
bullboy is offline   Reply With Quote
Old 8th December 2009, 12:17   #6
Senior - BHPian
 
Join Date: Sep 2006
Location: zxc
Posts: 3,394
Thanked: 658 Times
Default

Its still under warranty right. Get it resolved at A.S.S.

They changed the water pump at 12k kms. thats strange.

in my opinion its just the belts.
SirAlec is offline   Reply With Quote
Old 8th December 2009, 13:46   #7
BHPian
 
bullboy's Avatar
 
Join Date: Sep 2006
Location: Trivandrum
Posts: 577
Thanked: 35 Times
Default

yes .It has 3 yrs warranty (normal + Extd) .I went to A.S.S 4 times for this issue .Every time they will resolve the issue but after running for 200-300 kms the sound is back.
I also felt it is from the belts but dont know why they are unable to sort it out .Last time A.S.S people told that they flushed the entire coolant and the issue is completely solved.
I'm getting more frustrated over this.

Last edited by bullboy : 8th December 2009 at 13:48.
bullboy is offline   Reply With Quote
Old 8th December 2009, 16:32   #8
BHPian
 
ilangop's Avatar
 
Join Date: Jul 2008
Location: Pune/Neyveli
Posts: 913
Thanked: 578 Times
Default

Could it be from the POwer steering pump? A friend of mine had a similar problem and he identified it as a problem with that pump.
ilangop is offline   Reply With Quote
Old 8th December 2009, 18:43   #9
BHPian
 
bullboy's Avatar
 
Join Date: Sep 2006
Location: Trivandrum
Posts: 577
Thanked: 35 Times
Default

No idea . it is only at a particular rpm range.
bullboy is offline   Reply With Quote
Old 9th December 2009, 08:10   #10
BHPian
 
pb10gagan's Avatar
 
Join Date: Jan 2009
Location: Construction Capital
Posts: 357
Thanked: 2 Times
Default

could most probably be the alternator or the power steering pump.

i hope the power steering oil is topped up, if not look for some leakages.

any by sound from engine do you mean the engine compartment or have you actually figured out that its from the TDCi only.
pb10gagan is offline   Reply With Quote
Old 9th December 2009, 15:35   #11
BHPian
 
bullboy's Avatar
 
Join Date: Sep 2006
Location: Trivandrum
Posts: 577
Thanked: 35 Times
Default

@pb10gagan : Its from the engine compartment on the right side .where the belts and pullies are located.
bullboy is offline   Reply With Quote
Old 10th December 2009, 10:52   #12
GTO
Team-BHP Support
 
GTO's Avatar
 
Join Date: Feb 2004
Location: Bombay
Posts: 47,712
Thanked: 89,063 Times
Default

Quote:
Originally Posted by phamilyman View Post
check for alternator whine first!
Quote:
Originally Posted by ilangop View Post
Could it be from the POwer steering pump?
+1 to that. 99%, its either the power steering pump or the alternator that's causing a whine.
GTO is offline   Reply With Quote
Old 31st December 2009, 10:59   #13
BHPian
 
bullboy's Avatar
 
Join Date: Sep 2006
Location: Trivandrum
Posts: 577
Thanked: 35 Times
Default

This sound disappered by itself ... pheww..
bullboy is offline   Reply With Quote
Old 31st December 2009, 23:45   #14
BANNED
 
Join Date: Apr 2006
Location: chennai
Posts: 703
Thanked: 54 Times
Default

The Alternator /ac belt tensioner bearing is faulty . The sound would have come since last month it was raining heavily ( lol ) . Ask them to change the tensioner pulley .
greatmana2000 is offline   (1) Thanks Reply With Quote
Old 1st January 2010, 08:08   #15
BHPian
 
sudharma's Avatar
 
Join Date: Dec 2008
Location: Bangalore
Posts: 281
Thanked: 6 Times
Default

Quote:
Originally Posted by GTO View Post
+1 to that. 99%, its either the power steering pump or the alternator that's causing a whine.
+1 to that.

I understand that yours is a turbo Diesel? Could be your turbo whinning! What is the engine speed at which the turbo cuts in.?
sudharma is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
New Ford Ikon TDCi brochure! sidindica The Indian Car Scene 295 12th February 2012 21:18
Ikon TDCI discontinued ? EDIT: Confirmed: Ford stops Ikon production greatmana2000 The Indian Car Scene 61 10th February 2011 19:20
Advice Needed: Ford IKON Diesel(2009) engine sound too loud agent009 Sedans 16 15th March 2009 14:51
Ford Ikon TDCi normally_crazy The Indian Car Scene 17 28th November 2008 15:14
Sound from Engine Bay of Swift VDI (DDIS) - what would be the cause of this sound? DieselFan Technical Stuff 4 25th January 2008 18:31


All times are GMT +5.5. The time now is 21:47.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks