Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 15th December 2009, 10:04   #1
BHPian
 
wildchild4lyfe's Avatar
 
Join Date: Nov 2009
Location: mumbai
Posts: 405
Thanked: 4 Times
Unhappy Aveo 1.4 - Low Idling & Frequent Engine Stalling

i drive an Aveo 1.4.
well of late the cars been giving me problems.the car doesnt idle at 800. it stays in the range of 200-500..when i clutch it, it goes off... then after a couple of switching on and off it finally idles and runs smoothly.
the other day i went for a 300 km drive and on my way back the car started stalling every 10 - 15 mins..
the fuel mixture smelled very rich so i got the plugs checked.the plugs were fine. then i thought it because the car was running on the ac,music system and the xenons..i thought it was the battery...i dont think its that either..

can any of you guys here help me zero into the issue??

Thnaks..
wildchild4lyfe is offline   Reply With Quote
Old 15th December 2009, 10:07   #2
Senior - BHPian
 
gemithomas's Avatar
 
Join Date: Jan 2007
Location: Trivandrum
Posts: 2,364
Thanked: 136 Times
Default

Engine stalling after some running could be a fuel pump issue but not sure if it would lead to low idle rpm. Other things i can think of are the clogged throttle body or a bad oxygen sensor.
gemithomas is offline   Reply With Quote
Old 15th December 2009, 10:16   #3
Senior - BHPian
 
DieselFan's Avatar
 
Join Date: Mar 2007
Location: Bangalore
Posts: 1,570
Thanked: 233 Times
Default

Get you car ECU checked. Sometimes ECU settings go off track and this leads to erratic Idle RPMs. Best is take it to the authorised service center and ask them to run diagnostic tests on the car.
DieselFan is offline   Reply With Quote
Old 15th December 2009, 10:30   #4
BHPian
 
wildchild4lyfe's Avatar
 
Join Date: Nov 2009
Location: mumbai
Posts: 405
Thanked: 4 Times
Default

the TB has been cleaned as well as the injectors..

maybe i need to get my ECU settings checked...and i definately hope its not my o2 sensor..!!
thnx guys..!
wildchild4lyfe is offline   Reply With Quote
Old 15th December 2009, 11:04   #5
Senior - BHPian
 
Psycho's Avatar
 
Join Date: Jul 2004
Location: Bangalore
Posts: 1,042
Thanked: 95 Times
Default

How many km have you done and when was the last time you got the fuel filter changed.

It could also be the fuel pump but my guess would be the filter.
Psycho is offline   Reply With Quote
Old 15th December 2009, 11:13   #6
BHPian
 
anurag_p80's Avatar
 
Join Date: Dec 2007
Location: Hyderabad
Posts: 313
Thanked: 7 Times
Default

Have you definitly ruled out a case of bad fuel? Also check the Idle Control Valve, the Air Temperature sensor. If there is no fault with the sensors, than the Fuel Pump is probably the culprit.
anurag_p80 is offline   Reply With Quote
Old 15th December 2009, 11:29   #7
BHPian
 
wildchild4lyfe's Avatar
 
Join Date: Nov 2009
Location: mumbai
Posts: 405
Thanked: 4 Times
Default

hey psycho! big fan of your work..!
its been about 2000 kms since the last service...

@ anurag: as for fuel i filled it from the same pump i usually fill up..

Last edited by wildchild4lyfe : 15th December 2009 at 11:31.
wildchild4lyfe is offline   Reply With Quote
Old 15th December 2009, 12:10   #8
Senior - BHPian
 
Psycho's Avatar
 
Join Date: Jul 2004
Location: Bangalore
Posts: 1,042
Thanked: 95 Times
Default

Quote:
Originally Posted by wildchild4lyfe View Post
hey psycho! big fan of your work..!
its been about 2000 kms since the last service...

@ anurag: as for fuel i filled it from the same pump i usually fill up..
So you are not sure when it was last changed, in this scenario please take it to a mech and ask him to check the fuel filter for clogging.
Psycho is offline   Reply With Quote
Old 15th December 2009, 12:15   #9
BHPian
 
wildchild4lyfe's Avatar
 
Join Date: Nov 2009
Location: mumbai
Posts: 405
Thanked: 4 Times
Default

yes sir..!

a lil OT: hey Psycho do you see potential in the aveo?

its a 1.4 so it would run in the 1150-1450 catagory..
right now im running a FFE and a K&N conical.
its ported & polished by Mahesh from Bombay.

it is the only DOHC in the class and its a stock 94 bhp. a little on the heavy side but ill totally strip it down.
what according to you should be the next mod?
i want to keep it in the street stock catagory.
so yes im guessing an ECU?
anything else?
wildchild4lyfe is offline   Reply With Quote
Old 15th December 2009, 14:57   #10
Senior - BHPian
 
Psycho's Avatar
 
Join Date: Jul 2004
Location: Bangalore
Posts: 1,042
Thanked: 95 Times
Default

Quote:
Originally Posted by wildchild4lyfe View Post
yes sir..!

a lil OT: hey Psycho do you see potential in the aveo?

its a 1.4 so it would run in the 1150-1450 catagory..
right now im running a FFE and a K&N conical.
its ported & polished by Mahesh from Bombay.

it is the only DOHC in the class and its a stock 94 bhp. a little on the heavy side but ill totally strip it down.
what according to you should be the next mod?
i want to keep it in the street stock catagory.
so yes im guessing an ECU?
anything else?
I have never worked with this engine before so I am not going to be able to tell you for sure. And yes you are right an ECU and maybe a cam am assuming the aim is just for drags and street.
Psycho is offline   Reply With Quote
Old 15th December 2009, 15:51   #11
BHPian
 
wildchild4lyfe's Avatar
 
Join Date: Nov 2009
Location: mumbai
Posts: 405
Thanked: 4 Times
Default

thanks bud..! but with a cam setup i would run in the pro stock catagory. i wanna stay street stock..
i think the RD would be the next step.
wildchild4lyfe is offline   Reply With Quote
Old 16th December 2009, 17:50   #12
BHPian
 
s3va's Avatar
 
Join Date: Jun 2009
Location: Dubai
Posts: 646
Thanked: 3 Times
Default

wild,

Did you fix the issue ? If Yes, what was the issue ?
s3va is offline   Reply With Quote
Old 17th December 2009, 09:43   #13
BHPian
 
wildchild4lyfe's Avatar
 
Join Date: Nov 2009
Location: mumbai
Posts: 405
Thanked: 4 Times
Default

i got the plugs replaced cz i was running rich..but the probs still there.. i think its the ECM..i think ill take it to the service centre and get a full check..fingers crossed..right now the cars just farting around..!
wildchild4lyfe is offline   Reply With Quote
Old 23rd December 2009, 09:53   #14
BHPian
 
wildchild4lyfe's Avatar
 
Join Date: Nov 2009
Location: mumbai
Posts: 405
Thanked: 4 Times
Default

got everything checked...finally i think its the idle sensor..!
do any of you guys know how much it should cost?
wildchild4lyfe is offline   Reply With Quote
Old 23rd December 2009, 16:56   #15
Senior - BHPian
 
pranavt's Avatar
 
Join Date: May 2008
Location: Mumbai
Posts: 1,628
Thanked: 272 Times
Default

Plugs won't make your car run leaner or richer, they will just tell you if it's running rich or lean or detonating/knocking. Do you have the part number for the idle valve? Will be 5 times cheaper if you order it from outside India.
pranavt is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Stalling Problem rkkoul Technical Stuff 35 5th May 2016 13:30
Volvo recalling 7,000 diesel cars (including S60 & XC60) for engine stalling problem cbatrody The International Automotive Scene 0 21st February 2016 19:59
Engine stalling at low revs / idle kaushik_s Technical Stuff 37 4th March 2014 16:24
Santro LPG - Engine Stalling in 2nd & 3rd Gear Foxbat Technical Stuff 5 31st December 2012 07:45
Engine stalling at low speeds in my Fiat Grande Punto 1.2 E motor spirit Technical Stuff 20 7th February 2011 19:43


All times are GMT +5.5. The time now is 13:50.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks