Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 19th September 2005, 14:39   #16
BHPian
 
satan_crazy's Avatar
 
Join Date: Jul 2005
Location: Bangalore
Posts: 129
Thanked: 0 Times
Default

Quote:
Originally Posted by Jaggu
sure its not ur shoes
LOL! no man, not the shoes ... tried different shoes
satan_crazy is offline   Reply With Quote
Old 19th September 2005, 14:55   #17
BHPian
 
Harrie's Avatar
 
Join Date: Feb 2005
Location: KA 03, KL 12, TN 38
Posts: 699
Thanked: 20 Times
Default

Did you lift the mats and check if there is a mouse or something with its tail stuck in the clutch pedal?

Just kiddin... What shaft is it? Did yuo try changing the clutch cable? Ask the mechanic to use a different cable and see how it goes.
Harrie is offline   Reply With Quote
Old 19th September 2005, 15:04   #18
BANNED
 
dadudeonfire's Avatar
 
Join Date: May 2005
Location: mumbai - bandra
Posts: 367
Thanked: Once
Default

what car do you drive dude???
dadudeonfire is offline   Reply With Quote
Old 19th September 2005, 16:07   #19
Senior - BHPian
 
revtech's Avatar
 
Join Date: Nov 2004
Location: Bombay
Posts: 1,988
Thanked: 35 Times
Default

Quote:
Originally Posted by dadudeonfire
what car do u drive dude

Quote:
Originally Posted by satan_crazy
drive a baleno ... and she is fairly new too ... less than 2 months old
MB MARUTI BALENO not mercedes benz


Rev
revtech is offline   Reply With Quote
Old 19th September 2005, 16:15   #20
BANNED
 
dadudeonfire's Avatar
 
Join Date: May 2005
Location: mumbai - bandra
Posts: 367
Thanked: Once
Default

this sound usually comes from the clutch in the rainy season..
dadudeonfire is offline   Reply With Quote
Old 19th September 2005, 18:22   #21
BHPian
 
satan_crazy's Avatar
 
Join Date: Jul 2005
Location: Bangalore
Posts: 129
Thanked: 0 Times
Default

Quote:
Originally Posted by Harrie
What shaft is it? Did yuo try changing the clutch cable? Ask the mechanic to use a different cable and see how it goes.
no clue what shaft :( ... the works manager said that the clutch cable is fine ... just that the shaft has be polished ... no clue beyond this ... and its not like it squeaks ... its like some kinda friction at the last couple of inches when u press the clutch and it doesn't happen all the time ... very difficult to replicate the problem
satan_crazy is offline   Reply With Quote
Old 19th September 2005, 18:24   #22
BHPian
 
satan_crazy's Avatar
 
Join Date: Jul 2005
Location: Bangalore
Posts: 129
Thanked: 0 Times
Default

Quote:
Originally Posted by dadudeonfire
this sound usually comes from the clutch in the rainy season..
i think i can live with the sound till the end of the rainy season ... but its the friction thing that is irritating.
satan_crazy is offline   Reply With Quote
Old 9th February 2006, 21:49   #23
Senior - BHPian
 
humyum's Avatar
 
Join Date: Feb 2006
Location: Leicester/Mumbai
Posts: 2,306
Thanked: 2,188 Times
Default

The clutch sound that u are hearing is from the clutch bearing ...get the clutch bearing and the flywheel bearing replaced..dont know how much it would cost for a baleno..it costed around 800 bucks for me ..for my maruti 800
humyum is online now   Reply With Quote
Old 9th February 2006, 23:28   #24
SLK
Senior - BHPian
 
SLK's Avatar
 
Join Date: Feb 2004
Location: DL XX XX XXXX
Posts: 1,290
Thanked: 185 Times
Default

2 month old car everything has to be under warranty!
Did the guy tell you, why did/ how does a brand new shaft go squeaky?
SLK is offline   Reply With Quote
Old 10th February 2006, 00:29   #25
Senior - BHPian
 
speedsatya's Avatar
 
Join Date: May 2004
Location: bangalore/manga
Posts: 3,161
Thanked: 706 Times
Default

write to maruti ...and get that entire thing replaced under warranty ...
speedsatya is online now   Reply With Quote
Old 10th February 2006, 04:43   #26
Team-BHP Support
 
.anshuman's Avatar
 
Join Date: Dec 2004
Location: Good-Gaon
Posts: 7,714
Thanked: 8,941 Times
Default

get the spring greased and you wont hear the sound again,i did the same in my accent.
.anshuman is offline   Reply With Quote
Old 31st May 2009, 22:15   #27
Senior - BHPian
 
sumeethaldankar's Avatar
 
Join Date: May 2007
Location: Mumbai
Posts: 2,673
Thanked: 1,022 Times
Default Squeaking sound from 800's new clutch cable

Hi guys,
I had the clutch cable replaced on my '97 800 as a preventive maintenance around 3 months ago from Sai Service (MASS,Andheri).
I drove the car in some heavy traffic conditions last couple of days and when i reached home today ,found the clutch pedal giving a really irritating squeaky sound upon being released.
Now this is a brand new MGP cable which is just 3 months old and am wondering whats the issue with the sound.I mean is it of any case for concern to me or should i get it lubricated and forget it.Any chance of the sound coming because of improper installation.
Let me know.

thanks
sumeethaldankar is offline   Reply With Quote
Old 31st May 2009, 22:36   #28
BHPian
 
Join Date: Apr 2009
Location: Seattle
Posts: 573
Thanked: 49 Times
Default

Quote:
Originally Posted by sumeethaldankar View Post
Hi guys,
Now this is a brand new MGP cable which is just 3 months old and am wondering whats the issue with the sound.I mean is it of any case for concern to me or should i get it lubricated and forget it.Any chance of the sound coming because of improper installation.
The sound you describe seems to be from the clutch pedal itself and not the cable. To fix it, the hinge for the clutch pedal needs to be cleaned and lubricated (by dismantling it) - oiling it externally will not help.

MASS would have not bothered with that unless specifically instructed.
CrackedHead is offline   Reply With Quote
Old 31st May 2009, 23:42   #29
Senior - BHPian
 
Join Date: Sep 2006
Location: zxc
Posts: 3,394
Thanked: 658 Times
Default

There is a quick fix. no need to dissassemble the peddle.

Dude you will need a can of WD40 or Zorik 88. and spray it on the springs and hinges on the cable.
SirAlec is offline   Reply With Quote
Old 1st June 2009, 00:04   #30
BHPian
 
ankitahuja's Avatar
 
Join Date: Oct 2006
Location: Gurgaon & Delhi
Posts: 887
Thanked: 46 Times
Default

I recently got the clutch cable of my OHC replaced about 700kms back. The clutch is very squeaky, and it is quite irritating.

I was told mechanically, everything is OK with the clutch. I will try to use WD40 and see if the noise goes away. Any pointers where all/exactly should I spray?
ankitahuja is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Squeaking noise - What could it be? namit Technical Stuff 23 21st February 2014 11:42
Belt squeaking noise even after replacement rajivanoj Technical Stuff 24 28th January 2014 06:27
My NHC clutch making a squeaking noise on release battada Technical Stuff 15 29th November 2009 20:10
New Alto : Suspension squeaking! gpa Technical Stuff 0 8th August 2008 10:07


All times are GMT +5.5. The time now is 12:51.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks