Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 11th February 2010, 14:45   #1
BHPian
 
mustang89's Avatar
 
Join Date: Feb 2009
Location: new delhi
Posts: 348
Thanked: 0 Times
Default Smoke and Power Loss Problem with Swift Vdi

hey guys,
im posting this on behalf of my cousin who has a swift vdi type 2,done about 9000kms.Recently he has been having lot of problems with his car.The car doesnt go beyond 100 on 5th gear and it produces a hell lot of smoke.When I checked it with him I felt it to be white smoke and it had a hell of dirty burning smell.
The strange part is that it doesnt happen always.Sometimes the car behaves just normal and it pulls cleanly till 130-140,but sometimes there is this smoke problem and no effect of pedal pressure on acceleration.he has to reduce speed to 60-70 in 4th and then on accelerating again it acts just fine..
Although I felt it to be white smoke my bro feels that he has also seen black smoke at times.
The last service was done at 5k km.I am afraid that it might be some turbo problem.Please help
MODSlease move it to the appropriate section if wrong.
mustang89 is offline   Reply With Quote
Old 11th February 2010, 15:00   #2
BHPian
 
Join Date: Apr 2009
Location: Seattle
Posts: 573
Thanked: 49 Times
Default

Looks like a case of overfilling the engine oil. Are you sure the smoke is white ?
CrackedHead is offline   Reply With Quote
Old 11th February 2010, 15:13   #3
BHPian
 
mustang89's Avatar
 
Join Date: Feb 2009
Location: new delhi
Posts: 348
Thanked: 0 Times
Default

i felt it was white..cousin has seen black smoke also..problem is that its not the kind of smoke when you push a diesel car..its hell lot of smoke..all you see in rear view mirror is smoke..

Last edited by mustang89 : 11th February 2010 at 15:15.
mustang89 is offline   Reply With Quote
Old 11th February 2010, 15:15   #4
Senior - BHPian
 
extreme_torque's Avatar
 
Join Date: Feb 2005
Location: Melbourne
Posts: 3,546
Thanked: 1,317 Times
Default

Smoke and diesel smell indicates a turbo failure. It can also be a case of overfilled engine oil going by how competent our service centers are. Go to the A S S and ask them to have a look.
extreme_torque is offline   Reply With Quote
Old 11th February 2010, 15:19   #5
BHPian
 
mustang89's Avatar
 
Join Date: Feb 2009
Location: new delhi
Posts: 348
Thanked: 0 Times
Default

he always go to A.S.S.they couldnt spot a problem.thats why we are worried..can you suggest some good A.S.S.He goes to RANA in okhla.
mustang89 is offline   Reply With Quote
Old 11th February 2010, 15:38   #6
BHPian
 
mustang89's Avatar
 
Join Date: Feb 2009
Location: new delhi
Posts: 348
Thanked: 0 Times
Default

guys please help...
mustang89 is offline   Reply With Quote
Old 11th February 2010, 22:27   #7
BHPian
 
live2drive's Avatar
 
Join Date: Oct 2008
Location: New Delhi
Posts: 525
Thanked: 25 Times
Default

Turbo is suspect. Did you check the engine oil level? Does the engine check light glow?

Also, get the fuel filter checked. It could be clogged due to adulteration in fuel.
live2drive is offline   Reply With Quote
Old 11th February 2010, 23:03   #8
BHPian
 
mustang89's Avatar
 
Join Date: Feb 2009
Location: new delhi
Posts: 348
Thanked: 0 Times
Default

engine check light is which one?
sorry for stupid question.
mustang89 is offline   Reply With Quote
Old 11th February 2010, 23:43   #9
BHPian
 
mustang89's Avatar
 
Join Date: Feb 2009
Location: new delhi
Posts: 348
Thanked: 0 Times
Default

no engine check light doesnt glow.
mustang89 is offline   Reply With Quote
Old 16th February 2010, 17:27   #10
BHPian
 
username's Avatar
 
Join Date: Nov 2008
Location: Chennai
Posts: 78
Thanked: 10 Times
Default

Quote:
Originally Posted by mustang89 View Post
hey guys,
im posting this on behalf of my cousin who has a swift vdi type 2,done about 9000kms.Recently he has been having lot of problems with his car.The car doesnt go beyond 100 on 5th gear and it produces a hell lot of smoke.When I checked it with him I felt it to be white smoke and it had a hell of dirty burning smell.
The strange part is that it doesnt happen always.Sometimes the car behaves just normal and it pulls cleanly till 130-140,but sometimes there is this smoke problem and no effect of pedal pressure on acceleration.he has to reduce speed to 60-70 in 4th and then on accelerating again it acts just fine..
Although I felt it to be white smoke my bro feels that he has also seen black smoke at times.
The last service was done at 5k km.I am afraid that it might be some turbo problem.Please help
MODSlease move it to the appropriate section if wrong.

Hi,
Even i had this problem sometime back. But, now kind of figured out the reason. Visit the thread: http://www.team-bhp.com/forum/techni...ml#post1658363 (New Swift Diesel engine problem)

My problem - more detailed: http://www.team-bhp.com/forum/techni...ml#post1450627 (Swift VDi - White Smoke)

Let me know if this solves the problem.

Last edited by username : 16th February 2010 at 17:29.
username is offline   Reply With Quote
Old 16th February 2010, 18:40   #11
Senior - BHPian
 
greenhorn's Avatar
 
Join Date: Apr 2007
Location: TN-14
Posts: 6,837
Thanked: 1,312 Times
Default

if this is a turbo issue,
http://www.team-bhp.com/forum/techni...on-thread.html (Swift DDIS Turbo issues: Report & Resolution thread)
greenhorn is online now   Reply With Quote
Old 16th February 2010, 20:43   #12
BHPian
 
mustang89's Avatar
 
Join Date: Feb 2009
Location: new delhi
Posts: 348
Thanked: 0 Times
Default

going with my cousin to MASS tomorrow.lets see how it turns up.fingers crossed.he wants to change his engine oil also,should we go in for synth right away since the car has done only about 10k kms.
mustang89 is offline   Reply With Quote
Old 16th February 2010, 21:57   #13
jav
BHPian
 
Join Date: Apr 2007
Location: Bangalore
Posts: 194
Thanked: 6 Times
Default

ask them to check the turbo hoses first, i feel its mostly boost air leakage, as for synth i am not a big fan of synthetic oils but if you want to switch to synth its fine since its almost nearing 10k kms so no problems about that
jav is online now   Reply With Quote
Old 24th February 2010, 21:31   #14
BHPian
 
mustang89's Avatar
 
Join Date: Feb 2009
Location: new delhi
Posts: 348
Thanked: 0 Times
Default

I went to the service center last week,the turbo hoses and the intercooler was almost draining with engine oil,got them cleaned and when we went for a test drive after that the turbo kick was almost completely gone,the car was behaving as petrol with almost linear pickup.it was highly dissapointing as the maruti servicemen had no idea as to what the problem was and further accused us of not taking care of our car properly.we were accussed of over revving the car due to which the overflow occured.This highly angered me to which I was asked to stop giving inputs.This frustrated my cousin and we guys had a big row with the MASS guys and with the General Manager.They ordered the turbo and common rail which they surprisingly didnt have in stock.My cousin is going again to get the turbo and the rail changed tomorrow.I still feel that it isnt a problem with the common rail,more so of the turbo or EGR.But as it goes MASS guys dont know what it exactly is and they want to go by hit and trial method.
Well the sad story doesnt end here,another cousin of mine also had the same problems next day with his vdi after getting his 10k kms service.I have been seriously dissapointed with the Maruti Service and I have doubts about their handling of diesel engines from now.
Guys please help if I can get my cousins car serviced elsewhere.
The service guys surprisingly didnt know how to use the tech2 and to what all information it shows or what are the stock readings of boost pressure etc.

Last edited by mustang89 : 24th February 2010 at 21:35. Reason: Spelling mistakes
mustang89 is offline   Reply With Quote
Old 24th February 2010, 21:40   #15
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,746
Thanked: 7,449 Times
Default

Definitely a turbo spewing oil, replace it and do find a better A>S>S after this. Wouldn't be surprised if they filled excess oil in the first place, resulting in this blow up of oil seals.
Jaggu is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Swift VDi - White Smoke username Technical Stuff 9 26th November 2016 03:45
Loss in power at low RPM Sri_009 Technical Stuff 11 3rd June 2010 15:55
Santro Xing XP power loss? wantarangerover Technical Stuff 8 8th April 2008 17:01
Car loosing speed too quickly uphill... and power loss amu1983 Technical Stuff 10 27th June 2007 19:09
will installing a turbo charger Compensate power loss from CNG Fl|rty Modifications & Accessories 19 10th September 2006 03:15


All times are GMT +5.5. The time now is 01:27.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks