Go Back   Team-BHP > Under the Hood > Technical Stuff


Reply
 
Thread Tools Search this Thread
Old 15th March 2010, 01:00   #1
Newbie
 
kvdeep's Avatar
 
Join Date: Nov 2007
Location: Cochin
Posts: 7
Thanked: 0 Times
Default AC Problem / 1.1 Palio Stile SLE

Dear TBHPians,

The AC in my 1.1 Stile SLE has been behaving erratically. The trouble is with switching on the a/c, Sometimes there is a delay in starting the cooling after I press the a/c button. Sometimes it starts immediately, Sometimes it will start if I give a hard push on the switch / keep it pressed for a while.

However once it starts it works absolutely fine till I switch it off and there is no noticeable reduction in cooling etc. I usually drive with the a/c on and switch on / off while overtaking / on slopes as required, also, the a/c is reasonably powerful so I frequently switch it on / off to regulate the temperature also.

What could be wrong? Is it possible that the switch has developed some trouble due to frequent use or could there be something wrong with the temperature sensor?

Also, to replace the switch (if required) is it necessary to open the dash?

Did any of you face a similar problem?


Thanks and Regards,
Deepak / Palio Stile SLE / Infinity Black / 35K km in 15 months and counting :-)

Last edited by Jaggu : 15th March 2010 at 10:29. Reason: Removing [Font] tags, please avoid copy paste from external fornt editors, also Preview before Submitting posts. thanks
kvdeep is offline   Reply With Quote
Old 15th March 2010, 12:38   #2
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,752
Thanked: 7,478 Times
Default

Take it to a good AC mech or dealer and get it checked, as you said it might be the switch then its an easy job. If not you will need to get the system for any lose connections, low gas pressure etc
Jaggu is offline   Reply With Quote
Old 15th March 2010, 20:30   #3
Senior - BHPian
 
gemithomas's Avatar
 
Join Date: Jan 2007
Location: Trivandrum
Posts: 2,364
Thanked: 136 Times
Default

It should be a loose connection in the switch. You dont have to remove the whole dash. The central console which houses all switches and a/c vents can be removed AFAIK
gemithomas is offline   Reply With Quote
Old 15th March 2010, 21:20   #4
BHPian
 
Otto's Avatar
 
Join Date: Feb 2010
Location: Navi Mumbai
Posts: 52
Thanked: Once
Default

hmmm, If I'm not mistaken, isn't the switch self-illuminating? meaning that whenever you switch on the A/C, isn't there an LED built in to indicate that it's on?
there should be some sort of indication that your A/C is on - therefore should you have a problem with the switch then this lamp will tell you whether your A/C is infact on or off.
Otto is offline   Reply With Quote
Old 15th March 2010, 21:24   #5
Team-BHP Support
 
Jaggu's Avatar
 
Join Date: May 2004
Location: Bangalore
Posts: 17,752
Thanked: 7,478 Times
Default

If its a coupler issue then light may glow without ac kicking in, same case when gas is low. So that might not be a good indicator, but yes to see if switch is working fine it might be.
Jaggu is offline   Reply With Quote
Old 2nd April 2010, 11:58   #6
Newbie
 
kvdeep's Avatar
 
Join Date: Nov 2007
Location: Cochin
Posts: 7
Thanked: 0 Times
Default

I got it checked, but what the a/c mechanic was telling was that it was a faulty sensor...but funny,after that day, it has been working fine.. :-)

Thanks...Deepak / Fiat Palio Stile SLE
kvdeep is offline   Reply With Quote
Old 30th June 2010, 12:10   #7
Senior - BHPian
 
bottle's Avatar
 
Join Date: Sep 2006
Location: Chennai
Posts: 1,489
Thanked: 133 Times
Default

The a/c of my 1.2 palio doesnt seem to be working.. there is a hissing sound along with warm air. A nearby mechanic said that it could be because of a faulty cooling coil. Going to get it checked out properly so was wondering if there was anything I should be aware off before going to TASS
bottle is offline   Reply With Quote
Old 4th May 2013, 08:14   #8
BHPian
 
chakri400's Avatar
 
Join Date: Dec 2007
Location: Bangalore
Posts: 179
Thanked: 99 Times
Default

Quote:
Originally Posted by bottle View Post
The a/c of my 1.2 palio doesnt seem to be working.. there is a hissing sound along with warm air. A nearby mechanic said that it could be because of a faulty cooling coil. Going to get it checked out properly so was wondering if there was anything I should be aware off before going to TASS
Bottle, this is exactly the same problem I am seeing with my palio stile. Is this fixed for you? What was the problem? What fixed it? Who did you go to?
Summer has been difficult with this non functional ac
chakri400 is offline   Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search


Similar Threads
Thread Thread Starter Forum Replies Last Post
Magnesium Grey Stile 1.1 SLE, now Delivered yatin Test-Drives & Initial Ownership Reports 69 13th September 2017 11:07
Fiat Palio Stile 1.6 Sport - Strut Guide Problem (Front Suspension) sans_80 Technical Stuff 1 1st May 2010 14:29
Strange problem with Palio 1.6 stile vidushak Technical Stuff 10 17th May 2009 23:18
Palio Stile 1.6 or Palio Stile 1.3MJD? rudrah Hatchbacks 47 5th May 2008 03:45


All times are GMT +5.5. The time now is 13:40.

Copyright 2000 - 2017, Team-BHP.com
Proudly powered by E2E Networks